Sign in to follow this  
Guest

How to run ACARS client and ASN with FSX-SE

Recommended Posts

Hi There,

 

This is my first post.

 

I need help with SimConnect. (Did I spell that correctly? :wink:)

I want to run my ACARS client and ActiveSkyNext on my slave (client) computer while I run FSX SE on my main computer (server). I have downloaded and registered a legitimate copy of FSUIPC and WideFS and it works well with the ACARS client. However, ASN requires SimConnect, which, after reading about setting it up on the internet and watching a video by FroogleSim (he's a great youtube guy) who had a tutorial about how to setup "The bear called SimConnect" I though it wouldn't be too challenging, however I was WRONG! (I am a Mac user and a X-Plane native and my experiences with Windows and FSX have not been good with countless problems... I am not starting a sim or OS war) FSUIPC and WideFS were easy but Oh My GOSH! SimConnect is EVIL!!! :excl:

 

Ok, now I'll explain my problem...

 

I have installed all the versions of SimConnect (RTM - SP1 - XPACK) in my FSX SE root folder: SDK> ​core utilities kit> lib and SDK> ​core utilities kit> legacy interfaces on my client and my server computer. And I have all the IPv4 Addresses on my computers correctly listed and I have the required files, copied perfectly. However, when I start up FSX SE, I cannot load PMDG Aircraft. (The very reason I bought FSX ironically :smile: along with Concorde) When I attempt to load a PMDG airplane (I only have the 737-800/900 NGX and 777-200LRF/300ER Expansion) it gets stuck on loading the plane and FSX SE freezes but doesn't crash or anything. Also, ASN says waiting for simulator although the sim is open on my main computer. I have consulted the ASN manual ( a rare occasion for me :wink:) and have found that this problem is related to not correctly installing SimConnect. (Since scrapping everything simconnect that I have added, PMDG planes work perfectly...)

 

Again, my hope is to only have FSX SE on my main machine running while everything else is on my client machine.

 

If someone can help than this is much appreciated. (I have contacted ASN support but they cannot help with SimConnect)

 

Thanks,

 

Boeing777300.

 

Ironically, I do not know how to start a new topic so I am replying to this forum for help.

Edited by Guest

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Zach,

 

The message "Waiting for Simulator" means you haven't followed the steps correctly to install SimConnect. My advice would be to remove Simconnect from your Client and Server pc then start again follow the instructions preciously this is what I had to do several times until I realized I'd done the IP addresses wrong.

 

Also from the sounds of you have tried install SimConnect without even following the instructions just do the above, I appreciate it can be very frustrating as I found myself and I'm not that good with computers .

 

Regarding your 2nd issue as you can't start PMDG Aircraft I'm not following you and am confused as to what you exactly mean??

 

Thanks

 

Jason

Share this post


Link to post
Share on other sites

Hi Zach,

 

This is how I setup my flight deck via simconnect.

 

===================
Configuring Simconnect
===================

1.Folders to share:

    A. D:\P3D or FSX (change the path statement to reflect your path)

    B. C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D (change the path statement to reflect your path)

    C. C:\Users\Mike\My Documents\Prepar3D Files (change the path statement to reflect your path)

-----------------------------------------------------------------------------------------
The folders shown above should be shared with read/write permissions
-----------------------------------------------------------------------------------------

2. Your P3D Computer is the server computer (Copy WideServer.dll & WideServer.ini into P3D's "MODULES" folder).

3. Your networked computer is the client.

4. Your firewall software must be configured to allow SimConnect communications on port 500,
   this includes windows firewall and applies to all computers, both SERVER and CLIENT(s).

5. There are two files which must be configured on the server, they are:

    A. SimConnect.xml  |  Location - C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D (change the path statement to reflect your path)
    B. SimConnect.ini  |  Location - C:\Users\Mike\My Documents\Prepar3D Files (change the path statement to reflect your path)

----------------------------------------------------------------------------------------------------------------------------------------------------------------------    
NOTE: For use with Prepar3D:  You MUST copy the fsx.cfg file into your Clinet's C:\Users\Mike\My Documents\Prepar3d Files Folder
----------------------------------------------------------------------------------------------------------------------------------------------------------------------

--------------------
SimConnect.xml
--------------------
<?xml version="1.0" encoding="Windows-1252" ?>
  <SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
  <Disabled>False</Disabled>
  <Protocol>IPv4</Protocol>
  <Scope>global</Scope>
  <Address>192.168.1.100</Address>
  <MaxClients>64</MaxClients>
  <Port>500</Port>
  <MaxRecvSize>4096</MaxRecvSize>
  <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
  <Disabled>False</Disabled>
  <Protocol>Auto</Protocol>
  <Scope>local</Scope>
  </SimConnect.Comm>
  </SimBase.Document>


-------------------
SimConnect.ini
-------------------
[simConnect]
level=verbose
console=0
;RedirectStdOutToConsole=1
;OutputDebugString=1
;file=c:\simconnect%03u.log
;file_next_index=0
;file_max_index=9


10. Copy the simconnect.msi to all client computers and run the file.

11. Copy the SimConnect.cfg file into the following folder on all client computers.

    A. C:\Users\Michael\My Documents (change the path statement to reflect your path)

--------------------
SimConnect.cfg
--------------------
[simConnect]
Protocol=IPv4
Address=192.168.1.100
Port=500
MaxReceiveSize=4096
DisableNagle=0

 

Also remember to change the addresses to reflect your system and drop to command prompt to ping the addresses, make sure you have a connection with no packet loss.

 

Some additional info on Sim-Connect: http://www.codelegend.com/forums/viewtopic.php?f=2&t=634

 

Hope you find this helpful.

Share this post


Link to post
Share on other sites

Thanks so much!!! I'll try that asap and get back to you withy the hopefully successful results!

Zach,

 

The message "Waiting for Simulator" means you haven't followed the steps correctly to install SimConnect. My advice would be to remove Simconnect from your Client and Server pc then start again follow the instructions preciously this is what I had to do several times until I realized I'd done the IP addresses wrong.

 

Also from the sounds of you have tried install SimConnect without even following the instructions just do the above, I appreciate it can be very frustrating as I found myself and I'm not that good with computers .

 

Regarding your 2nd issue as you can't start PMDG Aircraft I'm not following you and am confused as to what you exactly mean??

 

Thanks

 

Jason

My issue with the pmdg problem is as follows, when I had the simconnect files on my computers ( which I have now killed and fixed the problem...) three plane wouldn't load properly... the screens were blank and I didn't get that 17 sec loading bar...

Hi Zach,

 

This is how I setup my flight deck via simconnect.

 

===================

Configuring Simconnect

===================

1.Folders to share:

A. D:\P3D or FSX (change the path statement to reflect your path)

B. C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D (change the path statement to reflect your path)

C. C:\Users\Mike\My Documents\Prepar3D Files (change the path statement to reflect your path)

-----------------------------------------------------------------------------------------

The folders shown above should be shared with read/write permissions

-----------------------------------------------------------------------------------------

2. Your P3D Computer is the server computer (Copy WideServer.dll & WideServer.ini into P3D's "MODULES" folder).

3. Your networked computer is the client.

4. Your firewall software must be configured to allow SimConnect communications on port 500,

this includes windows firewall and applies to all computers, both SERVER and CLIENT(s).

5. There are two files which must be configured on the server, they are:

A. SimConnect.xml | Location - C:\Users\Mike\AppData\Roaming\Lockheed Martin\Prepar3D (change the path statement to reflect your path)

B. SimConnect.ini | Location - C:\Users\Mike\My Documents\Prepar3D Files (change the path statement to reflect your path)

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

NOTE: For use with Prepar3D: You MUST copy the fsx.cfg file into your Clinet's C:\Users\Mike\My Documents\Prepar3d Files Folder

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

--------------------

SimConnect.xml

--------------------

<?xml version="1.0" encoding="Windows-1252" ?>

<SimBase.Document Type="SimConnect" version="1,0">

<Descr>SimConnect</Descr>

<Filename>SimConnect.xml</Filename>

<Disabled>False</Disabled>

<SimConnect.Comm>

<Disabled>False</Disabled>

<Protocol>IPv4</Protocol>

<Scope>global</Scope>

<Address>192.168.1.100</Address>

<MaxClients>64</MaxClients>

<Port>500</Port>

<MaxRecvSize>4096</MaxRecvSize>

<DisableNagle>False</DisableNagle>

</SimConnect.Comm>

<SimConnect.Comm>

<Disabled>False</Disabled>

<Protocol>Auto</Protocol>

<Scope>local</Scope>

</SimConnect.Comm>

</SimBase.Document>

-------------------

SimConnect.ini

-------------------

[simConnect]

level=verbose

console=0

;RedirectStdOutToConsole=1

;OutputDebugString=1

;file=c:\simconnect%03u.log

;file_next_index=0

;file_max_index=9

10. Copy the simconnect.msi to all client computers and run the file.

11. Copy the SimConnect.cfg file into the following folder on all client computers.

A. C:\Users\Michael\My Documents (change the path statement to reflect your path)

--------------------

SimConnect.cfg

--------------------

[simConnect]

Protocol=IPv4

Address=192.168.1.100

Port=500

MaxReceiveSize=4096

DisableNagle=0

 

Also remember to change the addresses to reflect your system and drop to command prompt to ping the addresses, make sure you have a connection with no packet loss.

 

Some additional info on Sim-Connect: http://www.codelegend.com/forums/viewtopic.php?f=2&t=634

 

Hope you find this helpful.

You're awesome, thanks so much!!! I just wanted to know if I put the Necessary files into documents -> Flight Sim x or flight Sim X steam and what one of these to share? ( I use steam at the moment, that will change next year when I move to P3D and spend a fortune renewing my addons...)

Share this post


Link to post
Share on other sites

Hi Zach,

 

I don't use stream, not sure if stream is a dummy folder for stream itself or if they reworked something in the FSX-Stream edition of FSX to use this folder... I would imagine the files would go into the  documents/fsx  sub-folder and you would share this same folder. You could also copy the files into the stream sub-folder and share that as well.

 

Not sure about the other two aircraft... But before I built my flightdeck, I spent just about 90+% of my time in the PMDG 737NGX and had no problems with networking... With that said, I never used the stream edition of FSX.

 

What is in your stream folder?.

Share this post


Link to post
Share on other sites

All works!!! Uninstalled SimConnect and reinstalled it - checked my IPv4 address and opened port 500!!! Thanks so much to both of you!!! The pmdg issue has resolved itself as well!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this