Sign in to follow this  
mikealpha

new user - FSX/SE crash

Recommended Posts

Hello,

 

I installed FSX Steam this morning, checked if DX 10 Preview is working and purchased the DX10 Scenery Fixer.

Now FSX with DX10 active doesn't even start anymore, with the following error :

 

Problem signature:
  Problem Event Name:    BEX
  Application Name:    fsx.exe
  Application Version:    10.0.62615.0
  Application Timestamp:    559f9a9a
  Fault Module Name:    dxgi.dll
  Fault Module Version:    6.3.9600.17415
  Fault Module Timestamp:    54503ca0
  Exception Offset:    00001ab0
  Exception Code:    c0000005
  Exception Data:    00000008
  OS Version:    6.3.9600.2.0.0.768.101
  Locale ID:    1033
  Additional Information 1:    b608
  Additional Information 2:    b6085393931ae17a255d31b1b882afe3
  Additional Information 3:    7013
  Additional Information 4:    701370909d18825bd2d5fb9469bd6ca3

 

Other installed Addons : FSLabs A320, AS Next, FTXGlobal

 

I used the profile as recommended in the FSLabs forum (not sure if it can be downloaded with being logged in there) :

http://forums.flightsimlabs.com/applications/core/interface/file/attachment.php?id=2669

 

I tried to get info in the manual and at google, but to no avail so far. Any hints what I should check ?

 

Mike
 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Please disregard. It`s a problem with FSLabs Spotlight. Uninstalling this solves the problem.

 

Mike

Share this post


Link to post
Share on other sites

Thanks for posting that, I was typing a long reply which I can now delete!!

Share this post


Link to post
Share on other sites

HI I have exaclty the same problem but with every airport and every plane. As soon as i click on fly the flight load and FSX-SE crash. Uninstalling spotlight by FSlabs dont create problems with the plane about lightings? Ah ibought the DX10 Fixer today so first installation. I had al the crashes loading the Trike FSLAB PMDG All But the error is this

 

Process File Event Name Event Time User Name Exception Code Exception Offset Fault Module Name Fault Module Version Process Path Report File Size Report File Path

fsx.exe Stopped working 8/30/2016 3:37:27 AM dino 0xc0000005 0x81335e59 FSL_A32XX.dll_unloaded 0.0.0.0 D:\SteamLibrary\steamapps\common\FSX\fsx.exe 37,584 C:\Users\dino\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_fsx.exe_8bd86f68455927624fc5a1494cdcc2233653932_0d407257\Report.wer
 
With the new version of the fslab i had in the last 2 day 4 flights and never had problems and now after installing the DX FIX i have this module not loading even if i am selecting a different plane
 

 

Thanks

Share this post


Link to post
Share on other sites

 

The crash is in the fsl a32x code even if you are loading another aircraft so I suggest you ask on the fsl labs forum as they would be better placed than me to advise you. I am assuming that you haven't previously run in dx10 and that this error would have occurred in dx10 preview without the fixer.

Share this post


Link to post
Share on other sites

If you search on the fsl forums you will find that exact error described as trying to load another aircraft after using a320x without exiting and restarting fsx. So open a post there and see what they advise, there is also an updated version of fsl spotlights which was causing some issues.

Share this post


Link to post
Share on other sites

Hi there Steve, I have never run FSX in Direct X mode preview i d run it yesterday for the very firs time after installing the fix. WHat happened?  Well I nstalled the fix and i suppose i followed all the indications and set all like for manual, at least i think so, well i operated this way i had a flight with fslabs a320 from LICC to EGKK. I loaded the trike and selected LICC then the tirke is at parking gate and all crash immedialy from that time on it always crash. then i deceided to move away from FSX librry the feeware scenery of LICC thiking it was a problem of scenery but the result was exacly the same. So i decieded to set the flight from another airport , AS_Lipe. The trike was loaded there without problems then i changed the airport  to LICC switch off the trike. Select the FSLAB A320 all ok. I started the flight end the flight close the sim. reboot computer and then i deceided to keep on reading the manual of the fixer but FSX didnt even start anymore it freeze and i had a messaege that warned me to load AS Module i had to restart the sim. I decieded to regenerate the FSX.CFG and FSX started again set all and when load the flight always the same error. The panel of the trike appear for few seconds and FSX cloeeses. I deceided to Uninstall the fixer. I uninstlled the librry then ininstalled the DX10 fixer and delted the DXfixer.Dll from the fsx folder where there is the fsx.cfg. Reboot computer set nvidia like my previouse setting and again nothing always crash. Now i am wondering wht can cause the problem.

Share this post


Link to post
Share on other sites

Hi Alfredo.

 

I understand that its frustrating when something doesn't work - and it may perhaps seem that I am not interested but that isn't the case.

 

When you buy the fixer it says at the bottom of the page in bold letters

 

"Test that DX10 Preview works on your system before purchase."

 

The reason for this warning is to prevent the following scenario where a customer has a FSX system that hasn't run before in DX10 mode before and will crash if it does so because of an unresolved issue with an addon or their PC. (This is rare but does happen)

 

1) Customer buys the fixer

2) Customer switches FSX to Dx10 preview

3) FSX crashes as it doesn't work in DX10 preview because of the addon/PC issue

4) Customer uninstalls the fixer

5) FSX still crashes as the problem wasn't to do with the fixer

6) Customer associates problem with installing fixer and becomes convinced that the fixer broke their system

 

 

Testing before purchase will show the problem was there and prevent the fixer being blamed unfairly.

 

Failing to carry out this simple step is like stepping into an aircraft and taking off without any pre flight checks.

Most of the time it will be fine... but occasionally it ends badly.

 

The error that you posted about the crash states that the crash occurred in some code in a module called

 

FSL_A32XX.dll_unloaded

 

Which is supplied by FSL as part of the A32XX Note that this isn't an error as you think saying that the module is unloaded - this is a module called "FSL_A32XX.dll_unloaded" supplied by FSL that runs when you haven't loaded the A32XX but are using a different aircraft. I don't know why this exists but presumably there is a good reason.

 

So when FSX crashes it seems to be running FSL code. The actual error is 0005 which is usually an attempt to access invalid memory but could be another permission issue.

 

Since your crash is occurring within FSL code they are the best people to ask about it - I don't know the purpose of that module and I cannot help fix it for

Share this post


Link to post
Share on other sites

Hi Steve first thanks for your reply, Secndi didnt blame your software at alli just associated tht before installing i didnt have any CTD and as soon as i installed rebooted and launched i had them all the time. Third when i said i ever run in DX10 Preview mode i didt mean i never tried it . I meant that i never flew an entire fly with them on as once took off and on the groundi had some issues i didnt like at ll and for me was impossible to fly with ths graphic issues missing textured blury objects and soon but the sim started regularly. Now once i have disinstalled the library and the product is there any manual delete? or some entriesthat should be checked to delete? I will try to disinstall the FSlab as well install it again and download and install the new verion of spotlight that reading their forum seems to work as well then i will give another try.

 

Thanks

Share this post


Link to post
Share on other sites

There are no manual steps necessary at all.

 

When you first install the fixer  it doesn't change anything in your fsx system.

 

When you install the libraries it  first runs through a  checklist of known addons that can cause CTDs in FSX and aborts if it finds one- ENBSeries is an example.

 

Assuming everything looks ok (that it knows about)  it then

 

1) copies 4 libraries (dlls)  into your fsx system directory which are the run time code.

 

2) It changes a texture called bkg.bmp which is only used in DX10.  First creating a backup.

 

3)  It installs 6 effects, and takes a copy of an effect texture.

 

If you have selected the option DX10 Lights Package it also

 

4) takes a backup copy of the dozen of so effects used in aircraft nav lights  and installs new versions that work in DX10

 

If you have selected the option Dx10 Compatible effects it also

 

5) examines all the effects in your system to see if any would have issues in DX10 and if so makes a slight modification marking the files so that they can easily be restored

 

If you have selected the option Dx10 Compatible Reflections it

 

6)   takes a backup of the environment texture used for legacy aircraft  reflections which isn't DX10 compatible  and replaces it with   one that is.

 

7) deletes the DX10 shader cache  so the shaders are rebuilt

 

 

When you uninstall the libraries it reverses steps 1 -6 

 

It then deletes the DX10 shader cache. so the shaders are rebuilt as they were previously.

 

Provided that you don't run the uninstall libraries before  FSX has fully shutdown  (this is hard as it  requires defeating the check for FSX running in the controller) then this guarantees that your FSX system is restored exactly as it was.

 

 

Note that when you uninstall the fixer from control panel it will leave a few config files which assist customers who uninstall/reinstall to retain their settings.

Share this post


Link to post
Share on other sites

Hi steve thanks i report u back that all was caused by a usb port and the joystick assigned to the trike. When iloaded up the FSLAB 320 I used the trike and since i assignedthe axis thru FSUIPC it closed to desktop. After hoursi noticethat i always started with the trike so i tried a plane with axis still not assigned and all worked. Then I tried the trike and fail again. So i unplugged the usb and plugged it back and no issue anymoe. Anywaynow i have todo all again but i did this this time. I clicked on DX10 Previe the flight start i give power and thesim hang. I mean without ur fix installed. So now i dont know if i should try ur fix or not. Ithink i will try it again and then i will see and check. Any suggestion? 

 

Thanks For ur patiente and help

Share this post


Link to post
Share on other sites

Hi Steve i installed ur fix again and now i can say it is working, I only have two issues about the texture of FTX global that does not load properly like pics i attach and the tool tips in The NGX 737 are not Shown even if the tool tip function is ticked.

 

http://picpaste.com/DINO-PC-2016-sep-1-001-523eFh3f.jpg       http://picpaste.com/DINO-PC-2016-sep-1-002-k1aKt4o2.jpg      http://picpaste.com/DINO-PC-2016-sep-1-005-xCGjFGKA.jpg

 

 

thanks

Share this post


Link to post
Share on other sites

Hello

 

Yes I am afraid that tooltips do not work in dx10 full screen, Microsoft forgot to code that and it's not possible to fix it. If you switch to windowed mode they will appear. Some people use a windowed mode without the window surround - search for the dx10 how to guide on nzfsim which explains how to do this.

 

Re ftx global Is there a problem in the scenery order priority? Do you have the right global region selected in ftx central? There is no reason for a ground texture to display differently in dx10 or dx9. Orbx always receive a copy of the fixer and test with it. I would suggest (sorry if I sound like a broken record here) posting on the ftx forum and asking for their advice on this one.

Share this post


Link to post
Share on other sites

Well orbx is correctly installed and the library priority is as for manual in dx9 i never had this issue. I wonder if it can be a problem of Nvidia insptector settings poblems, but even so i swicthed from the profile of nvidia i downloaded from fslab to match the DX10 and the previouse i had when i run the sim in DX9 but the result is the same. Anyway i think that it is a slow down of loading texture  but sinc it is very slow i have those issue. I will try and search on ORBX forum and if i receive a possible solution i will post it here too in case someone else could need it. Last question, As weather engines i am using AS2016 and ASCA, as u know the last Weather engine By HIFI has their own effects for rain snow lightings colors of the sky clouds and s on and i was wondering if running it in DX10 there is any special setting to do.

 

Thanks Steve

Share this post


Link to post
Share on other sites

Well the solutio is to set the frame rate limit to 30 inside FSX and not unlimited inside FSX and set 30 in Nviidia Ispector.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this