Sign in to follow this  
captain420

Strange EZDok behavior when switching view from internal to external using hotkeys

Recommended Posts

Not sure if I notice this correctly, but the problem seems to exists only with the Aerosoft Airbus. When switching from internal to external views. For example when I am in EZdok's virtual cockpit view which I have assigned as SHIFT+F1, and then I switch to the external left wing view which I have set to SHIFT+F6. It will take my to the COCKPIT VIEW: OVERHEAD PANEL. So I hit SHIFT+F6 again and it will finally take me to EZDok's external left wing view which I have set. Not sure why it's behaving like this. 

 

Why does pressing SHIFT+F6 take me to COCKPIT VIEW: OVERHEAD PANEL? I don't have this hotkey set anywere. I'm wondering if this problem relates to the Aerosoft airbus only. Cause EZdok works fine on my other planes when switching between internal to external view and vice versa. I already went into my control settings to see if I have any keys binded to SHIFT+F6 and I don't. So why is SHIFT+F6 taking me to this strange "COCKPIT VIEW: OVERHEAD PANEL"? and how can I unbind it so that SHIFT+F6 will work with EZdok?

 

I went to my aerosoft airbus's aircraft.cfg file to take a look and this is what my cockpit overhead camera entry looks like, there's no hotkey assigned to it at all. So I'm not sure why when switching from internal to external always triggers this camera?

 

UPDATE: Seems like pressing SHIFT+F7, SHIFT+F8 which are both assigned to external views on my Airbus using EZdok will also make this weird "COCKPIT VIEW: OVERHEAD PANEL" show up as well.

 

[CAMERADEFINITION.005]
Title = "OVERHEAD PANEL VIEW"
Guid = {156af20e-2480-46db-a9fd-8ef38cb450bf}
Origin = Virtual Cockpit
MomentumEffect = No
SnapPbhAdjust = Swivel
SnapPbhReturn = False
PanPbhAdjust = Swivel
PanPbhReturn = False
Track = None
ShowAxis = No
AllowZoom = False
InitialZoom = .37
SmoothZoomTime = 0
ZoomPanScalar = 0
ShowWeather = No
XyzAdjust = True
ShowLensFlare = False
Category = Cockpit
AllowPbhAdjust = No
PitchPanRate = 0
HeadingPanRate = 0
InitialXyz = 0.55, -0.27, -0.11
InitialPbh = -70.000, 0, 0

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

There is a known quirk about odd behaviour when switching from internal to external in the AS Airbus. In my case, when I hit the shortcut key, it switches to a view of the sky, so I have to press the key again to get it to display the correct external view.

Share this post


Link to post

So all this time, there's been no mention from AS or a fix to see what's causing conflicts between EZDok and AS Airbus?

Share this post


Link to post

I don't know if AS themselves have ever commented on it, but I've seen various people mention it before. To me it's a very minor problem that I can easily live with. (It seems to be the same as your problem, but instead of the overhead, I get the sky). I have many problems in the simming world, and having to make an extra push of a button to get an external view to appear is about 387th on the list.

 

You could try mentioning it over on the Aerosoft forums. You never know, you might get lucky.

Share this post


Link to post

Kevin thanks so much for that! I guess this is from you:

 

In the main install folder for sim. 

Look for the simobjects/airplane folder specific to the plane in question 

there is a sub folder called panels

For the Airbus specifically, go into the panel.cfg (for each version) and comment out the line that starts and ends...
gauge46 [...] AB_Systems!View,0,0,1,1
Just put a double slash before it. This disables it i.e. 
//gauge46...

In ezdok  you should be adding a shortcut assignment in the main ezdok studio specific to the vc view you want as default

this will move the camera To the vc view exactly as you defined it regardless of which external view you used last

 

I haven't tried it yet, but thank you for this valuable piece of information. It's been driving me nuts for years!

Share this post


Link to post

Wow thanks from me too Kevin. I'll be trying this out as soon as I get a chance. Looks like a real solution too.

Share this post


Link to post

Works for me too. Thanks again Kevin, and thanks Aaron for starting this thread. Otherwise I never would have bothered looking for a solution lol.

Share this post


Link to post

Neal, no problem, lol...

 

However I noticed something after commenting that part out of my panel.cfg file. You can no longer use the built in view system, even when you go to the right MCDU and select yes, the sliding view panels no longer show up, and I also remember that I also get a green info bar going across the top when using the built-in checklist and co-pilot features. Now that doesn't appear either. Not sure if the cause of this is because of editting out that section in the panel.cfg caused this or not. Neal, if you have a chance could you test yours out to see if the built-in view system in the AS airbus work and also see if you get the infobar working (make sure thats enabled in the right MCDU).

 

I wonder if the numbers the end of gauge46 [...] AB_Systems!View,0,0,1,1 mean something? I'm assuming 0 = disable and 1 = enable. 

 

Thanks!

Share this post


Link to post

Neal, no problem, lol...

 

However I noticed something after commenting that part out of my panel.cfg file. You can no longer use the built in view system, even when you go to the right MCDU and select yes, the sliding view panels no longer show up, and I also remember that I also get a green info bar going across the top when using the built-in checklist and co-pilot features. Now that doesn't appear either. Not sure if the cause of this is because of editting out that section in the panel.cfg caused this or not. Neal, if you have a chance could you test yours out to see if the built-in view system in the AS airbus work and also see if you get the infobar working (make sure thats enabled in the right MCDU).

 

I wonder if the numbers the end of gauge46 [...] AB_Systems!View,0,0,1,1 mean something? I'm assuming 0 = disable and 1 = enable. 

 

Thanks!

Yeah, you have to disable the AS viewing system in the right MCDU, otherwise they will conflict. Not really a problem, as Ezdok is much better.

 

I won't get near my PC until tomorrow at the earliest but I'll test out what you asked.

Share this post


Link to post

 

I re-installed the a320 321 extd versions and checked -

 

With tye panel.cfg mod - the checklist itself works but the text on screen does not appear

It looks like the view system is linked directly to the text bar - view system off /text off - bummer

 

I'm taking a further look at this at the moment

 

Kevin

Share this post


Link to post

AHhhh thanks for confirming that Kevin. I hope there's something that can be done on Aerosoft's side to resolve this problem. I need my INFO BAR, it comes in handy for the checklist feature when I'm not directly looking at the right MCDU.

Share this post


Link to post
Spent some time on this and may have a workaround -
 
however - it is ONLY for users that
access the external ezdok aircraft view using a joystick button in the main ezdok studio - shortcut box
I would be grateful if someone else could try it and feedback if it works for them.
 
step 1
remove the // mod from the airbus panel.cfg file and in sim set airbus view system to ON
 
step 2
add to P3d controls - define keys and buttons
views - View camera 4 (select) - YOUR j/button assignment to switch to ezdok aircraft view list
and slide the slider - Full Right
 
step 3
run the sim and try the view system -
 
I tried it with a saitek yoke and saitek x55 (stick and throttle buttons) which have different button polling speeds - switching from ezca to P3d default etc and it
seems to bypass the airbus view by performing the equivelant of a a long press/double press of the button
 
regards
 
Kevin H

Share this post


Link to post

Sorry Kevin for the late response, I have been having a lot of computer and network issues lately that I've been trying to fix. 

 

So what you're saying is that in order to have the INFO BAR working is to enable default AS Airbus viewmode to ON?

 

Have you figure what those numbers at the end mean? The 0,0,1,1? I'm sure it has something to do with enabling and disabling certain things. Perhaps messing with those values may fix the issue and allow us to keep the view mode off while having the info bar working again. I really don't want to enable the view mode... it gets in the way when those panels show. I like to have a clear vision when flying without any sort of HUD elements displayed on top of my sim.

Share this post


Link to post

I also found a fix for Keyboard users using a registered version of FSUIPC4

using the  key press function - basically you set the key (all keys for ez aircraft views assigned in ezdok)

 to send to sim - View camera select 4 - when key pressed & when key released

 

 

as to the View system - I did a quick check of the following and  it seems to be OK - basically it prevents the View - thumbnail etc window from appearing on screen

 

make a backup copy of the panel.cfg file and make this change to the original - add //  to [window 10] horizontal setting and/or //[window 11] for vertical bar setting

 

//[Window10]
size_mm=331,39
BACKGROUND_COLOR=0,0,0
position=0
visible=1
ident=2016
nomenu=1

 

you must leave the view system ON to allow the info bar

 

This needs to be repeated for each variant of the airbus - on first opening the aircraft I found the view went to cp fmc panel view after a few seconds - but selecting the ezdok view for the FMC view

fixed it and it did not come up again

 

 

Kevin

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this