Sign in to follow this  
Vincent

Recent CTD in 3.3.5 had me thinking

Recommended Posts

I just got my computer built by Jetline Systems as my dedicate FS computer. UAC and Defender off, no AV installed, about as vanilla base platform as possible.

 

I installed P3D 3.3.5, PMDG 777, GSX, from Anchorage to Korea (almost 8 hours flight), in the process I tried everything I could to make the sim crash. I tried clicking all the MFDs (Yup, the left PFD, too), going between windowed and full screen, and the sim just keeps going. The VAS usage was about 2.5-2.8G or so and was pretty steady. So I proceed to install the rest of my addons, which includes:

 

FSUIPC registered

FTX Global, Vector, OpenLC NA, PFJ & SAK

AS 2016 + ASCA (Sky texture & cloud structure only) + REX Essential Plus for texture

Multi Crew Experience

FSCaptain

FSRealTime

T2G KSEA

iFly 744v2

vPilot

WOAI

 

I took a flight couple days later from KJFK to KSEA. I loaded up at default KJFK (other than FTX that affects the area, I have no other addons for JFK and its surrounding). I start off with VAS usage about 2.7G. Took off and proceed uneventfully and I looked at the VAS every 30min to an hour. I again tried to make the sim crash throughout the flight unsuccessfully. However, I can see the usage steadily increasing. About 2 hours away from KSEA, my VAS was up to 3.5. When I turned base to intercept the final approach, FSUIPC started ding. I managed to land and taxi off the runway. When I tried to pull up the GSX menu was when P3D crashed with ntdll.dll

 

Yesterday I did a flight from KSEA to PHNL in the iFly 744. the VAS usage was about 3.2G. Tried to make sim crash again and nothing. The VAS was rock steady at around 3.2 throughout the entire flight.

 

After I restart the computer I started another flight from PHNL to KJFK in the PMDG 777. VAS initially was about 2.7. Took off and went to bed. I woke up and found P3D crashed about 5 hours into the flight. Location was a little east of KLAX. It was a ntdll.dll crash.

 

I started to wonder if there's a memory leak with FTX offerings. I currently attempting to finish the reminder of the flight and I had ORBX!VECTOR_APT, ORBX!VECTOR_OBJ, ORBX!VECTOR_CVX, and ORBX!VECTOR_EXX disable from scenery library. I'll see how that goes. Below are the settings for P3D and various addons

 

 

IMG_0059.jpg

IMG_0060.jpg

IMG_0061.jpg

IMG_0062.jpg

IMG_0063.jpgIMG_0064.jpg

IMG_0066.jpg

IMG_0067.jpg

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Good to see others testing.  I think your MSAA 8 samples is awfully high.  That's a resource and fps killer right there.  I am able to get away with 4 samples.  I seriously doubt you will see much of a difference between 8 and 4 other than better fps.

 

Orbx stuff and Ultimate Terrain stuff are known to be hard on frame rates, especially if you have the settings of those add-ons set high.  I don't own the FTX Global/Vector stuff yet but have heard others complain about the performance.  Remember you can have all of your settings set to the highest with just the default P3D and no addons.  When you add the eye-candy though (and everyone wants to have lots of eye-candy), then things go downhill pretty fast and you need to adjust your settings accordingly.

 

Hopefully you have checked out the AVSIM P3D Guide too for some valuable guidance and suggestions.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

I actually have no problem with FPS/ Smoothness with the sim. When I had it lock at 30 FPS it would stay there in the 777 most every where I go. Grant I don't have a bunch of addons other than the ones I listed. What I have now will give me 50-60 FPS most everywhere as well and like I said the sim is smooth, no microshutter (knock on wood).

 

My only problem so far is with the random CTD that I'm still trying to track down

Share this post


Link to post
Share on other sites

 Vincent, are you using the Orbx libraries? And/or Orbx Object flow? Have you tried your tests with them disabled? I have found an improvement in performance when I have those disabled. I would be interested in hearing your results.

 

Cheers and good luck,

Craig

Share this post


Link to post
Share on other sites

How do you turn off libraries and Object flow? I thought they need to work for Orbx to function correctly. And like I said, I have not problem with FPS and smoothness. Just VAS usage and random CTD

Share this post


Link to post
Share on other sites

  There should be an entry in the Scenery Library for the Orbx Libraries. They are not really necessary if you are flying a tube-liner. The libraries are a 3.5Gb file and only contain extra scenery items, like people, trees, static aircraft, etc. found at the Orbx airports. (ie, like those found in their PNW, NCA, and most of the other Orbx add-on scenery's,) Your PNW, NCA, etc., will still work, you just will not see the squirrels running around, and mechanics working on the static aircraft.

The object flow can be disabled in the dll.xml file usually found here for Orbx add-ons.  (C:\users\yourname\Appdata\Roaming\Lockheed Martin\P3Dv3\dll.xml)

If you are not having issues with stutters, then the object flow dll can probably be left alone.

As for the Orbx libraries, it is worth a test flight to see if it makes a difference.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this