Sign in to follow this  
Guest ps76

Sharper Textures on ground

Recommended Posts

Hi, I know there is a way to get sharper textures on the ground while flying, can anyone tell me where on the FS9 config I change to improve texture quality? What do I change on myEXTEDED_TERRAIN_RADUIS...mine is at 0.00Thanks,Bill

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Extended Terrain Texture can ONLY be `0` or `1` - off or on in binary. Others by experiment.If you can do it without a severe fps hit, set it to on.You can sharpen textures by using the graphic card properties - set anisotropic filtering to 8x or more.Hope this helps.Allcott

Share this post


Link to post
Share on other sites

this i how i set it, works pretty good. ofcourse it all depends on how much horsepower you have and what addons you run.[TERRAIN]TERRAIN_ERROR_FACTOR=100.000000TERRAIN_MIN_DEM_AREA=10.000000TERRAIN_MAX_DEM_AREA=100.000000TERRAIN_MAX_VERTEX_LEVEL=20TERRAIN_TEXTURE_SIZE_EXP=8TERRAIN_AUTOGEN_DENSITY=5TERRAIN_USE_GRADIENT_MAP=1TERRAIN_EXTENDED_TEXTURES=1TERRAIN_DEFAULT_RADIUS=9.500000TERRAIN_EXTENDED_RADIUS=9.000000TERRAIN_EXTENDED_LEVELS=1307992OHN

Share this post


Link to post
Share on other sites

If you have a Nvidia card, use Rivatuner and set a negative lod bias. It sharpens the mip maps and takes away the blur but can cause"at least my 6800gt to sometimes cause sparkles and some wavy pattern effects.

Share this post


Link to post
Share on other sites

And another example which clearly shows to me to how many riddles those fs9.cfg parameters are bound!Interesting only that some have indeed found "the key" to unlock these riddles, but the informations how to do so are buried deeply in the cyberspace. No one yet provided a "definite guide to fs9.cfg", too sad...Anyway, all I can say that according to my informations (and I searched the web a long time) terrain_default_radius and terrain_extended_radius seem to have an upper limit of 8, not 9.5.Terrain_extended_levels max value is 8 as well, so the incredible high value in the posting above would be disregarded by FS.A person nicknamed Jobia seems to have very profound informations regarding the fs9.cfg parameters, but I never found his guide/manual and he seems to have disapperared from the community...Andreas

Share this post


Link to post
Share on other sites

Well the "extended_levels" setting might be incredible high to you, but its the default setting, i didnt put it there :D.And you say that for "default_radius" and "extended_radius" the max setting seem to be 8, so i guess a setting of 9,5 and 9,0 is just as good.OHN

Share this post


Link to post
Share on other sites

The coarse ground textures are fixed at 4.8meters/pixel. It is possible to change that to 1.2m/pixel using SBuilder http://www.ptsim.com/forum/forum.asp?FORUM_ID=18 . However, even at that resolution the ground is blurred and only suitable for viewing from an altitude of >1000ft. Georender has supposedly better ground texture resolution in the Chelan Washington scenery. I have not bought it so can't comment. http://www.georender.org/Dick Boley @KLBE

Share this post


Link to post
Share on other sites

>If you have a Nvidia card, use Rivatuner and set a negative>lod bias. It sharpens the mip maps and takes away the blur but>can cause"at least my 6800gt to sometimes cause sparkles and>some wavy pattern effects.That's bad info if you're using Anisotropic Filtering... If you can run 8X or 16X AF without a performance hit, there's an "LOD Clamp" option in the advanced profile settings of the Nvidia driver that will produce the best image quality with no shimmer.

Share this post


Link to post
Share on other sites

The default number for extended_levels is 232.But according to Jobia, any value above 8 makes no difference anymore.Of course it's your choice what you put in the config file, I only like to assist here if I can...Did anyone see any FPS improvement when changing the _radius values to smaller numbers?Andreas

Share this post


Link to post
Share on other sites

One simple thing you can do is check your zoom levels in your various views windows. If they are set to 100% or higher, then lower them to around 80%. That will make a big difference on how blurry the ground textures look. Matt

Share this post


Link to post
Share on other sites

HiI use the following values (found in another forum):--Find and change these values in fs9.cfg (after making a backup of the original)For loading shaper textures farther out etc.TERRAIN_DEFAULT_RADIUS=9.900000 TERRAIN_EXTENDED_LEVELS=3.5TERRAIN_EXTENDED_RADIUS=9.900000TERRAIN_ERROR_FACTOR=100.000000TERRAIN_MIN_DEM_AREA=30.000000TERRAIN_MAX_DEM_AREA=100.000000--Many values work well/bad on different systems so I have to recommend the Fs9.cfg file backup first.Hope it helpsP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this