Sign in to follow this  
--Randy--

"Error opening file for writing"....when installing aircraft.

Recommended Posts

I have a brand new Windows 10 install with FSX-SE installed. 

 

When ever I try to install a new aircraft I get an "error opening file for writing" error and it refers to a file in steamapps\common\fsx\effects\fx_carldnc177.fx 

 

If I click ignore I get an error on another file relating to the aircraft. 

 

It doesn't appear to matter which aircraft I try to install. 

 

I am signed on as Administrator and have gone into User Account Control and moved the slider to the bottom and am running FSX-SE as Administrator and am running the aircraft install program as Administrator. 

 

If anyone has any ideas I would appreciate the help. 

 

Randy

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You could try reducing security:

 

Right click on the FSX folder, select properties, then security. Now create a group named "Everyone" and give it full access rights for the folder. You can also try to give all the other groups full access too, but this does not always work.

Share this post


Link to post
Share on other sites

Since we become members of the Users group when we log into windows and become authenticated, permission to alter file or folder content is properly achieved by adding the Modify permission to the Users group on that folder or file. I don't think this is a cure for Randy's problem, since the Users group already has modify access to the SteamApps folder.

 

Hi Randy! A while since we spoke. I hope all is good with you and yours.

Share this post


Link to post
Share on other sites

Thanks fellas. 

 

I tried the Everyone group change and it made no difference. 

 

This is really bizarre....I can not figure out what the heck is going on here. 

 

I even checked the Attributes in the Properties section of the FSX folder under the General Tab and it has Read only checked so I tried to uncheck it and it appears to run and change all the sub folders and files but when you go back to check it...it says Read Only.

 

So I am stumped.   

  • Upvote 1

Share this post


Link to post
Share on other sites

Have you tried enabling a hidden administrator account?  

 

Go to Command Prompt (Elevated).   Type:  net user administrator /active:yes   and Enter.   This should enable a new admin account for you to install the software.

 

To disable this account, go back to Command Prompt (Elevated) and type:  net user administrator /active:no  and Enter.

Share this post


Link to post
Share on other sites

Found the problem......and thanks for all the great suggestions.  I have never heard of the "hidden administrator account" I will have to remember that one. 

 

What I found was, I had used "FSX Reg Utility" to check to see if the correct path to Steam FSX was set in the Registry and it appeared to be correct so I didn't change it. Well a buddy of mine suggested that I reset it on the off chance that it appeared correct but really wasn't, and sure enough that was exactly what was going on. 

 

As soon as I reset the correct path to FSX Steam in the 2 Registry positions that show up in FSX RegUtility it started working correctly and I could install any aircraft I wanted. 

 

Thanks again everyone. 

 

Randy

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this