Sign in to follow this  
FSXCYYZEGLL

FSX keeps Freezing midflight, then starts again

Recommended Posts

Ok so during my past few flights fsx decides to keep freezing mid flight(sound but no movement), the first few times I just restarted the system, but after the 4th time I just left it, after about 10 minutes it just comes back again and goes normally. I've been able to do a couple of flights like this, but it gets really annoying because the freezes can occur hourly, I've tried it without affinity mask or buffer pool tweaks, only highmemfix and fiberframetimerefraction=.15, but it doesn't change anything at all. I also use FsrealWX Pro for weather( just adds real weather not any graphics changes to my knowledge), and it seems that every time the freeze occurred Fsrealwx would state on it's log there was no weather station in the vicinity. But during my last flight I decided during the middle of the flight to turn FsrealWX off and it kept freezing, so I don't know if it is that. Does anyone have any idea what it could be and how to fix it?

System: 4.0GHz quad-core Intel Core i7,16GB 1867MHz DDR3 SDRAM - two 8GB,3TB Storage, AMD Radeon R9 M395X with 4GB video memory

Settings: everything is basically max, with a pmdg 747 and ultimate traffic 2, at Cyyz.

Signed Jon Alxander

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jon

 

This sounds very much like the 8 minute freeze, Do you use an Affinity Mask setting in your CFG file? I used the suffer the same thing and found that when Active Sky correctly set my Affinity Mask the problem went away.

 

kind regards

 

Daz

Share this post


Link to post
Share on other sites

In general, the last thing you installed for FSX or software you made changes to is the culprit.  Hardware can cause problems like this, however, that may not be the case and will not address it.

Share this post


Link to post
Share on other sites

Hi Jon

 

This sounds very much like the 8 minute freeze, Do you use an Affinity Mask setting in your CFG file? I used the suffer the same thing and found that when Active Sky correctly set my Affinity Mask the problem went away.

 

kind regards

 

Daz

 

I turned affinity mask off for the last flight, and the 8 minute freeze was still coming, do I just need it on the correct setting and it will go away? Or will it go away by simply deleting affinity mask?

Signed Jon

Share this post


Link to post
Share on other sites

Hi Jon

 

I think it all has to do with the correct AF setting, my i7 4770K with HyperThreading on the affinity mask is set to 84. You will need to check if you have Hyper threading enabled to set the correct affinity mask setting. You may also want to adjust the sliders down a little bit to see if that helps. I have mine all set to max apart from water set to 2xLOW and autogen at normal/ Dense

 

I never had any problems until using Active Sky Next but I think this needs to have the correct affinity mask setting in order to function properly. You could try with default weather and a default aircraft and see if you still get the freeze

 

Hope this helps

 

kind regards

 

Daz

Share this post


Link to post
Share on other sites

I had this at the weekend, the freeze with no sound. I happened on a flight plan Id saved at the gate to KLGA. I restarted and flew again, it froze again. I had saved the flight on cruise this time, so ran again. It still froze. I switched off weather, traffic, remoteflight, airtrack.... so next day I deleted the flightplan and tried a fresh flight, same plane. Everything worked fine. Ive just tested another long flight and again it went beautifully.

 

Perhaps you have the same problem, are you starting from a saved game start?

Share this post


Link to post
Share on other sites

I had this at the weekend, the freeze with no sound. I happened on a flight plan Id saved at the gate to KLGA. I restarted and flew again, it froze again. I had saved the flight on cruise this time, so ran again. It still froze. I switched off weather, traffic, remoteflight, airtrack.... so next day I deleted the flightplan and tried a fresh flight, same plane. Everything worked fine. Ive just tested another long flight and again it went beautifully.

 

Perhaps you have the same problem, are you starting from a saved game start?

 

No I don't use saves so this probably won't help

 

Hi Jon

 

I think it all has to do with the correct AF setting, my i7 4770K with HyperThreading on the affinity mask is set to 84. You will need to check if you have Hyper threading enabled to set the correct affinity mask setting. You may also want to adjust the sliders down a little bit to see if that helps. I have mine all set to max apart from water set to 2xLOW and autogen at normal/ Dense

 

I never had any problems until using Active Sky Next but I think this needs to have the correct affinity mask setting in order to function properly. You could try with default weather and a default aircraft and see if you still get the freeze

 

Hope this helps

 

kind regards

 

Daz

Ok I'll use default weather and aircraft with slightly lower settings to see if the freeze still occurs without affinity mask, if it doesn't then I'll do a test with affinity mask at 84( I do have Hyper threading), if that does not work then i'll try at 14. Once those are all done i'll tell you how the results go. Thanks for the help everyone

 

Signed Jon

Share this post


Link to post
Share on other sites

This may or may not help, but it has worked for me in the past and I know it has helped some others.  I see you have 16 GB RAM - I assume 8 sticks of 2GB each.  Carefully remove them from your PC and switch around; i.e. place No1 stick into slot 8, 2 into slot 7 and so on.  Just mix them up basically.

 

I believe it is something called 'creep' when one of the contacts on a RAM strip looses contact.  Probably caused by heating up and cooling down.

 

Give it a go, can't do any harm.

Share this post


Link to post
Share on other sites

Yeah tried it without affinity mask, made the freezing unbearable( once every 10 mins for 15 min), weather program doesn't change a thing, adding affinity mask  84 alone doesn't help neither does adding it at 14, so tried affinity mask alone doesn't help, if it changes anything I had fps set at unlimited, for this test flight I'll try it at 30 fps with fsx's limiter, which didn't work either. I'm not really sure what to try next. And can everyone sign their name please, thanks.

Signed Jon

Share this post


Link to post
Share on other sites

Hi Jon

 

Have you tried deleting your CFG file and using the stock Cessna with clear sky weather not touching any of the sliders, maybe one of your add ons is causing the problem?

 

Daz

Share this post


Link to post
Share on other sites

Hi Jon

 

Have you tried deleting your CFG file and using the stock Cessna with clear sky weather not touching any of the sliders, maybe one of your add ons is causing the problem?

 

Daz

 

I've done a flight with the cfg in a stock baron for 3 or 4 hours and with ultimate traffic and that didn't cause a problem no freezes, I'll try it with the cessna stock, tried updating all the drivers and did that, freezes kept coming after trying that. It may be the add ons, but I've only ever experienced it when flying either pmdg 747 or cs 767 not on other airplanes or default aircraft. I really thought by updating my drivers it would've worked but apparently not.

Signed Jon

Share this post


Link to post
Share on other sites

Hi Jon

 

I think it all has to do with the correct AF setting, my i7 4770K with HyperThreading on the affinity mask is set to 84. You will need to check if you have Hyper threading enabled to set the correct affinity mask setting. You may also want to adjust the sliders down a little bit to see if that helps. I have mine all set to max apart from water set to 2xLOW and autogen at normal/ Dense

 

I never had any problems until using Active Sky Next but I think this needs to have the correct affinity mask setting in order to function properly. You could try with default weather and a default aircraft and see if you still get the freeze

 

Hope this helps

 

kind regards

 

Daz

 

Found the cause, the weather system fsxrealwx pro was causing it, did a flight without it and 3 hours later no crashes, now the question is how to fix this.

 

Signed Jon.

Share this post


Link to post
Share on other sites

Hi Jon

 

Am glad you managed to find the cause for the freezing, I am guessing that it might be overloading one of your cores hence the freeze

 

kind regards

 

Daz

Share this post


Link to post
Share on other sites

Hi Jon

 

Am glad you managed to find the cause for the freezing, I am guessing that it might be overloading one of your cores hence the freeze

 

kind regards

 

Daz

If it is the overloading of one of the cores due to the weather system, do you know how to fix it? I appear to have an 8 core system so affinity mask without hyperthreading is 254

Share this post


Link to post
Share on other sites

Well im going to try it with a different weather program to see if that stops the freezes, will tell you the results.

 

Signed Jon.

Share this post


Link to post
Share on other sites

Hi Jon

 

Am glad you managed to find the cause for the freezing, I am guessing that it might be overloading one of your cores hence the freeze

 

kind regards

 

Daz

Your right it is affinity mask, got asn and it tried to put an affinity mask setting that unfortunately didn't work, I'm trying to set affinity mask so that only 3 cores are used, you wouldn't by chance know how to do that?

Signed Jon.

Share this post


Link to post
Share on other sites

That's the problem with that tweak.  It does not work for everyone and you have to be a computer expert to use it properly.  You make one small mistake in your calculations and FSX dies.  It is the major reason we do not recommend this tweak in the AVSIM FSX Configuration Guide.  If you have a powerful computer, you should not need this tweak.  It might work for a while or for several months but eventually it will bite you and you will not know what you did wrong.

 

Best regards,

 

Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this