Sign in to follow this  
noahweber

Help needed: Super sluggish performance with XP11 demo

Recommended Posts

Hello, All.

Been a longtime FSX/P3D guy but was eager to try out the demo of the new 64-bit platform. I have a rig that is powerful enough to smoothly run P3D with high settings and a lot of intensive add-ons so I expected to see really good performance in XP11. Unfortunately, even though the sim is telling me I'm getting high 20's-low 30's FPS, I am getting unflyable amounts of stutters. Even when adjusting the graphics settings I cannot get the sim to feel "smooth" at ALL. Any ideas what might be going on? I am wondering if there might be some tweaks I need to apply to nVidia Profile Inspector but I don't know which ones. Frames are not being capped and V-Sync is OFF.

Also, is it possible to undock parts of the panel in XP11 like the PFD/ND/EICAS/etc. I use a multi-monitor setup so being able to drag those instruments onto my second screen is a big deal for me. 

Thanks for any ideas you all might have.

-Noah

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It's a beta - a lot of people are reporting fps issues.  You can try going to nvida control panel and find Texture optimization (you can make an xplane.exe profile) and make sure it is OFF.

 

Also fly in clear weather - in XP10 there was a cloud density slider - they don't have one right now...  when I fly in clouds fps drop to the low teens.

Share this post


Link to post
Share on other sites

You can try going to nvida control panel and find Texture optimization (you can make an xplane.exe profile) and make sure it is OFF.

 

Wasn't it "threaded optimization"?

Share this post


Link to post
Share on other sites

It's a beta - a lot of people are reporting fps issues.  You can try going to nvida control panel and find Texture optimization (you can make an xplane.exe profile) and make sure it is OFF.

 

Also fly in clear weather - in XP10 there was a cloud density slider - they don't have one right now...  when I fly in clouds fps drop to the low teens.

 

Thank you for this feedback. I understand it's a beta but this felt like excessively poor performance given my system. I'll look for this setting in the nVidia control panel.

 

Wasn't it "threaded optimization"?

 

I'll look for this setting too! Thanks!

 

-Noah

Share this post


Link to post
Share on other sites

Thank you for this feedback. I understand it's a beta but this felt like excessively poor performance given my system. I'll look for this setting in the nVidia control panel.

 

There are a couple of X-Plane rendering settings that you should keep low even if you have a powerful PC, because they have a big effect on performance:

 

.) "Reflection Detail" to Minimal

 

.) "Draw shadows on scenery" should be off

 

.) "Antialiasing" should not be too high at the far right.

Share this post


Link to post
Share on other sites

There are a couple of X-Plane rendering settings that you should keep low even if you have a powerful PC, because they have a big effect on performance:

 

.) "Reflection Detail" to Minimal

 

.) "Draw shadows on scenery" should be off

 

.) "Antialiasing" should not be too high at the far right.

 

I'll try this too. Thank you as well.

Share this post


Link to post
Share on other sites

There are a couple of X-Plane rendering settings that you should keep low even if you have a powerful PC, because they have a big effect on performance:

 

.) "Reflection Detail" to Minimal

 

.) "Draw shadows on scenery" should be off

 

.) "Antialiasing" should not be too high at the far right.

Agreed with the impact they have but you CAN keep those options on... ;) I myself wouldn't want to fly without shadows all over the place. I gladly take the performance hit and rather lower something else if performance drops too much. I also have reflections at medium and use 4xSSAA and in a lot of situations things are pretty smooth nonetheless (>2 year old system: 4790k@4.5, 6GB GTX780 and 16 GB RAM on Windows 10). And that is with world detail at MAX! Just wanted to make clear 'should be off' is debatable. ;)
  • Upvote 1

Share this post


Link to post
Share on other sites

Agreed with the impact they have but you CAN keep those options on... ;) I myself wouldn't want to fly without shadows all over the place. I gladly take the performance hit and rather lower something else if performance drops too much. I have reflections at medium and use 4xSSAA and in a lot of situations things are pretty smooth nonetheless (>2 year old system: 4790k@4.5, 6GB GTX780 and 16 GB RAM on Windows 10). And that is with world detail at MAX! Just wanted to make clear 'should be off' is debatable. ;)

Fair enough. I'll experiment with these settings and see if it makes a difference in my situation. Right now I feel like there is something fundamentally "off" about how XP11 is running because no matter what settings I've tried so far I get really bad stutters. It reminds me of a time when my P3D starting doing the same thing and it turned out to be a problem with the settings for my second monitor. It basically cut the frames in half on BOTH monitors whenever I moved anything to the second screen. I tried running XP11 with the second monitor disabled but it didn't make a difference. I'll keep playing with it. Thanks again, everybody, for the suggestions.

Share this post


Link to post
Share on other sites

Yeah threaded optimization- sorry for the confusion - should help with stutters

Share this post


Link to post
Share on other sites

Fair enough. I'll experiment with these settings and see if it makes a difference in my situation. Right now I feel like there is something fundamentally "off" about how XP11 is running because no matter what settings I've tried so far I get really bad stutters. It reminds me of a time when my P3D starting doing the same thing and it turned out to be a problem with the settings for my second monitor. It basically cut the frames in half on BOTH monitors whenever I moved anything to the second screen. I tried running XP11 with the second monitor disabled but it didn't make a difference. I'll keep playing with it. Thanks again, everybody, for the suggestions.

 

Since this is the first Beta, if you still have low performance even with many rendering options set to low, you could also try to report that as a bug:

 

http://dev.x-plane.com/support/bugreport.html

Share this post


Link to post
Share on other sites

Yeah threaded optimization- sorry for the confusion - should help with stutters

 

This appears to have solved my problem! Threading Optimization to OFF and the sim is running really smooth now. XP11 definitely LOOKS amazing! I just wish it were easier to undock panels without having to get a second computer on a network to run multiple views...

 

Since this is the first Beta, if you still have low performance even with many rendering options set to low, you could also try to report that as a bug:

 

http://dev.x-plane.com/support/bugreport.html

Thank you for this suggestion. It looks like I won't need to report it as a bug but I hope the devs know to recommend this tweak to people who are having the same problem.

 

Thanks everyone for helping me out!

 

-Noah

Share this post


Link to post
Share on other sites

I'm having bad performance of XP11 on my PC too. Where to turn the "Thread Optimization" off? Thanks!

Share this post


Link to post
Share on other sites

I'm having bad performance of XP11 on my PC too. Where to turn the "Thread Optimization" off? Thanks!

nVidia control panel - 3D settings - select the X-plane profile - turn off threaded opt and save.

Share this post


Link to post
Share on other sites

"Reflection Detail" to Minimal

If you have this to the minimum, you won't get updated real-time reflections. The reflection texture will be created just one time, when the aircraft is loaded, and then stay the same all the time. The effect of that: Even after 2 hours of flight, you can still see taxi marking or building reflections on your fuselage which were created when you loaded the aircraft at the airport. Consequence: Set reflection detail at least one notch above the minimum.

  • Upvote 1

Share this post


Link to post
Share on other sites

nVidia control panel - 3D settings - select the X-plane profile - turn off threaded opt and save.

Thanks a lot! Will give it a try soon.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this