Sign in to follow this  
jackralston

Sudden FPS drop after changing view

Recommended Posts

This one is a bit baffling as it's only started happening very recently. It happens regardless of which aircraft I use, which airport I am at or whether it is day or night.

 

I keep getting sudden FPS drops whilst cycling through the views. For example, if I am on 2D cockpit view and have a standard 45fps (setting on nvidia inspector) and then switch to VC view of which I usually have setup looking over the wing using active camera, I notice a sudden FPS drop that is very noticeable and causes a lot of stuttering visually. I might have 45fps in one view then it drops down to like 15fps. This also happens on other views too (not just VC view). When in VC view it might be fine, then switch to 2D cockpit and it starts stuttering, CTRL+S to overhead then back to 2D cockpit will then get rid of the FPS drop but it is an annoying cycle.

 

What have I installed/changed?
 

- few changes on my nvidia inspector which I have put to back to my usual settings (no difference)

- FS9Evo (was working fine when I first installed it)

- Ultimate Terrain settings (changed a few settings for Europe/USA/Canada)

 

Can't think what has caused it  :unknw:

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Does the Window Task Manager show any rogue program running which might cause this?

 

You can always try the old trick of backing up the FS9.CFG file, then delete the original and let the sim build a new file.  Does this make any difference?

 

Dijvid

Share this post


Link to post
Share on other sites

Nothing rogue running in the background. I have tried rebuilding FS9.cfg, getting rid of a few tweaks in terrain.cfg/scenery.cfg, putting back the default autogen default.xml file. It just keeps happening. 

Latest example is starting on 27R at EGLL UK2000 scenery using default C172 and default weather. FPS in cockpit is 45fps, change to outside plane view then switch back to cockpit and it's down to 20fps, once again change to outside view then back and it's up to 45fps....it is truly baffling.
 

Very tempted to reinstall everything but I have so many sceneries/planes/AI/tweaks it would take an age!

Share this post


Link to post
Share on other sites

It's a bit difficult to know what to suggest when I'm not at your PC myself.  I guess you could try removing Evo, UT and AI to see if that makes a difference but you've probably thought of that already.

 

Maybe the best way forward would be to reinstall the sim even if it does take an age.  After all, you're beginning to get into the "age" thingy now by trying to fathom out what's happening!!  But there again, if you do reinstall you will never know what has caused your problem and there's always the [remote] risk that it might all happen again.

 

If it were me I would reinstall once I'd given my best at trying to solve the problem.

 

Anyway, good luck with whatever you decide to do.  Just sorry I can't nail it down for you.

 

Dijvid

Share this post


Link to post
Share on other sites

Do you eventually use the 3D lights from FS9Evo?

It's known that they cause a remarkable FPS drop on some systems and using some view angles. To test this, you could temporarily deactivate the .bgl file that contains the lights library. Unfortunalety I'm currently not at my flightsim system, so I'm not able to specify which is the file name and its location. But maybe you remember it from installing Evo.

Share this post


Link to post
Share on other sites

vector very tempted to do a full reinstall if I cannot find the solution but yes it will take time. I don't think it's a texture issue as it happens everywhere at different airports and different times.

 

HaraldG already deactivated the bgl files in Scenery/Generic/Scenery folder, still no difference. Trying a few more things today and see what happens.

 

Edit: It is only really noticeable at ground level or on approach. When cruising FPS seem to stay stable.

Share this post


Link to post
Share on other sites
SOLVED IT! Turns out it was the ENBseries mod I had, once disabled FPS would stay high and smooth. No idea how it has taken this long for me to only just realise it was causing an issue though! 

 

Thanks for the help!  :smile:

Share this post


Link to post
Share on other sites

Thanks for providing us your solution. I never used any shader; that seems to have been the right choice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this