Sign in to follow this  
TszChun

What's Wrong with My PMDG 777? Experiencing a HUGE Memory Leak

Recommended Posts

Hello all,

 

I have been flying PMDG 777 for almost 2 year, but never experienced such a huge memory leak.

 

At the beginning of this year, I noticed that certain kind of missed approach was the culprit of memory leak in crusing stage, which was thankfully addressed by PMDG. Selecting STAR JUST before descent was one of the temporary solution mitigating the risk of OOM. Since then, I have successfully completed every flight without memory issue. However, after a long rest leaving flight sim behind, the memory leak issue occurs again! When I flew the 777 from LOWW to EGLL last week, I saw the VAS stably leaking around 400-500MB/hour when cruising. When the aircraft approached UK airspace, the sim got the Aerosoft's EGLL scenery loaded in hence the memory bounced suddenly to 3.8-3.9GB

 

The first thing I tried to do after the OOM was to lower both REX setting and TEXTURE_MAX_LOAD to 1024, then test the same flight. Unfortunately this did not do the trick, the VAS was still leaking at the similar rate. That's why I believe that the leak WAS NOT caused by graphic settings. 

 

Yesterday I tested another flight from EGLL to EDDF. 3GB VAS was used once I loaded the scenery which was normal, but I noticed that the memory was not released as soon as I climbed and left the scenery behind. Plus, the VAS leaked 400-500MB/hour as well. I could not completed such the short flight even though I disabled Aerosoft Zurich near EDDF by Scenery Config Editor.

 

What I have done after I take the long rest were (1) Upgrading ASN to AS16 to ASCA; (2) Setting both Min and Max Cloud Draw Distance to 60; (3) Updating AIRAC cycle to 1613; (4) Updating Orbx Libraries. I have no idea why the OOM came back. The most suspicious culprit I guess was AIRAC cycle because it has been the cause of memory leak before. In addition, when I flew the 777 from EGLL to LOWW, the VAS stayed almost constant when cruising. But while flying from LOWW to EGLL, and from EGLL to EDDF, the memory leak stably even though nothing big got loaded in in crusing stage! Is it possible that entering certain airports into FMC as DEST or ORIGIN was anither cause of memory leak?

 

I would be grateful if you guys could help testing the aforementioned airports to see whether memory leak was observable?

 

Anson

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

An AIRAC cannot cause a memory leak. Were it so, everyone who uses the T7 would be reporting it. They are not doing so. The airports you mention are all memory hogs and always have been.

 

DJ

Share this post


Link to post
Share on other sites

An AIRAC cannot cause a memory leak. Were it so, everyone who uses the T7 would be reporting it. They are not doing so. The airports you mention are all memory hogs and always have been.

 

DJ

 

Thanks for your reply.

 

I would be grateful if you could read my words patiently :wink: I totally understand that the sceneries I was using were memory-demanding. The main point is that I have never experienced OOM, nor memory leak in cruising stage, at the same airports with the same settings and addons except the four I have mentioned: (1) Upgrading ASN to AS16 to ASCA; (2) Setting both Min and Max Cloud Draw Distance to 60; (3) Updating AIRAC Cycle to 1613(4) Updating Orbx Libraries.

 

To make it more accurate, the navigation data containing "head-to-radial-intercept" missed approach procedure, according to PMDG, may cause memory leak. 

Share this post


Link to post
Share on other sites

 

 


To make it more accurate, the navigation data containing "head-to-radial-intercept" missed approach procedure, according to PMDG, may cause memory leak.

 

One thing you could try is to go back to the older AIRAC and see if the issue persists.  I suspect that Windows doesn't 'release' the memory from the app.  At least what it used to do was just hold on to it 'just in case' and let the app reuse it if it needed it.  Maybe.  I do think as more non-autogen objects come into the LOD area more memory is used...things like antennas, stadiums with a fixed location...but, since this is new that might not be the cause.

 

What version of P3D are you running?  3.3.5 and the latest HF2 are better on VAS than other versions.

Share this post


Link to post
Share on other sites

One thing you could try is to go back to the older AIRAC and see if the issue persists.  I suspect that Windows doesn't 'release' the memory from the app.  At least what it used to do was just hold on to it 'just in case' and let the app reuse it if it needed it.  Maybe.  I do think as more non-autogen objects come into the LOD area more memory is used...things like antennas, stadiums with a fixed location...but, since this is new that might not be the cause.

 

What version of P3D are you running?  3.3.5 and the latest HF2 are better on VAS than other versions.

 

I am using FSX :wink:

So strange is that after I did those four things, OOM suddenly came back at the route that I have never experienced any issue before :fool: Normally the VAS will be released a few hundreds MB while departing the airport with complex scenery, but now my sim doesn't do this...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this