chisposeti

Problems recording voice

Rate this topic

22 posts in this topic

Hi,

I am evaluating the version 2.1.0.2 with a trial license.

On my Windows 10, I have changed my native culture pack (es_ES) to en_US by default. Voices downloaded, "language you speak with your device" changed to english and "recognize non-native accents" checked, voice training done...

Installed XPUIPC and P2A is connecting just fine with X-Plane 11, but it is failing to me the most basic feature because P2A seems that it can't hear me at all.

In order to do the most simple test, I´m just trying to use "Grmr Help" and using the most simples sentences as "Say Altimeter" , "Ready to Copy" , etc. but I always have the green message "Full text:" and nothing more.

I have tried several things: run as administrator, compatibility modes (8 and 7), lowering the michropone settings to 44100 Hz, but I always had the same result.

I have done the tests with the headset's microphone and with the integrated one of my laptop and aren´t working with P2A, but both are working just fine with Cortana.

This is the log of starting the P2A, test in "Grmr Help" and close again:

Program StartedPilot 2 ATC (P2A) - version 2.1.0.2  01/20/2017 16:53:20
Pilot2ATC_200.exe    Information    0    SAPI does not implement phonetic alphabet selection.
Speech Recog Started
Speech Recog Restarted
Handle Recognized Speech Started
Application frmP2AMain started


Anybody with a similar problem?

Regards.


 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sounds like you may not be getting access to the Grammar DB.

When you connect to X-Plane, do you get 3 lines in the Speech Text Window:

 

Sim Connected

Recognition Engine Installed

Grammars Loaded

 

Dave

Share this post


Link to post
Share on other sites

I think that they are appearing, but I will able to confirm you in half an hour or so, my X-Plane is updating to beta 7 right now and seems that the server is slow.

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

I´m getting the 3 lines on beta 7:

 

Simulator Connected
Recognition Engine Installed
Grammars Loaded

 

But the same problem testing with Grmr Help

 

Regards

Share this post


Link to post
Share on other sites

It appears that the P2A installation is correct.

Using the Grammar Helper screen is best since it eliminates some of the variables  that can cause the main radio to not work.  If you're getting the "Full Txt" in green and nothing else, then the PTT button is working, but you are not being recognized.  And, based on all the other details you've provided, it sounds like Pilot2ATC is not hearing your input at all.

 

Have you pressed the Set as Default button on the Windows Recording Devices page with the Headset selected?

When you speak "Say Altimeter" be sure to press the PTT button on the screen, wait a half second, speak the phrase, wait a half second, release the PTT button.  That way your phrase is not cut off at the beginning or end.

 

Thanks,

Dave

Share this post


Link to post
Share on other sites

Hi Dave,

 

yes, I have set the microphone as default and the way that I use to speak to the Grmr Helper is similar to the way you describe, but nothing....

 

 

Thank you

Share this post


Link to post
Share on other sites

The only thing I can think of is the Grammar is loading but not working because of the PC Language/Culture setting.

When you added en-US, did you move it to the top of  the language list in Control Panel->Language ?

Then in the Advanced Settings, set "Override for default input method" to Use Language List.

 

Thanks,

Dave

Share this post


Link to post
Share on other sites

Hi again Dave,

 

Yes, en-US was on the top of the list. Anyway, I have set the values of Override that you have gave me but still it is not working.

 

Thank you Dave

Share this post


Link to post
Share on other sites

I'm running out of ideas of what could be wrong.

 

It is possible that the program is not getting proper access to the Grammar folder.  Check the permissions in the full path to the Grammar folder, for example c:\Pilot2ATC_200\Grammar.  Be sure there is an entry in the Users box named "Authenticated Users" and be sure that user has Read/Write authority.

 

if that's not the issue, you could try installing the update package.  That would fix any issues with the installation of P2A.

 

Dave

Share this post


Link to post
Share on other sites

Hi Dave,

The permissions for authenticated users was right on the folder. I have installed the update package but not yet working. This is the content of the folder, maybe you see something weird

Regards!

 

sc1.png

Share this post


Link to post
Share on other sites

That looks correct.  So probably not the problem.

 

 

If you have another computer to try it on, that might be worth doing.  Or even a different microphone you can set up to see if that makes a difference.

 

Could also try setting the Microphone Advanced Settings back to Default if you have been messing with the sample rates.  Or try changing the sample rates to see if that makes a difference.

 

Dave

Share this post


Link to post
Share on other sites

Hi,

 

sorry, at this moment I don't have another computer to do more testing. I have tries 2 microphones with jack and the integrated one. Maybe next week I'll have access to an USB headset.

 

Regards.

Share this post


Link to post
Share on other sites

If your running windows, you could try a right click on the speaker Icon in your task bar, then select Open Volume Mixer. Select System Sounds and the Recording. Maybe your Microphone is not selected.

As you speak into the mike I think you should see the bar graph on the right follow your speech. As you can see in the window, it is configurable.

Apologies if you have already done this, did not see it in your post.

 

Chuck

Share this post


Link to post
Share on other sites

Hi Chuck

I have already checked , the mic is selected and the green bar shows the activity when I speak. The mic is working with Cortana, voice recorder, etc... It seems that the problem is only in P2A.

 

Thanks anyway

Share this post


Link to post
Share on other sites

Another long shot.  Try checking the Privacy Settings and be sure that the Microphone is enabled for All Apps.   In Windows 8 and 10, you can limit access to the microphone to certain apps.

 

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now