Sign in to follow this  
pilotdcm

Aircraft won't initialize, seems frozen

Recommended Posts

I loaded the Queen into Prepar 3d 3.4 upon release yesterday and it opened up just fine the first time and I was able to activate it and look around the beautiful handiwork.  I noticed there were no sounds in the cockpit so I thought I would restart it and try again.  Once i restarted, it now wouldn't initialize.  I have tried un-installing the Queen and re-installing the queen to no avail.  After many tries I loaded it up and randomly everything works!! I enjoyed the wonderful simulation for a bit but by then it is late and time for bed.  This morning fire it up and you guessed it, it won't initialize.  No keyboard input will control anything on the airplane in real time.  If you hit a key command the simulator will sit there indefinitely until you hit the escape key twice (once asking if you want to end scenario, then again to cancel and go back to sim).  after that, it will respond to one of the keys you hit and that is it.  For example, you are in the cockpit and you hit the "s" key, nothing will happen.  hit the escape key twice and voila, you are on the outside of your plane, can't control or change anything but you can still see the outside of the airplane.  Hit "shift+s" and nothing happens, hit escape twice and voila, back in the inoperative cockpit again.  Just for some other information, I am running in stock Prepar3d V3.4, no scenery addons, stock weather, and no texture addons.  I followed the 4 point suggestions from PMDG for Prepar 3D with no changes.  Anybody have any ideas?

 

Thanks, David Mallory  

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Dn't know if it applies to P3D too, but it used to happen in the 777 in FSX:SE and was related to missing simconnect libraries ?

Share this post


Link to post
Share on other sites

There's a readme file right next to the installer (named "FSX:SE ..." or "P3D users read this") that outlines steps that you must follow if you're using FSX:SE or P3D. We also have an article on our support site that includes the directions.

 

I'd provide a link here, but my browser at the day job won't let me paste links.

Share this post


Link to post
Share on other sites

Hi! I have the same problem... Same as described! I tried unregistering it and registering it again, to no avail, updates the PMDG Operation Centre, nothing changed. Rebooted computer, nothing changed, will now try a full reinstallation.

 

UPDATE: Complete reinstallation didn't fix the issue... Grrrr

Share this post


Link to post
Share on other sites

Frederick,

 

It's best to reach out and ask for help first. All of what you did likely isn't causing the issue.

 

Which simulator are you using? If it's FSX:SE or P3D, you need to install some simconnect files. Looks like we may have left this out of the installer zip file, however, and I can't paste links into my browser from my day job (no idea why, but hey...).

 

If you google "support.precisionmanuals.com simconnect p3d" then it should bring the article right up. That should get you going.

Share this post


Link to post
Share on other sites

in the read me file next to the installer there was only a "README_PMDG_747_Base" file with generic instructions on how to find support on the PMDG website and the EULA, definitely no instructions for FSX: SE or Prepar 3d.  I did read the article on the PMDG website at this link.  http://support.precisionmanuals.com/kb/a112/important-and-nearly-foolproof-steps-to-running-your-pmdg-product-in-prepar3d-v3.aspx.   After doing all that, it didn't change anything.  I ended up completely removing P3D and reinstalling it fresh (didn't have any addons in it to begin with, so not that big of a complication.)  After re-installation, I redid all 4 simconnect installers in the redist folder of Prepar3D and then I reinstalled the queen again.  After doing all that, it was working for me and I am currently in my first test flight.  I will keep update here after I finish my flight and exit out and try and start the sim up again fresh to see if it this actually completely worked for me.  It worked one time yesterday evening, and then stopped working again, so we will see what happens!

 

David Mallory

Share this post


Link to post
Share on other sites

Kyle,

 

I am running on the latest P3D version. I already own the PMDG 737 and PMDG 777. I have also sent a ticket on the PMDG website, currently waiting for their response. I just thought I'd share it here so as to give some weight to the thread. I won't be reinstalling my whole Flight Simulator... so I'll wait for a solution. 

Share this post


Link to post
Share on other sites

David,

 

Thanks for reporting back. That's quite a pain, but glad it's working. If it does it again, and you don't want to reinstall everything, I think you can uninstall the SimConnects and reinstall them individually.

 

Frederick,

 

Can you uninstall the SimConnect files (via the Control Panel), and then reinstall them? Make sure you're installing the correct ones, as well.

Share this post


Link to post
Share on other sites

Kyle,

 

If I uninstall the SimConnect Files from the control panel will that affect FSX as well as P3D?  Upon unistalling/reinstalling will that refresh them for FSX as well as P3D?

Share this post


Link to post
Share on other sites

David,

 

In short, no - they're independent.

 

-----

 

Frederick,

 

Start > type "services.msc" > Find FlextNet in the list and ensure that it is set to "manual."

 

Do you use any tweaking tools that deactivate Windows services, or have you manually changed windows services?

Share this post


Link to post
Share on other sites

David,

 

In short, no - they're independent.

 

-----

 

Frederick,

 

Start > type "services.msc" > Find FlextNet in the list and ensure that it is set to "manual."

 

Do you use any tweaking tools that deactivate Windows services, or have you manually changed windows services?

 

 

I checked FlexNet and it is indeed set to manual. I have manually changed some windows services such as the malware detection software by Windows. However, I did this seeing that the PMDG 747 wasn't working.

Share this post


Link to post
Share on other sites

Frederick,

 

If you haven't already, submit a ticket. There are some extra steps we can walk you through, but I don't have them available to me at the moment. One of our techs will, though.

 

EDIT: Were you ever asked to activate? If not, check to verify that there isn't an activation window hanging out "behind" the P3D window when you go to activate it.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this