Sign in to follow this  
Seat*

Can´t get Traffic Toolbox to load

Recommended Posts

Here is my problem. The Traffic toolbox dosen´t load in P3D.  My dll.xml looks like this. Can I get som help to solve the problem

 

/Thomas

ESNN

 

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>ObjectFlow</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>N:\P3D v 3.4.9\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery\ObjectFlow_P3D.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>FSUIPC 4</Name>
    <Disabled>False</Disabled>
    <Path>Modules\FSUIPC4.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>Captain Sim Sound</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>Captain_Sim\bin\cs.sound.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Name>Traffic Toolbox</Name> 
    <Disabled>False</Disabled> 
    <Path>L:\P3D SDK\Environment SDK\Traffic Toolbox SDK \TrafficToolbox.dll</Path>
  </Launch.Addon>
</SimBase.Document>

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Mine:

 

<Path>C:\Program Files (x86)\Lockheed Martin\Prepar3D v3 SDK 3.4.22.19868\Environment SDK\Traffic Toolbox SDK\traffictoolbox.dll</Path>

Share this post


Link to post

Hi Vaughan

My path is correct. I have My SDK on My L drive.

 

/Thomas

Share this post


Link to post

Did you download the SDK for the version of P3D that you now have .. they must match?

Or are you using your last (old) SDK version and a newer P3D version?

 

 

When I ran the SDK my default location is :

C:\Program Files (x86)\Lockheed Martin\Prepar3D v3 SDK 3.4.22.19868

 

For my version of P3D3.4.22.19868.

 

This way I can always see the version mumber.

Share this post


Link to post

Try to remove the trailing space shown in red: ...\Traffic Toolbox SDK_\..

Share this post


Link to post

I have the newest SDK (last) and the latest version of P3D. Sorry but it was not any space after Traffic Toolbox SDK even if it looks so.

 

Any other suggestions?

 

/Thomas

Share this post


Link to post

"have the newest SDK (last) and the latest version of P3D. Sorry but it was not any space after Traffic Toolbox SDK even if it looks so.

 

Any other suggestions?"

 

 

 

I would Uninstall it / and verify not on drive "L"

Download a fresh copy of SDK from your P3D account

Verify the checksum

Install it (as admin if allowed) in the default drive/location

Update your dll.xml path (copy / paste the path).

test it

Share this post


Link to post

I also found that if i did not have the sdk version number in the dll mine did not work either

Share this post


Link to post

Thanks Vaughan. Your solution fixed the problem!!

 

/Thomas

Glad it worked.

Have a good day.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this