RXP

RXP GTN 750/650 Touch v2.4.1 available

Recommended Posts

Hi,

Before an official release, I wanted to let you try the v2.4.1 release candidate! If there are no 'crash' reports, it will become officially released.

A quick list of the changes:

  • Massive performance gains: our tests systems show minimal to nearly no FPS changes from 1 to 2 GTN (and even up with 2GNS + 2GTN in some cases - YMMV).
  • TCAS missing targets corrected.
  • Revisited and greatly improved all 'panel instruments links', with support for mixing GNS and GTN devices (GPS datarefs, HSI datarefs, NAV datarefs and related instruments).
  • Always On option: now you can opt to have your devices 'always on' regardless of the avionics switch. This shall help with 3rd party aircraft with custom/non-standard electric buses.

Download link for both e-commerce installers

Update: the installers have been re-uploaded with the Win10 fix!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Jean Luc

This update din't work for me, got the following error log:

17/03/02 21:14:02.060 02760 -    ] # rxpGtnSim64.dll version 2.4.1.0
17/03/02 21:14:32.825 02760 INFO ] using C:\X-Plane 11\Aircraft\Laminar Research\Cessna 172SP\checklist.gtn
17/03/02 21:14:34.806 02760 ERROR] GTN 750.1 process not ready: C:\ProgramData\Reality XP\rxpGtnSim32.dll
17/03/02 21:14:34.810 02760 ERROR] Status 0x, code: c000070a

Share this post


Link to post
Share on other sites

Can you try rebooting the computer and compare? Can you cross check your antivirus logs and/or explicitly while-list rxpGtnSim32.dll (C:\ProgramData\RealityXP) and win.xpl (XP\Resources\Plugins\rxpGTN\32)

Share this post


Link to post
Share on other sites

Just tried GTN 750/650 and GNS 530/430 Can not get screens to power-up on any. Just black screen with gauge.

GTN2.4 and GNS 2.2 was all working for me.

Tried the always on button and reboot no joy.

Share this post


Link to post
Share on other sites

Bluebell2, what does say your log files?!?

Share this post


Link to post
Share on other sites

17/03/02 21:56:53.918 02808 -    ] # rxpGtnSim64.dll version 2.4.1.0
17/03/02 21:57:23.162 02808 ERROR] GTN 650.2 process not ready: C:\ProgramData\Reality XP\rxpGtnSim32.dll
17/03/02 21:57:23.162 02808 ERROR] Status 0x, code: c000070a
17/03/02 21:57:23.624 02808 ERROR] GTN 750.1 process not ready: C:\ProgramData\Reality XP\rxpGtnSim32.dll
17/03/02 21:57:23.625 02808 ERROR] Status 0x, code: c000070a
 

17/03/02 21:56:47.771 02808 -    ] # rxpGnsSim64.dll version 2.2.1.0
17/03/02 21:57:22.288 02808 ERROR] G430.2 process not ready: C:\ProgramData\Reality XP\rxpGnsSim32.dll
17/03/02 21:57:22.289 02808 ERROR] Status 0x, code: c000070a
17/03/02 21:57:22.690 02808 ERROR] G530.1 process not ready: C:\ProgramData\Reality XP\rxpGnsSim32.dll
17/03/02 21:57:22.690 02808 ERROR] Status 0x, code: c000070a
 

 

17/03/02 21:56:45.316 02808 -    ] # win.xpl version 2.2.1.0

 

17/03/02 21:56:50.893 02808 -    ] # win.xpl version 2.4.1.0

Share this post


Link to post
Share on other sites

Thank you, I'm looking into this. Either there is a file I've missed adding in the installers, or there is a hiccup with different Windows versions. Can you please remind me your Windows OS versions?

Share this post


Link to post
Share on other sites

Ok bug identified (we've just missed a thing when preparing the installers). An update on its way tomorrow!

Share this post


Link to post
Share on other sites

Update: the installers have been re-uploaded with the Win10 fix now!

the GTN audio panel has been strengthen against wrongly coded plugins ( ref: "No GPS Position" thread), and the map now properly rotates with your heading when below 30kts (instead of your track).

Share this post


Link to post
Share on other sites

GNS works great but still a problem with GTN.

When powering up GTN 750/650 screen stays black and the 3D window disappears.

Logs:-

17/03/04 09:55:19.123 07848 -    ] # win.xpl version 2.4.1.0

17/03/04 09:55:22.035 07848 -    ] # rxpGtnSim64.dll version 2.4.1.0

Share this post


Link to post
Share on other sites

Tried going back to v2.4.0 but now that will not work either. Same no power up and 3D panel disappears.

Share this post


Link to post
Share on other sites

same here.

can we have please the installer working to go back to v2.4.0 ?

this thing is spoiling my weekend now .....

Marc.

Share this post


Link to post
Share on other sites
2 hours ago, bluebell2 said:

Tried going back to v2.4.0 but now that will not work either. Same no power up and 3D panel disappears.

There is always something! Is the popup window at least working ok, i.e. is the GTN working fine and all, just it won't render in the 3D panel?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now