iceking

Problems with Saitek Throttle Quadrant

Recommended Posts

Hi there,

Recently, i have trouble with my saitek throttle quadrant as it keeps resting to default controls when i start FSX. I have to chnage the settings every single time i restart my FSX. I did not have this problems at all before but i don't know why it happened to me now. Anyone can help me?

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

When you say you have to reset the changes is this to the levers or the switches, where are you resetting, do your profiles work, have you the latest driver and software from Logitec (MadCatz).      Might be an idea to run Ccleaner and a defrag program.  Must admit I haven't had this problem but maybe the above may help someone to help you. Re vortex681, I've never had the need to use run as administrator, maybe that depends on your system set up.

Echofox

 

Share this post


Link to post
Share on other sites
3 hours ago, Echofox said:

... have you the latest driver and software from Logitec (MadCatz).

Re vortex681, I've never had the need to use run as administrator, maybe that depends on your system set up.

I've never installed the Saitek software and my quadrant works perfectly.

If you install to the C: drive (particularly to Program Files (x86)) and UAC is enabled, you sometimes need to run "as administrator" to be able to save changes. Worth a look!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now