Sign in to follow this  
jimble

Flows and GSX

Recommended Posts

Opened another thread as the last one has gone a bit off topic with the gentleman with problems with his PMDG. If you want me to stop opening new threads just let me know. I followed the instructions for making flows, holy cow it works!..brilliant thanks, i imported the flows for the  Emb 145 and my 170/75 E jets have come to life. This add on gets better every day.

   I am again having problems with GSX as it has stopped responding to voice commands. I recently did the factory reset, repeated voice training and all was well, i can tell if it is going to work or not as when MCE starts up, several menus appear for a short time GSX should be one of them..if it pops up it will work with voice commands, if it doesn't it wont. I have posted on the GSX forum to see if they might have any idea why it stops working, in the mean time, any ideas what might happen to it?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

6 hours ago, jimble said:

Opened another thread as the last one has gone a bit off topic with the gentleman with problems with his PMDG. If you want me to stop opening new threads just let me know. I followed the instructions for making flows, holy cow it works!..brilliant thanks, i imported the flows for the  Emb 145 and my 170/75 E jets have come to life. This add on gets better every day.

   I am again having problems with GSX as it has stopped responding to voice commands. I recently did the factory reset, repeated voice training and all was well, i can tell if it is going to work or not as when MCE starts up, several menus appear for a short time GSX should be one of them..if it pops up it will work with voice commands, if it doesn't it wont. I have posted on the GSX forum to see if they might have any idea why it stops working, in the mean time, any ideas what might happen to it?

I am glad your getting results with MCE flows. Once you create a few its an unstoppable process to realistic simulator flying!

Re GSX, I can tell you that my GSX (Couatle) decided to go on strike the other day? What I did was uninstall the Couatle Stand alone manager and GSX using Windows un install and re install those two programs. When you re install, it will automatically download the latest files.

I don't know why exactly, but every time I add new scenery, the Couatle GSX programs can go silly!

Hope that helps.

CheersDavid

Share this post


Link to post
Share on other sites
10 hours ago, jimble said:

Opened another thread as the last one has gone a bit off topic with the gentleman with problems with his PMDG. If you want me to stop opening new threads just let me know. I followed the instructions for making flows, holy cow it works!..brilliant thanks, i imported the flows for the  Emb 145 and my 170/75 E jets have come to life. This add on gets better every day.

   I am again having problems with GSX as it has stopped responding to voice commands. I recently did the factory reset, repeated voice training and all was well, i can tell if it is going to work or not as when MCE starts up, several menus appear for a short time GSX should be one of them..if it pops up it will work with voice commands, if it doesn't it wont. I have posted on the GSX forum to see if they might have any idea why it stops working, in the mean time, any ideas what might happen to it?

Good to hear you found your way with the E175 & 195

By the way, you don't need to go through speech training every time you reset MCE to fctory settings or run the app wizard.

Overdoing speech training might actually lead to worse results.

The trained speech profile is managed by Windows. It's only lost when you delete your user account or format C: drive clean.

Regarding GSX interfacing...

There are conditions that must be met before MCE brings-up the ramp agent.

One of them is that all engines must be seen as NOT running and parking brake is set.

I assume you're running MCE V2.7.0.6 and that 

1 - You installed MCE to C:\Program Files (x86)\ folder

2 - You set "fsx.exe" and "prepar3D.exe" to run as administrator.

It has to be that way when Windows UAC is enabled (we don't recommend disabling it).

This will ensure MCE which runs externally to the sim for better stability of the latter and to prevent speech engine eating valuable VAS, can communicate with the simulator without Windows putting a block to specific operations.

With the sim running, load the aircraft with engines running and go to <Sim> tab in MCE user interface.

If it reports "aircraft on ground, engine(s) running", you can safely assume MCE IS getting data from the sim as expected.

 

Share this post


Link to post
Share on other sites
On ‎09‎.‎04‎.‎2017 at 3:42 AM, jimble said:

 i can tell if it is going to work or not as when MCE starts up, several menus appear for a short time GSX should be one of them..if it pops up it will work with voice commands, if it doesn't it wont.

 

I've also had this problem in some cases.

 

My solution was to first fully load the sim and only then start MCE (do not autostart MCE with the sim). I never had this problem again since I do it that way.

 

I guess MCE has some kind of timeout while waiting for the sim to load. If it takes too long (too many aircraft and scenery to load) MCE cannot connect to GSX anymore.

 

Share this post


Link to post
Share on other sites
1 hour ago, RALF9636 said:

 

I've also had this problem in some cases.

 

My solution was to first fully load the sim and only then start MCE (do not autostart MCE with the sim). I never had this problem again since I do it that way.

 

I guess MCE has some kind of timeout while waiting for the sim to load. If it takes too long (too many aircraft and scenery to load) MCE cannot connect to GSX anymore.

 

An interesting observation!

This could also be dependant upon how fast a particular PC can load all the Scenery. But GSX also needs to initialize at the airport your spawning at. Several seconds, about 5 in my case. 

The classic is if you start MCE before the PMDG NGX has finished initializing, typically 15 seconds. If you don't wait for the NGX to load, MCE won't communicate with it either.

So I think a good idea to wait a bit before loading MCE last. 

From my experience, if I install new scenery and/ or aircraft, for some reason Couatl doesn't always run properly. A re install usually fixes it.

Cheers

David

 

Share this post


Link to post
Share on other sites

That's the order that i fire up the sim. The aircraft is configured before i start MCE and right now GSX is not responding at all to voice command.Might try another factory rest of MCE and see what happens.

Share this post


Link to post
Share on other sites
13 hours ago, jimble said:

That's the order that i fire up the sim. The aircraft is configured before i start MCE and right now GSX is not responding at all to voice command.Might try another factory rest of MCE and see what happens.

MCE won't bring ramp agent aboard until a few conditions are met.

For instance, aircraft must be on ground, parking brake set and engines not running.

If it can't read FS data, it's unlikely to see aircraft is on ground.

Try this...

With aircraft loaded, sitting on the ramp, engines running, go to MCE <Sim> tab and check the green font line reports it as such.

If not, there is an issue with something blocking operation between "mce.exe" and "fsx.exe".

A reminder, when Windows UAC is enabled, and we don't recommend disabling it you MUST 

1 - Install MCE to default C:\Program Files (x86)\ folder

2 - Set "fsx.exe" and/or "Prepar3D.exe" and/or "fs9.exe" to RUN AS ADMINISTRATOR.

Is running FSX/P3D/FS9 via a launcher app like "SimStarter", "FPS_Limiter" oir other, the latter must also be set to run as administrator.

This will guarantee smooth communication between the sim executable and "mce.exe" which runs externally from the sim for better stability of the latter and to prevent speech engine eating valuable VAS memory.

 

Share this post


Link to post
Share on other sites

Can Confirm that factory reset option in MCE fixed the problem and GSX is working again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this