Dane Watson

Middle Mouse Button Changed?

Recommended Posts

Did the MMB get changed? I used to like the ability to press the MMB and the CP Menu options would pop up, that was very handy.

It is not working anymore - why?

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm using the newest version and I have problem with the Mouse Controls setup in Preferences --> Camera too.

I tick several options and it doesn't work. However if I restart chaseplane, it will work. You can try to restart it and see, but it is only a workaround for now. There is something wrong with it.

It was working with 0.1.700 but 0.1.704 somehow mess it up.

Hoang Le

Share this post


Link to post
Share on other sites

I am having the same problem with the Middle Mouse button not showing the view selector?? It worked last week.

Share this post


Link to post
Share on other sites
15 minutes ago, Nominator said:

I am having the same problem with the Middle Mouse button not showing the view selector?? It worked last week.

Have you tried to restart Chaseplane? During flight, exit chaseplane completely and open it again.

 

Share this post


Link to post
Share on other sites

Hi Hoang, yes I tried restarting CP but my MMB does not trigger, what I thought was a very useful tool, to bring up a type of heads-up-display which then allowed you to access the CP UI menus. I miss that feature, would like to see it brought back.

Share this post


Link to post
Share on other sites
1 hour ago, Dane Watson said:

Hi Hoang, yes I tried restarting CP but my MMB does not trigger, what I thought was a very useful tool, to bring up a type of heads-up-display which then allowed you to access the CP UI menus. I miss that feature, would like to see it brought back.

After recent Protocolerror problem that just occured minutes earlier I think they revert back to 0.1.633 and it is working normally now.

 

Share this post


Link to post
Share on other sites

What I was refering to was the option found in ver. 0.1.663 that allowed Enable Middle Mouse View Selector found in Preferences\Camera

 

ou0LtFsF8Gr2E3ucJDtYvjaDfHlL9dKNLDqVoT5_

Share this post


Link to post
Share on other sites

Hi, I just try to enable that option and it works for me

Hoang Le

Share this post


Link to post
Share on other sites

Keven - first let me say I am amazed at your speedy response to issues - great job sir.

I did find issues at first starting CP - see attached printscreen. Tried it twice and then instead of clicking OK to the Download Failed I left it for a while then clicked OK then the download of 0.1.704 processed.

Just so you know the MMB does not work for View Selector - see my email to you about 9:30 PM PST

-_8e8tZj2264D7EyBFjY840j8uHW6ttjuckr828J

Share this post


Link to post
Share on other sites

Keven, got your email - did the RegEdit restarted CP but the MB does not show View Selector (Hold Steady)

Share this post


Link to post
Share on other sites

Same problem here, MB view selector does not trigger anymore the popup tool, not sure when this started but I feel it was even before the latest 0.1.704 update.

Share this post


Link to post
Share on other sites

Guys I have something I would like you to try:

  1. Put your sim in windowed mode
  2. Resize it to take roughly half the horizontal size of your monitor
  3. Try to enable the In-Sim View Selector with your mouse close to the edge of your sim window
  4. Tell me if the view selector shows behind the simulator or not at all

Thank you!
Keven

Share this post


Link to post
Share on other sites

Tried your suggestion but no, does not appear - tried all four edges, nothing.

But it for sure worked in 0.1.663

Share this post


Link to post
Share on other sites

I'm having the same problem, I can't get the button for the middle mouse button hold for panning, nor can I get the menu to come up either.

I am sure you guys will sort it.. I'm using v0.1.707

Share this post


Link to post
Share on other sites

Wait now it's back after a restart!

What I did..

1 - Turn off all the selections in .. PREFERENCES > CAMERA (tab) > Mouse Controls.

2 - Close Chaseplane

3 - Reloaded Chaseplane

4 - Put in MB Pan & Tilt (Hold + Move)....... MB View Selection (Hold Steady)

Now it works, does this help you Dane?

Share this post


Link to post
Share on other sites

We keep pushing new builds (4 today so far). We really hope this is all over by tonight!

 

Share this post


Link to post
Share on other sites

Hey it's cool.. it's alpha..  I'm just glad I decided to come back and give it another go.. now I am used to it.. it's quite a pain to have it not working.. Just shows how much I use it without thinking now..

Just going to check out the new features I've just seen now :)

 

 

Share this post


Link to post
Share on other sites

FUBAR here.

I ran the registry set and now it will not run. It starts and then back to the desktop.

I'm sure you'll figure it out.

Like craig says: it's alpha, it's all good. And like someone else said, I'm completely spoiled with CP and wouldn't think of using anything else.

Will try again later.

Share this post


Link to post
Share on other sites
25 minutes ago, RichieFly said:

FUBAR here.

I ran the registry set and now it will not run. It starts and then back to the desktop.

I'm sure you'll figure it out.

Like craig says: it's alpha, it's all good. And like someone else said, I'm completely spoiled with CP and wouldn't think of using anything else.

Will try again later.

Try reinstalling it, there shouldn't be any issue running it right now. You no longer need to user the registry file.

Share this post


Link to post
Share on other sites

Hey Keven - still not working with 0.1.710.

I will be out of commission until Sunday or Monday as I am taking my PC in for a new SSD right now.

By the way Keven, I did install that file into RegEdit - should it stay there or does that have anything to do with these issues??

I will get your replies and others in the Forum on my tablet.

 

Keep trying Keven - like others have said we all know it is Alpha mode - all is good.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now