Guest JustanotherPilot

XP11 Default scenery reload how

Recommended Posts

Hi,

Still learning how to use X-Plane 11(from FSX) and have somehow made my default scenery and custom scenery a dogs breakfast, it's everywhere and not showing airports correctly - I have managed to get them in the right order thanks to Youtube, the trouble is that while trying to learn how to use XP10 I had installed custom scenery, changed global airports etc. When I installed XP11 I just transferred all of my XP10 files over. I have just learned that HD Global scenery 3 is not compatible with XP11.

I would like to reset XP11 back to default and start with scenery again. I have the download version of XP11( a very big download). How do I do this?

steve

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

My suggestion is to delete the custom scenery folder and run again installer to replace default files.

Share this post


Link to post
Share on other sites

Thanks Riccardo, I thought of doing that, do you know the size of the files download for custom scenery

Share this post


Link to post
Share on other sites

Wait, hold on, why would you need to delete your custom scenery folder? It would do literally nothing beyond making it necessary for you to download every scenery you ever downloaded again. Don't do that- it would just be a pain and wouldn't solve anything. You can try deleting 'Global Airports', located within your custom scenery folder, and re-running the installer to get a fresh Global Airports folder (about 145 MB). After doing that, delete your scenery.ini folder, run XP so that it regenerates, and double/triple check your scenery order. There are plenty of guides, but it should generally go:

  • Airports/Cities
  • Textures (like orthophotos)
  • Mesh

Also, you might have misunderstood. HD Mesh v3 (I'm assuming that's what you're talking about) is 100% compatible with XP11. Nothing about the scenery processing structure changed between XP10 and XP11. It just isn't as up-to-date as XP11's default mesh, simply because HD Mesh v3 has older data from ~2013 (so a road built in 2015 wouldn't appear using HD Mesh v3, while it would appear by default in XP11). You can still install and load HD Mesh V3 just fine in XP11- I'm using a few tiles myself actually.

Also, I'm not sure I understand what your issue is. What do you mean that airports don't appear right? Some screenshots would be helpful (Press shift+space, they'll appear in your main XP folder's 'Output' subfolder). Also, you should give us your scenery.ini file. Just copy the contents and past them either here or at pastebin.com. 

Now, deleting/reinstalling your default scenery folder *might* be what you're looking to do, but that's a huge download (~60GB for the whole world IIRC) and it might not solve your problem which I'm confident is some sort of .ini ordering/file structure issue. However, we can't know for sure until you post the ini and screenshots or a detailed description of the problem you're having (no airports? trees on runway? Conflicting buildings? etc...).

Share this post


Link to post
Share on other sites
1 hour ago, hamoody said:

Wait, hold on, why would you need to delete your custom scenery folder? It would do literally nothing beyond making it necessary for you to download every scenery you ever downloaded again. Don't do that- it would just be a pain and wouldn't solve anything. You can try deleting 'Global Airports', located within your custom scenery folder, and re-running the installer to get a fresh Global Airports folder (about 145 MB). After doing that, delete your scenery.ini folder, run XP so that it regenerates, and double/triple check your scenery order. There are plenty of guides, but it should generally go:

  • Airports/Cities
  • Textures (like orthophotos)
  • Mesh

Also, you might have misunderstood. HD Mesh v3 (I'm assuming that's what you're talking about) is 100% compatible with XP11. Nothing about the scenery processing structure changed between XP10 and XP11. It just isn't as up-to-date as XP11's default mesh, simply because HD Mesh v3 has older data from ~2013 (so a road built in 2015 wouldn't appear using HD Mesh v3, while it would appear by default in XP11). You can still install and load HD Mesh V3 just fine in XP11- I'm using a few tiles myself actually.

Also, I'm not sure I understand what your issue is. What do you mean that airports don't appear right? Some screenshots would be helpful (Press shift+space, they'll appear in your main XP folder's 'Output' subfolder). Also, you should give us your scenery.ini file. Just copy the contents and past them either here or at pastebin.com. 

Now, deleting/reinstalling your default scenery folder *might* be what you're looking to do, but that's a huge download (~60GB for the whole world IIRC) and it might not solve your problem which I'm confident is some sort of .ini ordering/file structure issue. However, we can't know for sure until you post the ini and screenshots or a detailed description of the problem you're having (no airports? trees on runway? Conflicting buildings? etc...).

I'm following this topic, I see you know about X-Plane, I started in November.
In the last 4 or 5 days I updated Global Scenery through Update Scenery Online, but one problem I noticed was not changed.
Well, I notice that airports are in correct location, with correct orientation, but no city streets, there is a shift.
I found situations where streets almost invaded runways.
In an airport that I know as well as in my city I made a comparison and I was able to confirm through Google Earth the divergence.
Is there anything to be done?

Thank you.

 

João Alfredo

Share this post


Link to post
Share on other sites
1 hour ago, Dumont said:

I'm following this topic, I see you know about X-Plane, I started in November.
In the last 4 or 5 days I updated Global Scenery through Update Scenery Online, but one problem I noticed was not changed.
Well, I notice that airports are in correct location, with correct orientation, but no city streets, there is a shift.
I found situations where streets almost invaded runways.
In an airport that I know as well as in my city I made a comparison and I was able to confirm through Google Earth the divergence.
Is there anything to be done?

Thank you.

 

João Alfredo

Unfortunately, I don't think there's much you can do. XPlane uses Open Street Map (OSM) data, which is generally pretty good, but can be inconsistent, especially outside of the US or Europe. Every now and then, you'll see roads in places they shouldn't be or small errors like that. You can try downloading the HD Mesh v3 tile for your location to see if that solves the problem (http://www.alpilotx.net/downloads/x-plane-10-hd-mesh-scenery-v3/). It also uses OSM but it's slightly older data that has been 'tweaked' a little, so your misplaced roads might be fixed by it.

If this doesn't work, you can try adding an 'Exclude' polygon in Overlay Editor (OE). It's pretty simple- just download OE and open your airport and put an 'Exclude: Roads' polygon in the area where you see the problem road. This way, no roads at all will show up where you have this polygon. There are a few tutorials for how to do this with OE, but you should be able to figure it out easily as the interface is pretty simple. 

All this being said, you shouldn't see instances of roads going over airports, with normal cars driving around on the runway. Is this what you're seeing, or are your roads simply mis-aligned or cut off unrealistically? If the roads are showing on the airport tarmac, it might be a layering issue. Make sure all your airports, including "Global Airports" are moved to the top of the ini file in your scenery folder.

Which airport are you seeing these problems at? I'll load them up in my sim to see if I have these issues too. 

Share this post


Link to post
Share on other sites
9 hours ago, JustanotherPilot said:

I have just learned that HD Global scenery 3 is not compatible with XP11.

Where did you "learn" that? (and it is called - if you mean that - HD Mesh Scenery v3 ... nut much "global" in that name).

Please read this pinned topic here for more details on this "compatibility" topic:

 

Share this post


Link to post
Share on other sites
8 hours ago, hamoody said:

Unfortunately, I don't think there's much you can do. XPlane uses Open Street Map (OSM) data, which is generally pretty good, but can be inconsistent, especially outside of the US or Europe. Every now and then, you'll see roads in places they shouldn't be or small errors like that. You can try downloading the HD Mesh v3 tile for your location to see if that solves the problem (http://www.alpilotx.net/downloads/x-plane-10-hd-mesh-scenery-v3/). It also uses OSM but it's slightly older data that has been 'tweaked' a little, so your misplaced roads might be fixed by it.

If this doesn't work, you can try adding an 'Exclude' polygon in Overlay Editor (OE). It's pretty simple- just download OE and open your airport and put an 'Exclude: Roads' polygon in the area where you see the problem road. This way, no roads at all will show up where you have this polygon. There are a few tutorials for how to do this with OE, but you should be able to figure it out easily as the interface is pretty simple. 

All this being said, you shouldn't see instances of roads going over airports, with normal cars driving around on the runway. Is this what you're seeing, or are your roads simply mis-aligned or cut off unrealistically? If the roads are showing on the airport tarmac, it might be a layering issue. Make sure all your airports, including "Global Airports" are moved to the top of the ini file in your scenery folder.

Which airport are you seeing these problems at? I'll load them up in my sim to see if I have these issues too. 

Image LOWS before Scenery update, street invade runway.
In Global Scenery update, partially resolved.
About update here:
Http://www.x-plane.com/kb/updating-scenery-x-plane-11/
 

Image here:

https://1drv.ms/f/s!Ahop1Lb2NA4hgZ5sO_swgGgek0MHxg

Goianésia SWGO on XP-11 appears unpaved runway, with WED changed to asphalt.
Blue dots reference avenues, red dots, runway.
I live in Goianesia from 1976 until 2002 I flew ultralight, so labyrinthine attacked, so better stop flying so I can wait for my grandchildren, Pedro, 4 years and Alice 2 years are more fun than ultralight!

 

João Alfredo

Edited by Dumont
add data

Share this post


Link to post
Share on other sites
1 hour ago, Dumont said:

Goianésia SWGO on XP-11 appears unpaved runway, with WED changed to asphalt.

Blue dots reference avenues, red dots, runway.
I live in Goianesia from 1976 until 2002 I flew ultralight, so labyrinthine attacked, so better stop flying so I can wait for my grandchildren, Pedro, 4 years and Alice 2 years are more fun than ultralight!

 

A simple look at OpenStreetmap / OSM (where all the road data is coming from) shows me, that the airport(!) in X-Plane seems to be completely misaligned (at least by comparing it to your screenshot).

So, quite likely, the roads are correct, but the airport is not! The airport might need some update via WED (especially re-aligned and placed in the right location AND maybe given a correct boundary) and then re-submitted to the Scenery Gateway (https://gateway.x-plane.com/).

 

Share this post


Link to post
Share on other sites
On 24/04/2017 at 11:46 AM, hamoody said:

Wait, hold on, why would you need to delete your custom scenery folder? It would do literally nothing beyond making it necessary for you to download every scenery you ever downloaded again. Don't do that- it would just be a pain and wouldn't solve anything. You can try deleting 'Global Airports', located within your custom scenery folder, and re-running the installer to get a fresh Global Airports folder (about 145 MB). After doing that, delete your scenery.ini folder, run XP so that it regenerates, and double/triple check your scenery order. There are plenty of guides, but it should generally go:

  • Airports/Cities
  • Textures (like orthophotos)
  • Mesh

Also, you might have misunderstood. HD Mesh v3 (I'm assuming that's what you're talking about) is 100% compatible with XP11. Nothing about the scenery processing structure changed between XP10 and XP11. It just isn't as up-to-date as XP11's default mesh, simply because HD Mesh v3 has older data from ~2013 (so a road built in 2015 wouldn't appear using HD Mesh v3, while it would appear by default in XP11). You can still install and load HD Mesh V3 just fine in XP11- I'm using a few tiles myself actually.

Also, I'm not sure I understand what your issue is. What do you mean that airports don't appear right? Some screenshots would be helpful (Press shift+space, they'll appear in your main XP folder's 'Output' subfolder). Also, you should give us your scenery.ini file. Just copy the contents and past them either here or at pastebin.com. 

Now, deleting/reinstalling your default scenery folder *might* be what you're looking to do, but that's a huge download (~60GB for the whole world IIRC) and it might not solve your problem which I'm confident is some sort of .ini ordering/file structure issue. However, we can't know for sure until you post the ini and screenshots or a detailed description of the problem you're having (no airports? trees on runway? Conflicting buildings? etc...).

Hi,

To illustrate my problem these images will help, the first is XPlane 11 showing YSSY Kingsford Smith Airport v1.50 by ISDG installed -  notice the lack of water in Botany Bay. The secons shows how it is supposed to look. In another post, a user posted the default XP11 scenery which is identical to image 2 so I now I have messed up big time..mesh maybe? . I have slowly worked through all my installed custom scenery and mesh and libraries, disabling them one by one but still no improvement.

My XP11 YSSY ISDG v1.50

B733_29_zpsp3socovs.png

Real World and default scenery

botany%20bay_zpstwhakz4j.jpg

A big difference!

I just can't track down my error.

 

steve

Share this post


Link to post
Share on other sites

I haven't read the entire thread but what happens if you temporarily move the YSSY scenery ?  Run xp again.  Is the bay back?

Share this post


Link to post
Share on other sites
6 hours ago, ryanbatcund said:

I haven't read the entire thread but what happens if you temporarily move the YSSY scenery ?  Run xp again.  Is the bay back?

No Effect, still have no water, which makes me think it's a mesh/ortho problem..but where is it hiding.

Share this post


Link to post
Share on other sites
On 24/04/2017 at 11:19 AM, alpilotx said:

A simple look at OpenStreetmap / OSM (where all the road data is coming from) shows me, that the airport(!) in X-Plane seems to be completely misaligned (at least by comparing it to your screenshot).

So, quite likely, the roads are correct, but the airport is not! The airport might need some update via WED (especially re-aligned and placed in the right location AND maybe given a correct boundary) and then re-submitted to the Scenery Gateway (https://gateway.x-plane.com/).

 

Thanks Andras, I moved the airport to the correct location, now a small inconvenience is that in the correct place there is a little pronounced ripple in the airstrip, but not something so serious that prevents from using, in other XP-11 default scenarios already many similarities.
What tool can I use to fix it, I do not think WED?

 

João Alfredo

Share this post


Link to post
Share on other sites
17 hours ago, Dumont said:

Thanks Andras, I moved the airport to the correct location, now a small inconvenience is that in the correct place there is a little pronounced ripple in the airstrip, but not something so serious that prevents from using, in other XP-11 default scenarios already many similarities.
What tool can I use to fix it, I do not think WED?

There are no official tools to do this, nor is it really recommended (especially if we only talk about minor issues!) ... there are a few community built "tools" to mess with the mesh, but doing this has a few implications which have to be considered ( --> http://www.alpilotx.net/faq/modifying-the-mesh-for-your-own-projects/)

Other than that, its important to upload your modification / correction to the official Laminar Scenery Gateway. This ensures that:

  • others see (enjoy) this correction too (as Laminar ships updates every now or then with X-Plane updates)
  • and when ever we (I or Lamianr) cut a new base mesh, this will be respected and the airport area gets some smoothing treatment in the mesh (and gets an airport base terrain type) within the boundaries of the airport. This usually also removes all or most "ripples" / annoyances in the mesh.

 

Share this post


Link to post
Share on other sites
6 hours ago, alpilotx said:

There are no official tools to do this, nor is it really recommended (especially if we only talk about minor issues!) ... there are a few community built "tools" to mess with the mesh, but doing this has a few implications which have to be considered ( --> http://www.alpilotx.net/faq/modifying-the-mesh-for-your-own-projects/)

Other than that, its important to upload your modification / correction to the official Laminar Scenery Gateway. This ensures that:

  • others see (enjoy) this correction too (as Laminar ships updates every now or then with X-Plane updates)
  • and when ever we (I or Lamianr) cut a new base mesh, this will be respected and the airport area gets some smoothing treatment in the mesh (and gets an airport base terrain type) within the boundaries of the airport. This usually also removes all or most "ripples" / annoyances in the mesh.

 

Well, I accessed alpilotx, and I was quite impressed with the complexity to change mesh, I watched Joz's video as well.
I decided to send a file to LR with this, the airport in the correct position and dimensions, I already sent it.
Is approval or not a process that takes days or months?
Thank you very much.

João Alfredo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now