Sign in to follow this  
johnfo

Issue with Trees on Freeware Scenery Addon

Recommended Posts

Hello 

I have recently installed a piece of freeware scenery into my FSX:SE addon scenery folder. However, there are trees literally all over the airport except the runway. I cannot see the control tower from the terminal stands as there are so many trees. 

I have read about the lumberjack tool; but not actually sure it will work for my situation. The tool appears to be there to remove trees from around the runway area (in particular the RWY threshold) and does not mention anything regarding taxiways and other areas. Is there anything I can do with this tool to ensure all of the trees are cleared from my new freeware airport? 

In the event that this tool does not work, should I simply just delete the scenery files from the addon scenery folder in order to uninstall the addon scenery or is there another way I should be doing this? 

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thank you for the reply but no, I do not have either of those installed or any other scenery addons. 
 

Share this post


Link to post
Share on other sites

Check your terrain.cfg in your main sim folder, surch for "airport background" ( about 26 entries ) and look for the render priority, it should be 200000 instead of 20000 and if in the header is the word "maskclass" then the remaplandclasstype should be changed from "none" to "airport", this is an old FSX bug.

Herman

Share this post


Link to post
Share on other sites

OK I will have a look when I get home this evening and report back. Thanks again for the reply - fingers crossed it works. 

Share this post


Link to post
Share on other sites

Which addon are you speaking about specifically?  Perhaps you just need an exclude...

Share this post


Link to post
Share on other sites
9 hours ago, electricman said:

Check your terrain.cfg in your main sim folder, surch for "airport background" ( about 26 entries ) and look for the render priority, it should be 200000 instead of 20000 and if in the header is the word "maskclass" then the remaplandclasstype should be changed from "none" to "airport", this is an old FSX bug.

Herman

Unfortunately this did not work - the airport also has some buildings in the middle of it too as tough it has been placed in the middle of a field and the trees/building have not been taken away from that part of the map

Share this post


Link to post
Share on other sites

I just downloaded and installed the FSX scenery for EGNT.  This was one .bgl file that had updated gates and fuel positions.  I saw no extra trees on the airport property.  The file name was egnt_afcad.zip

 

I also have my buildings and trees per cell at a low number in the FSX.cfg

[TERRAIN]
IMAGE_PIXELS_FOR_AUTOGEN_POLYGONS=512
TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=500
TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=500
LOD_RADIUS=4.500000
MESH_COMPLEXITY=50
MESH_RESOLUTION=21
TEXTURE_RESOLUTION=26
AUTOGEN_DENSITY=5
DETAIL_TEXTURE=1
WATER_EFFECTS=4

Share this post


Link to post
Share on other sites

I have just checked my .cfg file and below is what I have, I seem to be missing the first three lines as yours has. couldyou shed any light on this? 

[TERRAIN]
LOD_RADIUS=4.500000
MESH_COMPLEXITY=75
MESH_RESOLUTION=20
TEXTURE_RESOLUTION=26
AUTOGEN_DENSITY=3
DETAIL_TEXTURE=1
WATER_EFFECTS=7

Share this post


Link to post
Share on other sites
14 minutes ago, johnfo said:

I have just checked my .cfg file and below is what I have, I seem to be missing the first three lines as yours has. couldyou shed any light on this? 

[TERRAIN]
LOD_RADIUS=4.500000
MESH_COMPLEXITY=75
MESH_RESOLUTION=20
TEXTURE_RESOLUTION=26
AUTOGEN_DENSITY=3
DETAIL_TEXTURE=1
WATER_EFFECTS=7

It's probably because I added those lines.  Copy them and add to your FSX.cfg  Maybe it will help with your

situation.

Share this post


Link to post
Share on other sites

Does the add on have 2 .bgl files, one with the airport ICAO and some letters or numbers and a second one with the same letters and numbers but with the letters _CVX.bgl? the second one is absolutely necessary because that is the airport background taking away all autogen.

Herman

PS as for the max trees and max buildings in Charliearon's cfg, they are only there for a low end or medium end PC and are basically the same as reducing your autogen slider, no need for them thus.

And for the first entry, that isn't even in the FSX SDK code so it will not be recognized by FSX and serves no purpose what so ever. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Did a search on flightsim and the only EGNT I find for FSX is an AFCAD file without an airport background, that could explain your problem, this type off file can be put in the AI airports folder if you have traffic 360 or my traffic but not where it says it should go.

http://www.freewarescenery.com/fsx/uk.html here you can find better stuff;

Herman

Share this post


Link to post
Share on other sites
4 hours ago, electricman said:

Does the add on have 2 .bgl files, one with the airport ICAO and some letters or numbers and a second one with the same letters and numbers but with the letters _CVX.bgl? the second one is absolutely necessary because that is the airport background taking away all autogen.

Herman

PS as for the max trees and max buildings in Charliearon's cfg, they are only there for a low end or medium end PC and are basically the same as reducing your autogen slider, no need for them thus.

And for the first entry, that isn't even in the FSX SDK code so it will not be recognized by FSX and serves no purpose what so ever. 

This is the problem - there is only one .bgl file. There is no other file with _CVX.bgl. 

I will remove this addon scenery and use the site that you have provided for any future downloads.
One final question, if there are two .bgl files should I paste them both straight into the '/Addon Scenery/' folder or should one of them go somewhere else?

Thank you for looking that up for me!   

Share this post


Link to post
Share on other sites

They should both go into the addon scenery/scenery folder or you create a new folder in the addon scenery folder with the name of the airport and in that folder you create a new scenery and texture folder, then put the files into that scenery folder and add the folder in FSX to your scenry librarie, the first way is the easiest.

Herman

Share this post


Link to post
Share on other sites

OK thank you for your help with this. Much appreciated. I'll hopefully get this sorted tonight. 
Thanks again. 

Share this post


Link to post
Share on other sites

A CVX file is not an absolute requirement, plenty of updated AFCADs don't include a CVX file. In such a case FSX will use the default airport background.

If you post a link or at least the file name of the download then some of us can test it to see if the same problems appear.

Sometimes problems are caused by having more than one addon installed for the same airport. There's a utility called Simple Airport Scanner that helps to find duplicated addon files.

Share this post


Link to post
Share on other sites

egnt_afcad.zip at flightsim.com   I'll look here also!  Yep, in the Library here, also!

Share this post


Link to post
Share on other sites
23 hours ago, fshobby said:

A CVX file is not an absolute requirement, plenty of updated AFCADs don't include a CVX file. In such a case FSX will use the default airport background.

If you post a link or at least the file name of the download then some of us can test it to see if the same problems appear.

Sometimes problems are caused by having more than one addon installed for the same airport. There's a utility called Simple Airport Scanner that helps to find duplicated addon files.

This is link for the .exe file I downloaded and installed. 

http://www.arm-computers.co.uk/Airfield_Index/Index_1/Airfields_4_/airfields_4_.html

The first link is where I downloaded the scenery from. Let me know what you find out. Thanks 

 

Share this post


Link to post
Share on other sites

I have just found that the problem I was having was due to a missing texture file which for some reason does not agree with my system; I have just removed that freeware addon and used a different one from another developer - problem solved. I now have a fully functioning EGNT addon airport.

Thanks to you guys who commented and helped me out here, much appreciated! 

Share this post


Link to post
Share on other sites
2 hours ago, johnfo said:

This is link for the .exe file I downloaded and installed. 

http://www.arm-computers.co.uk/Airfield_Index/Index_1/Airfields_4_/airfields_4_.html

The first link is where I downloaded the scenery from. Let me know what you find out. Thanks

I took a look at this airport. The reason you get trees is that it requires that you also install photo scenery product. This is mentioned in the pdf manual:

Other Required Scenery
Horizon GenX Photo scenery Volumes 3 together with GenX Mesh

The scenery excludes the default airport background. Photoscenery will suppress autogen but if you didn't install the photoscenery then because the default background is excluded, the autogen will pop up through the airport aprons.

2 hours ago, johnfo said:

 

I have just found that the problem I was having was due to a missing texture file which for some reason does not agree with my system; I have just removed that freeware addon and used a different one from another developer - problem solved. I now have a fully functioning EGNT addon airport.

 

Good to hear it's resolved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this