vortex681

DX10 Anti Aliasing settings in Controller

Recommended Posts

Steve, I recently updated successfully to the Windows 10 Creators Update. One minor issue was that is set all of my NVIDIA Control Panel and Profile Inspector settings to default. I previously used 4x sparse grid supersampling with 8x CSAA set in the DX10 Anti Aliasing box in the DX10 Controller and this seemed to work well with my 2560x1440 monitor. After the Windows Update, I decided to try just FXAA in the NVIDIA Control Panel for FSX and it looks just as good to my eyes and gives about 15-20 FPS more. What setting would you recommend in the DX10 Controller for DX10 Anti Aliasing using FXAA?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If using FXAA then I would try with no AA in the controller, if that doesn't work then change it to 4x.

Share this post


Link to post
Share on other sites
1 hour ago, SteveFx said:

If using FXAA then I would try with no AA in the controller, if that doesn't work then change it to 4x.

Thanks!

Share this post


Link to post
Share on other sites

15-20 FPS more---WOW!

Please post your settings in the Nvidia-CP and Nvidiainspector.

I think that many of us are looking for the best performance settings.

Mike

  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, bigmike said:

Please post your settings in the Nvidia-CP and Nvidiainspector.

Mike, as I said in the first post, the Creators Update reset all of my NVIDIA Control Panel and Profile Inspector settings to default. I'm still playing with the options but, so far, the only changes I have made are in the NVIDIA Control Panel to the Microsoft Flight Simulator 10 profile (under the Program Settings tab):

Anisotropic filtering - 8x

Antialiasing - FXAA - On

Multi-display/mixed-GPU acceleration - Single display performance mode

Vertical sync - Fast

Everything else in the NVIDIA Control Panel and Profile Inspector I've left at default.

The FXAA antialiasing softens the image slightly but the anisotropic filtering sharpens it again. FXAA has only a small performance penalty compared to the other antialiasing modes and it doesn't look much different to me. I had some screen tearing with vsync off and the last setting, Fast vsync, is only supposed to work well for FPS at multiple times the monitor refresh rate but seems to be doing the job with only a few FPS drop over having vsync off. I've been using the RealAir Legacy v2 at a local airport in the ORBX England region as a rough benchmark and was previously getting an average of about 40-45 FPS. I am now seeing 55-60 FPS average (both according to the FSUIPC log). I'm not specifically chasing FPS as FSX ran smoothly before but better performance is always a bonus and I was surprised to see such a boost. Before the Creators Update, I had quite a few tweaks in the NVIDIA Profile Inspector but it now appears that they weren't necessary. If I find any better settings, I'll let you know.

  • Upvote 1

Share this post


Link to post
Share on other sites

So do you not use NVInspector at all and only NV Control panel?

Also I presume you are not limiting fps externally or in sim?

Would be good to see all your Control Panel settings and your FSX.cfg file to understand your complete picture. Also what CPU /clock rate, GPU and memory do you use, as all these things can affect fps within a system.

Cheers,

Stuart

 

Share this post


Link to post
Share on other sites
4 hours ago, STUART_H said:

So do you not use NVInspector at all and only NV Control panel?

Correct.

4 hours ago, STUART_H said:

Also I presume you are not limiting fps externally or in sim?

Correct.

4 hours ago, STUART_H said:

Would be good to see all your Control Panel settings and your FSX.cfg file to understand your complete picture.

The only changes I've made in the Control Panel are those listed in my previous post. My fsx.cfg is default apart from the addition of:

[Display]
WideViewAspect=True
ForceVCShadowMap=1

I use FSX:SE so the highmemfix entry isn't required. I had quite a few additional tweaks to the fsx.cfg on my old system but the FSX installation on my new build seems to run well without them.

4 hours ago, STUART_H said:

Also what CPU /clock rate, GPU and memory do you use, as all these things can affect fps within a system.

 i7-6700k, Asus Maximus VIII Hero, 16GB RAM, MSI GTX 970, Windows 10 Pro 64-bit with the Creators Update. I'm currently running the CPU at stock speeds. I will probably overclock when I become unhappy with the performance but it seems to be running well enough at the moment.

I have Active Sky Next and FS Force (for my FF joystick) running and I have ORBX EU England installed. I use REX 4 textures, Steve's Fixer with the Cloud Shadows add-on and FaceTrackNoIR for head tracking. I'll post my in-game settings once my Flickr account behaves itself.

Share this post


Link to post
Share on other sites

Thanks for your comprehensive reply.

One question: you say you "use FSX:SE so the highmemfix entry isn't required”. I've never seen that FSX:SE does not need that entry, perhaps I missed something. Do you recall where that was documented?

Stuart

Share this post


Link to post
Share on other sites
30 minutes ago, STUART_H said:

One question: you say you "use FSX:SE so the highmemfix entry isn't required”. I've never seen that FSX:SE does not need that entry, perhaps I missed something. Do you recall where that was documented?

See: https://dovetailgames.kayako.com/knowledgebase/article/View/64/16/what-exactly-have-you-updated-in-microsoft-flight-simulator-x-steam-edition-compared-to-the-microsoft-supplied-boxed-version-of-fsx

 - about half-way down under "Default System-Setting Alterations".

Share this post


Link to post
Share on other sites

Cheers,

Guess it doesnt matter whether the entry exist or not then.

Share this post


Link to post
Share on other sites
21 hours ago, vortex681 said:

Mike, as I said in the first post, the Creators Update reset all of my NVIDIA Control Panel and Profile Inspector settings to default. I'm still playing with the options but, so far, the only changes I have made are in the NVIDIA Control Panel to the Microsoft Flight Simulator 10 profile (under the Program Settings tab):

Anisotropic filtering - 8x

Antialiasing - FXAA - On

Multi-display/mixed-GPU acceleration - Single display performance mode

Vertical sync - Fast

Everything else in the NVIDIA Control Panel and Profile Inspector I've left at default.

The FXAA antialiasing softens the image slightly but the anisotropic filtering sharpens it again. FXAA has only a small performance penalty compared to the other antialiasing modes and it doesn't look much different to me. I had some screen tearing with vsync off and the last setting, Fast vsync, is only supposed to work well for FPS at multiple times the monitor refresh rate but seems to be doing the job with only a few FPS drop over having vsync off. I've been using the RealAir Legacy v2 at a local airport in the ORBX England region as a rough benchmark and was previously getting an average of about 40-45 FPS. I am now seeing 55-60 FPS average (both according to the FSUIPC log). I'm not specifically chasing FPS as FSX ran smoothly before but better performance is always a bonus and I was surprised to see such a boost. Before the Creators Update, I had quite a few tweaks in the NVIDIA Profile Inspector but it now appears that they weren't necessary. If I find any better settings, I'll let you know.

Thank you very much.

But no improvement here with your settings.

You have AA and Anisotrop ticked in FSX and 4x in the Fixer?

Mike

Share this post


Link to post
Share on other sites
18 hours ago, bigmike said:

You have AA and Anisotrop ticked in FSX and 4x in the Fixer?

Yes to both. I can only think that the performance boost has been down to using FXAA instead of sparse grid supersampling. The improvements happened after installing the Creators Update but I'm not sure if that made any difference or if it's just that it forced me to try some different settings. Either way, I'm not complaining!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now