superflygary

Voice isn't heard no matter what I do.

Recommended Posts

Hi there,

I'm still on the last few days of my free trial, my issue is my voice will not get through to P2ATC.  I'm running xplane 11 on  windows 10 home version. So far I have worked through everything I have been able to find in the manual and on the web.  I have checked my language pack is set to US English, and downloaded the speech pack. I have my audio card set to primary sound driver and the same in the p2atc config. I have checked the microphone using the "listen to" on sound card setting and can hear my voice. I can speak into the mic and have my PC respond when I say for example "open chrome"  it hears me and opens chrome. I have used the grammer help, when I press practice, then hold down the PTT button for a second then start speaking, then release the PTT button a second after, in the text box I see "full txt"  and that is it.

Is there anything that I'm missing, or any other info you need to try and help me out?  I had my first full ATC controlled flight last night using the sayit button and it was great fun, I can see me really enjoying this if I can get my voice to be recognized.

Thanks for any help

superfly

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

To work with P2A, the microphone must be set to be the default recording device.  Double check that setting in the Windows Sound settings.

Also, try running the program as Administrator by right-clicking the .exe file or taskbar icon and select "Run as Administrator".  If there is some access issue causing the problem, this usually fixes it.

When you try practicing, just say "Say Altimeter" as that is the simplest phrase that would be understood.  Also, hold the PTT button down for only a fraction of a second before speaking rather than a full second.  Just long enough for the button press to register...about 1/5 of a second.

IF the above doesn't work, try connecting to the SIM in the main window and let me know what happens.  That sometimes helps in trouble shooting.

Thanks,

Dave

Share this post


Link to post
Share on other sites

Thanks Dave,

Yes the microphone is set to default, I have tried to run as administrator, but that was the first thing I tried and perhaps the other settings I changed while troubleshooting would have fixed that.

I tried the "say altimeter" a bunch of times with different key press durations. So I know it's just not hearing me.

I've also connected to the sim and tried as well.

Unfortunately I'm going away for the weekend and my trial will be over when I return, maybe I'll have time to try running as admin before I go, if the wife gives me a few minutes :)

Thanks for the reply.

Gary

 

 

Share this post


Link to post
Share on other sites

Gary,

When you return, send me an email (admin @ pilot2atc.com) and I'll see what I can do to get you going.

Dave

Share this post


Link to post
Share on other sites

Hi Dave,

I've just installed Pilot2ATC demo and am having the same problem.

My microphone works fine except in Pilot2ATC, where nothing is recognised except pushing the PTT button in the sim makes the Pilot2ATC button highlight in green to indicate it's receiving.

I have tried running as admin, changing audio to 44100, default device etc etc and nothing has worked.

Thanks for your help,
Toby

 

Share this post


Link to post
Share on other sites

I found the fix for me. It was to disable enhancements on my default sound device. Once I did that, p2atc started hearing the mic.

Share this post


Link to post
Share on other sites

Unfortunately, same problem here. Microphone works fine with TeamSpeak, Skype, SQUAD and Battlefield (both ingame voice) and others. But does not trigger any reaction of Pilot2atc.

Windows 10, MSI Gaming Pro Carbon z470, nVidia Geforce 1080, AMD Ryzen 5 2600x, Realtec Audio drivers, Sennheiser Headset

Any suggestions are welcome. Thx in advance.

Share this post


Link to post
Share on other sites

Assuming you are fully connected to the SIM (Connect button is GREEN and there are 3 aqua lines in the Speech Text box), then here are some other things to check.

1.    SWITCH SETTINGS: Check to be sure the Power indicator in the bottom left of the main P2A screen is  green.  If not, then you need to turn on the battery switch and avionics switch in the aircraft, or if that doesn’t turn it green, check the 2 options “Ignore Battery Switch” and “Ignore Avionics Switch” in the Config P2A Setup panel.
2.    VALID CALL SIGN: Make sure you are using a valid call sign by changing it to the default Mfg: Beech; Tail Number: N431VB and pressing the Save Button.  You can send me a screenshot of this page and I will let you know if there is a problem with the call sign.
3.    VALID FREQUENCY: Be sure you have a valid frequency showing in the Active frequency display.  Open the Radio Panel and check that the frequency selected has a valid controller assigned.  Try swapping the active and standby frequencies a couple of times.
4.    PTT BUTTON: Use the PTT button on the main screen to eliminate the possibility of it being the Joystick button setup as the issue
5.    VALID PHRASES: Make sure the phrase you are using is appropriate for the controller.  “Say Altimeter” should work with all controllers, so use it.
6.    VOLUME SETTINGS: Check the Windows Volume Mixer and be sure Pilot2ATC volume is turned up. (RIght click on the speaker icon in the task bar and select Volume Mixer).  Also check the volume of the voices in P2A Config.  On the Communications tab of the Sound dialog, be sure "Do Nothing" is checked for when Windows detects Communications activity.
7.    SOUND DRIVERS AND ADD ON PROGRAMS - Many PCs come with Sound Add On programs from the manufacturer that are run at startup.  Some of these programs may "Capture" the microphone and prevent Pilot2ATC from hearing it.  Also, some addons may have such features.  Check to be sure there are not other sound programs running.  Also be sure that you have the latest Audio Drivers for your Microphone installed.
8.    GRAMMAR HELP SCREEN AND DIAGNOSTICS: Try using the Grammar Help screen.  
⦁    Press the Grmr Help button to the right of the Flight Plan
⦁    Pess the Practice button 
⦁    Take a screenshot of the resulting Message box with the connection information and email to me 
⦁    Try saying "Say Altimeter" with no other words.  It should be recognized.  Let me know the result.
⦁    If not being recognized, press the "Replay" button and see what your voice sounds like.  If no sound

Share this post


Link to post
Share on other sites

Hello Dave,
thank you for your response and service. It fits this awsome software that I appreciate very much! Lets go on to the issue:

1.    SWITCH SETTINGS: Check to be sure the Power indicator in the bottom left of the main P2A screen is  green.
check! it´s green
2.    VALID CALL SIGN: Make sure you are using a valid call sign by changing it to the default
check! Callsign is Beech N45XS
3.    VALID FREQUENCY: Be sure you have a valid frequency showing in the Active frequency display. Open the Radio Panel and check that the frequency selected has a valid controller assigned.  Try swapping the active and standby frequencies a couple of times.
check! Freq is valid, actice and standby swapped a couple of times. ATIS freq returns ATIS information without any prob.
4.    PTT BUTTON: Use the PTT button on the main screen to eliminate the possibility of it being the Joystick button setup as the issue
check! PTT button turns to green when pressed either assigned key or P2A screen. No prob.
5.    VALID PHRASES: Make sure the phrase you are using is appropriate for the controller.  “Say Altimeter” should work with all controllers, so use it.
check! Pressing PTT and saying "say altimeter" returns no reaction. If I use the "say it" option, everything works fine, the controller responds as estimated.
6.    VOLUME SETTINGS: Check the Windows Volume Mixer and be sure Pilot2ATC volume is turned up. (RIght click on the speaker icon in the task bar and select Volume Mixer).
check! all volumes on 100%
Also check the volume of the voices in P2A Config.
check! all volumes on 75% and I can hear them.
On the Communications tab of the Sound dialog, be sure "Do Nothing" is checked for when Windows detects Communications activity.
set and checked!
7.    SOUND DRIVERS AND ADD ON PROGRAMS - Many PCs come with Sound Add On programs from the manufacturer that are run at startup.  Some of these programs may "Capture" the microphone and prevent Pilot2ATC from hearing it.  Also, some addons may have such features.  Check to be sure there are not other sound programs running.  Also be sure that you have the latest Audio Drivers for your Microphone installed.
Latest drivers are installed, Dave. I have no idea what addons are running. Do you mean Realtek Audio Manager?
"Nahimic 2+" was delivered with the Mainboard. I turned it off and on with no difference in result.
btw: Windows 10 does not list P2A as an app thats has control over the microphone. Is this essential? If so: how can I add it to that list?

8.    GRAMMAR HELP SCREEN AND DIAGNOSTICS: Try using the Grammar Help screen.  
⦁    Press the Grmr Help button to the right of the Flight Plan
⦁    Pess the Practice button 
⦁    Take a screenshot of the resulting Message box with the connection information and email to me 
⦁    Try saying "Say Altimeter" with no other words.  It should be recognized.  Let me know the result.
⦁    If not being recognized, press the "Replay" button and see what your voice sounds like.  If no sound
I followed all steps. Will send you my screenshots. "Say altimeter" does not trigger anything. Replay returns nothing. It´s just as if my mic is simply cut off...

 

Share this post


Link to post
Share on other sites

#7 - Some audio programs take exclusive control of the microphone, so I would recommend turning off any that may be doing that.  I don't think the Realtek Audio Mgr would be a problem, but I would check all its settings.  The other audio programs I would try running without.

#8 results do indicate that the Mic is not getting through to P2A.  

Here are some things you may have already checked but might be causing this problem:

⦁    Be sure your microphone is not muted on the device itself
⦁    Recheck that the microphone is set as the Default recording device in Windows. 
⦁    In the Microphones Properties: 
⦁    1)Check the volume level of the Microphone
⦁    2) On the Advanced tab, be sure the Exclusive Mode option is unchecked 

⦁    There have been a few users with USB headsets that worked on USB 2 ports and not USB 3 ports, so if you have a USB headset, try changing ports.
⦁    Another user fixed it. by uninstalling a couple of bundled Asus sound effects programs and the program then started hearing speech but could not recognise it. He then ran through the speech recognition training and it then could recognise the commands properly.

Another user had a new usb headset. It plugged in and was recognized as a headset, but wouldn't work. He finally installed the gaming software/drivers that came with the headset, and all the problems were resolved.

Share this post


Link to post
Share on other sites

The screenshots look good and confirm what you were saying.  It's probably that the Microphone level is very low.

If you are using a headset, Windows may recognize that and put a set of "level" settings on the Levels tab of the Headphone Properties.  To set these, select the Headset in playback devices and press "Properties". Select the Levels tab.  Be sure all levels are turned up, especially the Microphone setting here on the Playback device. 
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now