jandjfrench

GFWL Error after selecting with Toolkit

Recommended Posts

Hi,

Attempt to insert error image.

https://app.box.com/s/h297m5a0pqwh3ycqsefvecybh6yzmqy5

Flight works fine in Non-GFWL and Unmodified mode but not GFWL.  I believe that I can reinstall Flight using GFWL Marketplace and it will run without problems but once I use Toolkit it fails.  Any sugestions as to what to try?

Jim F.

Edited by jandjfrench

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

yes, the toolkit replaces a default file to run. So you can either use the default install or use the toolkit version but not both at the same time.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi AirWay,

I don't know what you mean when you refer to both at the same time.  Several years ago, when I first became aware of Toolkit,  I installed it and was able to select either GFWL, Unmodified, or NonGFWL mode with Addon Manager.  Each mode worked appropriately after selection.  After installing the converted FSX World scenery I had problems in certain areas and after multiple re-installs of Flight and various versions of Toolkit I'm no longer able to fly in GFWL mode after Toolkit is installed.  On a recently acquired computer with a fresh install of Win 7 Pro. I installed Flight and using Toolkit .31 I had the same problem.  Now, after removing Flight and Toolkit I've reinstalled Flight and all Addons that I previously purchased from Marketplace and Flight works correctly.  My concern is that by installing Toolkit I will once again be unable to use GFWL mode.  I'm hoping that the error info I posted will help in solving my problem.

Jim F.

 

Share this post


Link to post
Share on other sites

I think I have had other people report GFWL mode crashing.  I don't know why, and am not sure when I will have a chance to look at it.  Do older versions of the toolkit work?  Would be nice to know which version broke it.

Share this post


Link to post
Share on other sites
7 hours ago, stonelance said:

Do older versions of the toolkit work?  Would be nice to know which version broke it.

I read this an hour ago and tried toolkit versions .28, .31 & .32 in both modes GFWL and non GFWL. I didn't have failures in any case. The only thing I notice in versions .31 and .32 is the auto login doesn't work. But this is a minor issue that doesn't bother me too much. These 3 versions are very reliable.

Oscar

Share this post


Link to post
Share on other sites

Hi,

On the, new to me, computer I tried installing .32 prior to installing Flight.  The Toolkit install went fine and it checked for and added various files but it detected that Flight was not installed.  I'm not sure exactly what I did next but I did download Flight from the Marketplace.  I think I started Flight to check it before running Addon manager and it worked fine.  I don't recall the exact order but at some point after choosing the various modes The GFWL no longer worked.  I tried uninstalling both Flight and Toolkit several times and reinstalling Toolkit .31 and .32 and the problem remains.  I have reinstalled Flight again and it works fine but am holding off reinstalling any version of Toolkit until I have an idea what to check for if the problem recurs.  I understand that upon removing Flight some files are not removed but no problems after reinstall.  I'm not sure that something is not leftover from Toolkit that may cause problems after it is reinstalled.  On my main computer I have the same problem and believe I tried .28 on that as well but the problem remains.  I have Win 7 Pro on both computers and both AMD and Intel CPUs.  

Jim F.

Share this post


Link to post
Share on other sites

The toolkit shouldn't install unless Flight is already installed, and uninstalling Flight after the toolkit is installed may require reinstalling the toolkit.

Share this post


Link to post
Share on other sites

That was what I experienced.  I'm not sure which version of Toolkit I used but when I ran setup without Flight the different steps of the install were displayed sequentially and at some point the notice that Flight wasn't found was displayed.  If I recall correctly I tried to install the free version and was asked for the product key so I went with my marketplace version.  My recollection may not be correct as I've tried many different ways to solve the problem.  During one of my install attempts I was presented with my product key which I've copied.  It may come in handy.  I don't understand the significance of the missing "MSCVCR100.dll" referenced in image included in my first post of this thread is but seems related to the problem I'm having.  After Googling the missing file it seems it's included in 2 different 64 bit download package versions and I didn't know which to try.  The file is not in my System32 folder. 

Share this post


Link to post
Share on other sites
19 hours ago, jandjfrench said:

I don't understand the significance of the missing "MSCVCR100.dll" referenced in image included in my first post of this thread is but seems related to the problem I'm having.  After Googling the missing file it seems it's included in 2 different 64 bit download package versions and I didn't know which to try.  The file is not in my System32 folder. 

This error seems to occur when the Microsoft Visual C++ 2010 Redistributables are missing. So your best bet is to try and install that.

Share this post


Link to post
Share on other sites

Where do you see MSCVCR100.dll is missing?  In that first image I just see that it crashed inside of code in the dll, so not super useful.

The only difference between GFWL mode and Unmodified should be that the GFWL version ends up modifying the root FileLocator.config file in the Flight directory.  I don't believe it doesn't anything else, but I could be wrong.

Do you have addons installed and enabled in addon manager?  I would try disabling them all if you do.

Share this post


Link to post
Share on other sites

Sorry for not being clear.  I checked and MSCVCR100.dll was not in the ...system32 folder.  I've since installed both vcredist_x64.exe and vcredist_x86.exe at different times and no longer see the reference to a missing MSCVCR100.dll when I check the error report after Flight crashes in the GFWL mode.  I don't know what to try that would be helpful.  I've reinstalled both flight and various versions of Toolkit multiple times and haven't been able to solve the problem.  When I experienced the problem on the new computer I was really at a loss.  I'm concerned about deleting Flight again as Marketplace operation seems to be acting up.  

Share this post


Link to post
Share on other sites

Well it is called msvcr100.dll,  Maybe that is why you can't find it?  Uninstalling and reinstalling Flight won't fix anything so not point in doing that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now