DeCaf

Cannot get 777 to work in P3D v4

Recommended Posts

I just installed the PMDG 777 into Prepar3D v4 today, using the latest installers as available on my download page (under previous orders). 

From the Welcome Screen I select the PMDG 777 and click Ok.

Initially Prepar3D closed right after asking for the activation code. Then after a few attempts it closed without asking for the activation code, before showing the progress bar though.

After a few more attempts, it started asking for the activation code on each launch again, but this time the progress bar showed up and the aircraft loaded. 

But after loading almost none of the click-spots in the VC works, and it is cold and dark.

The application log was ominously empty, i.e. no entries added when P3D closed for some reason.

Then I did another attempt, and this time P3D actually crashed, with the following entries in the Event Viewer:

 

Application: Prepar3D.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0020001, exception address 00007FF80D519E08
Stack:
Faulting application name: Prepar3D.exe, version: 4.0.28.21686, time stamp: 0x594a7255
Faulting module name: KERNELBASE.dll, version: 10.0.15063.447, time stamp: 0x30ec82a7
Exception code: 0xc0020001
Fault offset: 0x0000000000069e08
Faulting process id: 0x3568
Faulting application start time: 0x01d2f329d8f6a936
Faulting application path: F:\P3D\Prepar3D.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: 9f684be9-9102-458f-921e-9ce8868c35e4
Faulting package full name: 
Faulting package-relative application ID: 

What surprised me a bit is that the P3D DLL.XML file contains no entries for PMDG. I seem to remember that this file used to contain some entires for PMDG dll's. Has this changed, or could this be the cause of the problem?

EDIT: 

Actually I may have been looking at the wrong DLL.XML file. I was looking at the one in User\AppData\Roamaing... However the one under ProgramData\Lockheed Marting... actually contains one entry for PMDG, the "PMDG Interface" one, so I was probably mistaken there.

EDIT 2: 

I have now also tried the entire process (uninstall/reinstall) etc. without anti-virus or firewall enabled (ESET), but no difference. It crashed again. :(

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

5 hours ago, DeCaf said:

After a few more attempts, it started asking for the activation code on each launch again, but this time the progress bar showed up and the aircraft loaded. 

But after loading almost none of the click-spots in the VC works, and it is cold and dark.

You are having a string of problems.  First the activation and then the dead simulation.  Are you using the Estonia Migration Tool?  Are you running the PMDG installer with "as admin" rights?  As for "without anti-virus" most times just turning it off doesn't get rid of it.  Remove it and try.

Share this post


Link to post
Share on other sites

 

19 minutes ago, downscc said:

You are having a string of problems.  First the activation and then the dead simulation.  Are you using the Estonia Migration Tool?  Are you running the PMDG installer with "as admin" rights?  As for "without anti-virus" most times just turning it off doesn't get rid of it.  Remove it and try.

No, I'm not using any migration tool or similar. Only genuine P3D v4 compatible products installed.  Everything is run as administrator.  I'll try with uninstalling the anti-virus, even though I've never had a problem with it before. However the built in windows defender cannot be uninstalled AFAIK, so that one I can only disable, but I'm suspecting that a lot more users would have problems if that was causing the problem. Anyway, I'll try a re-install without ESET antivirus installed and report back.

Share this post


Link to post
Share on other sites
6 hours ago, DeCaf said:

I just installed the PMDG 777 into Prepar3D v4 today, using the latest installers as available on my download page (under previous orders).

Did you uninstall the previous version first?

Edit: Disregard. I just saw in a comment below that you did in fact uninstall/reinstall. At this point, you might want to submit a support ticket to PMDG directly: http://support.precisionmanuals.com

Edited by wsmeier
New info

Share this post


Link to post
Share on other sites

This is a bit embarassing I believe. Before doing anything I thought I should try running the SimConnect installers again, in case that had something to do with it. Once I was presented with the Activation Key dialog.  But now that I went to look up the activation key, I noticed that I probably used the wrong key all the previous times. It appears I may have used the key for the 300ER expansion rather than the 200LR base package... Anyway, I entered the 200LR key and everything worked without a hitch.

I would of course have expected an invalid key message rather than the crashes, but perhaps there was something wrong with the SimConnect installations as well. Either way, not sure which of these fixed the problem, but the problem is fixed.

Apologies for taking up your time with another user-error, and thank you for your assistance nevertheless! :)

Best Regards,

Peter.

Share this post


Link to post
Share on other sites
24 minutes ago, DeCaf said:

Apologies for taking up your time with another user-error, and thank you for your assistance nevertheless! :)

Thanks for the update.  Windows Defender has never been associated with a AV blocking problem with any PMDG software so I got concerned and interested, I use it myself.  Glad you got it sorted out.

Share this post


Link to post
Share on other sites

It has happened before. The activation key only checks if the key itself is valid, not if it is the valid key for the aircraft you are activating. So mixing up keys has been a issue before. Only during startup you find the aircraft not working because then is checks the validation for the particular aircraft!

PMDG is aware of this, but cannot change it (yet), as the validation program is made by another company. And apparantly has not made too many victims to urge a quick change in this.

Share this post


Link to post
Share on other sites
2 minutes ago, fleng200 said:

PMDG is aware of this, but cannot change it (yet), as the validation program is made by another company. And apparantly has not made too many victims to urge a quick change in this.

I have two keys to my house. The both go into the lock, but only one turns it. It's pretty common to simply be aware of the key - physical or otherwise - that you are attempting to use prior to using it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now