Mark Niebauer

ATC Not working in Prepar3d with PMDG

Recommended Posts

After updating to the new Prepard3d V4 and the New PMDG 222-200  or using the PMDG 747  The ATC stopped working. I am using GSX with v4 updates.  THe ATC window comes up but not functioning. . .ANy ideas out there?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

You need to turn on the microphone on the pedestal. If you can't find the location of the button, check the manual.

Share this post


Link to post

I am having a similar problem, but what happens is that ATC simply stops functioning. The screen is there, with a message "no messages to send to XXXX" or "no messages to send to anyone", without any other option.

That happens only with PMDG 777 and 737 NGX. 

Is there way to reset only the the ATC engine only, to try to fix that during flight ?

Thanks for your help

Share this post


Link to post
32 minutes ago, Gilson said:

I am having a similar problem, but what happens is that ATC simply stops functioning. The screen is there, with a message "no messages to send to XXXX" or "no messages to send to anyone", without any other option.

That happens only with PMDG 777 and 737 NGX. 

Is there way to reset only the the ATC engine only, to try to fix that during flight ?

Thanks for your help

Same here. 

Share this post


Link to post

I've also encountered the "no messages to send to XXXX" problem with the NGX, but was able to work around it by clearing the flight plan from P3D's Flight Planner and reloading it.

Share this post


Link to post

Great advice ! At least for the first flight after clearing the flight plan and loaded again, it worked perfectly.

Maybe it´s time for PMDG to fix that.

Many thanks.

Share this post


Link to post

I have the same problem with PMDG 747 and 737 and the default ATC. After the IFR read back (i.e. when the squawk code is meant to be auto set) , there are no more options for any ATC interaction. Other AI seem to continue interacting with ATC. Furthermore, the squawk code fails to auto set as it used to. I have tried clearing and reloading the flight plan with no success. Has anyone raised this issue with PMDG? If not, I will do so. 

Share this post


Link to post

Never happened in my system. The clear before load solved all problems.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now