helinick84

FSX Menu Issues PLEASE HELP!

Recommended Posts

Hi All,

I have just developed a new problem with FSX.  I have just updated my graphics driver and now i have an issue when i load FSX. When i click on any menu item or "change aircraft" etc. the screen freezes!  The strange thing though is that the game itself isn't actually freezing? When i CTRL ALT DEL, it momentarily shows the menu i have chosen but then when i open task manager it goes back to the frozen screen again?  I have tried to re-boot the computer to see if its a momentary glitch but it keeps happening.

I have tried to roll back my graphics card driver to the previous version but it is still doing the same thing.  Will i need to do a clean re-install of FSX or is there anything that you can think of that might be an easy fix that i am overlooking?

Thanks for all your help and suggestions.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

27 minutes ago, helinick84 said:

Hi All,

I have just developed a new problem with FSX.  I have just updated my graphics driver and now i have an issue when i load FSX. When i click on any menu item or "change aircraft" etc. the screen freezes!  The strange thing though is that the game itself isn't actually freezing? When i CTRL ALT DEL, it momentarily shows the menu i have chosen but then when i open task manager it goes back to the frozen screen again?  I have tried to re-boot the computer to see if its a momentary glitch but it keeps happening.

I have tried to roll back my graphics card driver to the previous version but it is still doing the same thing.  Will i need to do a clean re-install of FSX or is there anything that you can think of that might be an easy fix that i am overlooking?

Thanks for all your help and suggestions.

 - rebuild your shader folder every time you update graphics driver or after you change FSX settings / fsx.cfg. For detailed instructions see AVSIM CTD Guide, you have there many other usefull informations. You should put uiautomationcore.dll in main FSX folder(there are download links in this guide).

The other reasons could be corrupted WX file for default flight(C:\Users\USERNAME\Documents\Flight Simulator X Files), you can move(or delete all WX file to check this).

Check your default free flight, never use addon aircraft for this. Just leave it to default(trike)

Share this post


Link to post
Share on other sites

Does the entire PC freeze? Or do you still have control over other windows programs etc? My FSX:SE "freezes" but only for some seconds if I'm changing options. I believe it's doing this because I haven't disabled the preload.

So, forgive me for asking but how long have you left the PC alone to see if FSX recovers?

Share this post


Link to post
Share on other sites
On 7/8/2017 at 9:21 PM, lodestar said:

 - rebuild your shader folder every time you update graphics driver or after you change FSX settings / fsx.cfg. For detailed instructions see AVSIM CTD Guide, you have there many other usefull informations. You should put uiautomationcore.dll in main FSX folder(there are download links in this guide).

The other reasons could be corrupted WX file for default flight(C:\Users\USERNAME\Documents\Flight Simulator X Files), you can move(or delete all WX file to check this).

Check your default free flight, never use addon aircraft for this. Just leave it to default(trike)

Thanks so much for your help lodestar!!  I have managed to work out the problem using the AVSIM CTD Guide that you suggested!  It turns out that it was a Microsoft Visual ++ issue!  For some reason when my graphics driver was updated it changed the Visual ++ software so i used the Visual C++ Redist Installer V54 that is suggested in the CTD Guide to re-install the software and now everything is working again!!  Thanks again!

See you in the sky!

Share this post


Link to post
Share on other sites
2 hours ago, helinick84 said:

Thanks so much for your help lodestar!!  I have managed to work out the problem using the AVSIM CTD Guide that you suggested!  It turns out that it was a Microsoft Visual ++ issue!  For some reason when my graphics driver was updated it changed the Visual ++ software so i used the Visual C++ Redist Installer V54 that is suggested in the CTD Guide to re-install the software and now everything is working again!!  Thanks again!

See you in the sky!

I'm glad to hear that.

Some addon installers will usually install older versions of C++, i allways run C++ installer after installing new addons, just in case

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now