Premier

P3D v4 upgrade

Recommended Posts

Hello there.

I have the PMDG 737NGX 8/900 and the PMDG 777 installed into P3D v2.5. I would like to try them in P3D v4. Do I need to pay for an upgrade?

Many thanks,

 

Chris Morgan

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

8 minutes ago, Premier said:

Hello there.

I have the PMDG 737NGX 8/900 and the PMDG 777 installed into P3D v2.5. I would like to try them in P3D v4. Do I need to pay for an upgrade?

Many thanks,

 

Chris Morgan

Hi Chris,

Uninstall the version you currently have installed and download a new installer from your account and install.

Give this a read too

http://support.precisionmanuals.com/kb/a112/important-and-nearly-foolproof-steps-to-running-your-pmdg-product-in-prepar3d-v3.aspx

Share this post


Link to post
Share on other sites

Thanks for your fast reply! :-)  I gather you cant have the NGX installed in P3D 2.5 and P3D v4 at the same time ( Both versions of P3D are in thier own folders)? Thanks for the additional link. I dont have P3D v3 installed tho

Share this post


Link to post
Share on other sites
9 minutes ago, Premier said:

Thanks for your fast reply! :-)  I gather you cant have the NGX installed in P3D 2.5 and P3D v4 at the same time ( Both versions of P3D are in thier own folders)?

No problem! :biggrin: As far as I believe that shouldn't be a problem.

 

Some good info in this thread too - 

 

Share this post


Link to post
Share on other sites
3 hours ago, Premier said:

Thanks for your fast reply! :-)  I gather you cant have the NGX installed in P3D 2.5 and P3D v4 at the same time ( Both versions of P3D are in thier own folders)? Thanks for the additional link. I dont have P3D v3 installed tho

I think the latest versions of the NGX and 777 are not compatible with anything before P3D v3.4, so you won't be able to run both v2.5 and v4.

Share this post


Link to post
Share on other sites

Hello I have P3D V3 and I just take P3D V4 I also havePMDG that worked with P3D V3 how to update PMDG for P3DV4 should I repay the download? Thank you for your answers

Share this post


Link to post
Share on other sites
3 hours ago, Poisson52 said:

Hello I have P3D V3 and I just take P3D V4 I also havePMDG that worked with P3D V3 how to update PMDG for P3DV4 should I repay the download? Thank you for your answers

You only need to download the latest P3D installer for the NGX. It is compatible with both P3Dv3 and v4. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now