CF104

MU-2 Beacon

9 posts in this topic

Hello All,

I am a new user of the MU-2 and have version 2.5 running in P3D V4 (4.0.28.21686). The one issue I have is with the red beacon which flashes inside the cockpit and cabin. I see there are a few posts regarding this but it looks like it shouldn't be happening with the latest versions of both the MU-2 and P3D.

Any insight would be great.

Cheers,

John 

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

32 minutes ago, CF104 said:

No-one from Flysimware has any ideas?

Cheers,

John

Just as an informational note, this is considered a User to User support forum.  As such, FSW does not routinely monitor this forum. While FSW does occasionally post here, it usually is as a follow up on an issue that was raised directly through the FSW website contact page http://www.flysimware.com/FLYSTORE_2015/en/contact-us .  So if no one here has an idea on the red beacon issue, your best bet is probably to contact FSW directly. 

Al

 

1

Share this post


Link to post
Share on other sites

Hi Al,

Thanks for your reply. Hmm... according to the Flysimware website 'Contact Us' page, this is Flysimware's Official Forum. I'll try to contact then through their Contact Form.

Cheers,

John 

0

Share this post


Link to post
Share on other sites

Hi John,

Well, maybe this is the Official FSW User to User forum? 

Note that at the top of the Forum home page it says :

Flysimware Forum

Product information on upcoming projects. This is unofficial user-to-user support and developer support is provided via their official website.

So yes, I would email FSW (Mark Taylor) directly.  I don't have P3D so can't be of much direct help.

Al

0

Share this post


Link to post
Share on other sites

Here is a secret about beacon and strobe lights. Most developers create these using the aircraft.cfg file and this causes the lights to reflect inside the interior model depending on the distance and location. So right below the pilot seat is the worst. Some popular sim Company's i won't mention have posted this is normal for FSX and P3D and there is no fix. I agree as long as your using the config to create lights.

But there is a solution. If you hard code those 2 lights in the exterior model and do not use the config file then they will not reflect on the interior parts. i do this for all of my aircraft and it works for both FSX and P3D. 

So i did a test today and all the aircraft in P3D V4 all do the same but the beacon is not close to the VC. And i find that this latest version is not working with my method. So i can only blame P3D V4 for changing the lighting. I tried to turn on receive check box for interior and the walls stopped reflecting but all my parts with reflective shine still continued to flash from the beacon. So for now there is no fix until P3D V4 gives the public a reason why it now reflects this lights when hard coded. So until i learn of a fix this is considered normal by most developers.

3

Share this post


Link to post
Share on other sites

not sure how p3d handles light reflections but placing an invisible polygon into the model might be worth trying. if p3d shadows and light reflections are accurate the polygon should prevent the light from getting inside the cockpit.

0

Share this post


Link to post
Share on other sites
On 9/14/2017 at 4:15 PM, paradoxbox said:

not sure how p3d handles light reflections but placing an invisible polygon into the model might be worth trying. if p3d shadows and light reflections are accurate the polygon should prevent the light from getting inside the cockpit.

By hard coding the lights then the fuselage works as a solid polygon to prevent the light from reflecting inside the interior model just like an invisible polygon as you mentioned. So for some reason P3D V4 is no longer stopping light from bleeding effects that are hard coded and this new change upsets me because the hard coding was the trick to stopping any bleeding of light.

So i hope someone will pass this info to P3D so they know that some developers hard coded effects so they will not bleed and now your latest version is no longer working. And again this hard coded trick works on all the previous versions.

Can anyone confirm that the previous versions of P3D do not bleed with my products?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now