RichieFly

My sorry attempt at using P3Dv3 again

Recommended Posts

After several months of joyously no-fuss P3Dv4 usage, I decided I really wanted to fly the FLS A320x again. I really miss that aircraft. This required using version 3 of P3D which I hadn't done since version 4 came out.

Boo! Hissss!

I spent over 2 hours trying this and that..the usual troubleshooting that goes along with version 3, with no luck. The device driver hang message was taunting me.

I know it's one or more of the entries in one of the 5 configuration files (P3D.cfg, both EXE.xml and both DLL.xml). I deleted them all (after making a copy of each one) and the cache files and yeah, P3Dv3 started up. Then I added a module or 2 back in and boom! same error.

I guess I can wait for the new version of the A320x after all.

I'd forgotten or chose to forget this all too typical nightmare. I'll spend my 2 hours flying instead of trying to fly.

The end.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Not sure if you are aware but there currently are problems with P3DV3.4 and Windows 10.  Seems crashes started as soon as Microsoft updated Windows 10.  Doesn't happen for V4 users.  See the AVSIM CTD Forum for more details if you are not aware of this already.

What is interesting is the fact you got rid of the dll.xml and exe.xml for P3Dv3 and the sim worked.  Then you added a module or two back and the crashes started again.  What module or two did you return to the dll.xml and exe.xml.  You do know there are two dll.xml's?  The default is located in the same folder as your P3DV3 scenery.cfg folder.  There's another one in the same folder as your p3d.cfg that was installed by third party programs.  When you rename your dll.xml and exe.xml located in your scenery.cfg folder, when you restart P3D, the default dll.xml and exe.xml will be built.  So, your issues are with a module loading from a third party vendor.  P3DV3 works flawlessly without any addon or modules from third party vendors.  When you installed the FSL A320, they should have made the appropriate entry in the dll.xml if there are any modules needed by the addon.  You have proven something was not installed properly when working with a module or two in the dll.xml.  

BTW, instead of deleting after backing up your dll.xml, just rename it to dll.xml.off.  If the new one created does not work, then delete the new one and rename the old one back to dll.xml.

Best regards,

Jim 

Share this post


Link to post

Yes, I am on V4 and it has been very stable for me, even with the latest and greatest Windows Updates which were applied to my PC when I wanted to download their programming languages, about two weeks ago.  I have the update service turned off though, I wait a week or two after the update is available before I risk having issues on my system.  I like to see what happens first before applying an update, rather than being a user tester.

John

Share this post


Link to post
24 minutes ago, Cactus521 said:

Yes, I am on V4 and it has been very stable for me, even with the latest and greatest Windows Updates which were applied to my PC when I wanted to download their programming languages, about two weeks ago.  I have the update service turned off though, I wait a week or two after the update is available before I risk having issues on my system.  I like to see what happens first before applying an update, rather than being a user tester.

John

Don't turn off windows updates. Just hide the one update that is causing all the problems with P3D. It is very easy to do. Google the topic. 

Share this post


Link to post
12 minutes ago, Bobsk8 said:

Don't turn off windows updates. Just hide the one update that is causing all the problems with P3D. It is very easy to do. Google the topic. 

My last system crashed because of Windows Update.  It was a Vista based system.  On shutdown it went into the update loop and it kept saying "0 Pct Remaining" .  Then it got stuck in a loop, rebooting every five minutes to no avail.  If you use Google, you will see that other Vista Users had this problem.  I contacted Microsoft in a chat session and they told me, in order to update to Windows 10, I'd have to wipe my drive and do a full install, that they no longer supported Vista updates.

 A lot of users got caught in this, that's why I now take a "wait and see" approach.  I had a clean system, no malware, no viruses, very few services.  I always used "HijackThis" to monitor what was going on in the background.  If a service was suspicious, from an infected website, I would kill it then go into DOS mode to rename their .exe or .com to something that wouldn't execute on bootup.  Then I would flush the registry from their entries.  I was attacked just once, came over Google and I notified Google immediately.  I emailed the fix to them, happened several years ago.  30 years as a computer programmer and WAN analyst has given me insight into such attacks.

I Firewall and monitor all activity on my system, most hackers are trying to get sim files like my Carenado files, or even the sims themselves.  I've caught this action a number of times, and I just cut them off.  That's the risk of the web, someone is always looking for a system to hack into. I don't get paranoid about it, I just follow some useful steps to keep my system clean, such as not visiting malicious sites, or being careful of what I type in the url bar.  Many malware providers have hijacked misspellings of url's, and you can get caught easily if you type cnnn instead of cnn.  I ran a WAN for five years in the early 2000's and I regularly held sessions on safe surfing, since we allowed our employees to surf on breaks.  I could view their sessions at random to make sure they weren't hitting malicious sites, keeping their workspace safe.

Don't want to start a flame war, those who know me here know I know my stuff, having added add-ons for the sim for the past fifteen years for scenery development, such as LandClass Assistant, Colorado scenery, and Autoland, which has become obsolete with all the photoreal scenery we have available.  I no longer support either app since they lay in the dustbin of FS2002...  There are folks better than me working on these things now, I am retired :)

John

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now