RXP

RXP GTN 750/650 Touch X-Plane v2.4.9 RC

Recommended Posts

Hi,

I'm pleased to announce v2.4.9 Release Candidate is now available!

This update includes stability and performance enhancements, and corrects all known issues to date.

Please make sure to post your feedback for this version in this thread only. Once we get enough feedback, this will become an official release through "Check Updates..."

 

Please note: along with enhanced support for the latest trainer 6.41, this build tries addressing the 'black screen' problem some of you have reported in the forum. We'd particularly like your feedback on this issue.

 

Download link for both e-commerce installers

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

All working okay. The 650 seems to take a bit longer to reboot than the 750 when battery switched off and on. Looking good, all we need now is the weather icon working.:biggrin:

  • Upvote 1

Share this post


Link to post
Share on other sites

Jean-Luc.  Started a couple of flights and, so far, the 750 has started and is running just fine!

Thanks,  Howard

Share this post


Link to post
Share on other sites

Hi, 

Thank you both for the initial reports! I'm hoping this black screen is gone for good now, but I'll keep an eye to your reports in the future.

@bluebell2 is the new version still causing the 'last screen' remanent image when powering off?

Share this post


Link to post
Share on other sites
2 hours ago, RXP said:

@bluebell2 is the new version still causing the 'last screen' remanent image when powering off?

Seems to have fixed that little problem.

  • Upvote 1

Share this post


Link to post
Share on other sites

No difference for me, back to black screen at startup of Xplane 11. Getting really fed up of this, nearly £50 down the drain, I spend more time restarting windows and Xplane than I do flying. Probably time to get a refund which is a shame as when it works its really good but it only works randomly for me.

Share this post


Link to post
Share on other sites

As an aside to this problem could consistently successful users state which version of X Plane 11 they are using? The reason I ask is that I have this morning reverted to 11.05 and 2 times out of 4 the GTN has started after a system reboot. On the beta version of Xplane this success rate was more like 1 in 8. I really want to be able to use this plugin and am trying to assist the developers but spending 3/4 of my free time rebooting and reloading is getting really annoying. Love it when its works.

Share this post


Link to post
Share on other sites

Hi and thank you for your invaluable input. v2.4.9 RC is a release candidate which helps us assess whether the changes are working. This also helps us assess which changes we can add before official release. 

In this case, we've pinpoint the issue, and the RC is including certain changes which prove helpful for most. We still have other changes that we've kept out of this build for now otherwise we couldn't have been sure what we've found out is indeed the root cause for most.

We will offer a new build if not today, tomorrow, with more stringent checks around the part of code which causes this in the trainer.

In the meantime, don't expect the solution running on any X-Plane beta. It may, but there is no guarantee simply because XP beta breaks things plugins rely on. Better stick to 11.05 for now. Furthermore, can you please post the content of your RXP log files when it fails?

Share this post


Link to post
Share on other sites

Will do. the log files never seem to show any errors? should I check them immediately after closing Xplane after a failed / black screen issue? Regards

Share this post


Link to post
Share on other sites

You can check them right away when X-Plane is still running with the device failed. Otherwise they'll get overwritten the next time X-Plane runs.

Share this post


Link to post
Share on other sites

Jean-Luc I still have a problem with the washed out looking display.  Has anyone else reported this problem?  I have updated to the latest version and the latest video driver.

Share this post


Link to post
Share on other sites

Hello Jean-Luc, the new version of the Trainer, does not load the flitecharts of Europe,
With the previous version, however, I could use them
The Trainer setup menu gives me a choice between jeppesen world, which is very limited to a few cards that are in a folder or "card" from Garmin just for USA.
Any idea to activate them? Or any solution?
Thank you for your work and effort.

Share this post


Link to post
Share on other sites

@jatar I've reviewed the changes and the only charts missing with trainer 6.41 are the ones for Canada. Do you have a particular example of a chart for Europe that was present in 6.21 but not longer in 6.41? 

@HWDALE Unfortunately there is no other report so far. The 'washed out' display for others wondering is like having the transparent parts of an on screen icon filled in white instead of being transparent, these parts being randomly composed of little white rectangles of different sizes.

For maybe the last 3 updates there is code in place to try mitigate this. It's been very difficult to find similar issue with the same video cards reported online (for other games) except a few, for which the most often found answer was either failing/overheating video card, or bugs in the video card drivers.

These are mostly due generally to driver optimizations which fail under some circumstances. In other words, to make driver fasters, they code 'shortcuts' and depart from the standard, like say a command to paint the screen in black, they shortcut with a command to clear the screen instead, which is faster. However in doing so, it fails to also initialize other important data related to a 'paint' command. This is what I've found the most with Intel and AMD drivers. To circumvent this, you can 'trick' the video card in its own game, and say paint in near-black instead of absolute black (say paint with 1,1,1 instead of 0,0,0) and this is what our implementation is doing.

I'll have to think of other ways to try 'fooling' the card around and see how it responds, but we need to make sure the 'normal' implementation is working fine first, which seems to be the case with v2.4.9 so far.

Share this post


Link to post
Share on other sites

Hi Jean-Luc, I have access to a garmin of the airclub with its updates and I obtained the files to put them in the Trainer, now with the new trainer is not possible, since they have changed the format. Before it was a single file that we called "card" and now it is a folder with the files of the different airports.
Is it possible to generate realityxp 2.4.9 compatibility with the previous 6.2 trainer? It would be a solution.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.