kiosutra

Any solution to missing trees?

Recommended Posts

Hey gang! 

I recently booted up FSX and noticed nearly all my trees are gone! So delved into the great avsim forum. But I cant seem to find a solution. It seems FTX users have run into this, but alas I do not use such program. Anyone else see this before? 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Rename the FSX.cfg to fsx.cfg.off, restart FSX and see if this fixes the problem.  You may have to reinstall (repair) FSX too.  There are a lot of addon programs that decide you do not need the default trees so they disable it and install their own trees.  Then, when you remove the addon, you're left with no trees.  These are all educated guesses.  Do not think there is one solution to this problem (if a problem).  I just know for a 100% fact, when you install FSX/SP2 or Acceleration, you have trees, lots of trees.  In fact so many trees many tried to turn them off or tweak the FSX settings to give one more or less because there were too many and they were taking up too many resources.  There were programs that also tried to reduce the number so you would get better performance.  I believe GEX has the ability to do this.

If you repair FSX, it will overwrite your fsx.cfg and scenery.cfg so you will need to backup these files.  It will not harm any installed addons.  Still, I would rebuild your fsx.cfg first.

Share this post


Link to post
Share on other sites

Unfortunately, This doesn't seem to solve the issue either. I find it weird that this mystery has eluded the great fellow nerds on this forum. Its super frustrating to have to reinstall everything from scratch. Still digging for a solution though. 

Share this post


Link to post
Share on other sites
15 hours ago, kiosutra said:

Unfortunately, This doesn't seem to solve the issue either. I find it weird that this mystery has eluded the great fellow nerds on this forum. Its super frustrating to have to reinstall everything from scratch. Still digging for a solution though. 

There shouldn't be any need to reinstall everything from scratch. You are referring to Orbx scenery, correct? Which area? Is it across the whole globe?

Share this post


Link to post
Share on other sites
2 hours ago, Rockliffe said:

There shouldn't be any need to reinstall everything from scratch. You are referring to Orbx scenery, correct? Which area? Is it across the whole globe?

The OP said he noticed users of FTX had the same problem but he uses no such program,  Most trees pop up due to Autogen.  Increase that slider.  Under [Terrain] in your FSX.cfg add these lines, if not there.

[TERRAIN]
IMAGE_PIXELS_FOR_AUTOGEN_POLYGONS=1024  
TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=500
TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=500

The numbers can be increased or decreased.

Share this post


Link to post
Share on other sites

As I stated in my reponse, the trees were there when he first installed FSX.  It was something he installed later that took them away.

2 hours ago, charliearon said:

Under [Terrain] in your FSX.cfg add these lines, if not there.

I already told him to rename the fsx.cfg and restart FSX and let the config rebuild.  If he did, the default parameters would have been returned. It did not fix his problem.  As I stated, there are some programs that remove trees and replace them with their own and, when the member uninstalls that program, the program does not return the defaults.  It's upsetting but nothing one can do about it other than to reinstall/repair FSX (which the OP has already done as I suggested that in my recommendation and he said that didn't solve his problem).

Share this post


Link to post
Share on other sites
10 minutes ago, Jim Young said:

As I stated in my response, the trees were there when he first installed FSX.  It was something he installed later that took them away.

I agree 100%......  That is if the OP will admit to doing that.  I would guess that many folks try different downloads, don't like what they see, then delete it all without making any backups.

  • Upvote 1

Share this post


Link to post
Share on other sites

If indeed the trees autogen have literally disappeared, the OP could save a lot of heartache and I would have thought, install Orbx trees or a similar programme from one of several devs. There is also most likely to be a freeware option too.

Share this post


Link to post
Share on other sites

Solved. 

 

The solution I found was to delete and restore the original *autogen* folder in the FSX folder. It has restored the trees and has not effected my sim and add-on in any negative way. 

 

I appreciate the help!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now