RXP

RXP GTN 750/650 Touch X-Plane v2.4.9 Released!

Recommended Posts

I'm pleased to announce the v2.4.9 is now live in your "Check Updates..."

Thank you all for your assistance with the release candidate!

  • Enhanced: Reduced video card memory usage by 50%.
  • Enhanced: Using Ryan 9900BX TCAD instead of 9900B.
  • Enhanced: Preliminary changes for X-Plane 11.1.
  • Enhanced: Further performance and stability enhancement.
  • Fixed: Black screen issue experienced on few systems.
  • Fixed: Corrupted graphics when using Intel Video card.

PS: should you've installed the RC, check updates will not report the new version. You'd need to download the e-commerce installer from our website instead.

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Jean-Luc,

When I check for updates it says "You're up to date" but I'm still using that file you sent me (RC3). Don't I need to update?

Thanks.

 

Share this post


Link to post
Share on other sites

Well, I just tried to check to see if my RC version of  2.4.9 was the same as what you posted and it is, but now I get the black screen. Here is what my rxpGtnSim.dll.log says:

17/11/04 04:15:06.383 12536 -    ] # rxpGtnSim64.dll version 2.4.9.0
17/11/04 04:19:39.613 12624 ERROR] Trainer Failed Task: 00000001
17/11/04 04:19:39.660 12624 ERROR] The specified procedure could not be found., code: 0000007f
17/11/04 04:21:09.459 12816 ERROR] Trainer Failed Task: 00000001
17/11/04 04:21:09.503 12816 ERROR] The specified procedure could not be found., code: 0000007f
17/11/04 04:21:35.893 05388 ERROR] Trainer Failed Task: 00000001
17/11/04 04:21:35.959 05388 ERROR] The specified procedure could not be found., code: 0000007f

And here is a dropbox link to a screen shot showing what I see.

https://www.dropbox.com/s/8ddfq0cbqdar4ih/xsMU2B60_15_3.png?dl=0

The GTN750 looks like it wants to turn on but just isn't turning on.

I also checked the garmin trainer and the 750/650 will not turn on there either. I have not tried to reboot my system yet.

Share this post


Link to post
Share on other sites
41 minutes ago, Alvega said:

You're up to date" but I'm still using that file you sent me (RC3). Don't I need to update?

Yes I'm sorry I've not thought about this! The files have the same version number so it won't detect the new version. Instead, just download the ecommerce installer ps from the web site and use the 'reinstall' option.

Share this post


Link to post
Share on other sites
31 minutes ago, asandor said:

my RC version of  2.4.9 was the same as what you posted and it is

It is not the same version, although the file numbers are the same ( see above). Just reboot and reinstall like indicated, and let me know how it goes.

Share this post


Link to post
Share on other sites
1 minute ago, RXP said:

Yes I'm sorry I've not thought about this! The files have the same version number so it won't detect the new version. Instead, just download the ecommerce installer ps from the web site and use the 'reinstall' option.

 

Can't I just place the "rxpGtnSim32" I had before in the folder and then check for updates?

Share this post


Link to post
Share on other sites

It won't work because the RC already is the last version (from a file number standpoint). It was an oversight when releasing the RC.

Share this post


Link to post
Share on other sites
1 minute ago, RXP said:

It won't work because the RC already is the last version (from a file number standpoint). It was an oversight when releasing the RC.

I'm downloading the new installers now and will give them a try.

Share this post


Link to post
Share on other sites
12 minutes ago, RXP said:

It won't work because the RC already is the last version (from a file number standpoint). It was an oversight when releasing the RC.

I don't need to reinstall the trainer again, right?

Share this post


Link to post
Share on other sites

Ok, rebooting and installing 2.4.9 did seem for work. I'll test it some more over the next day or so and see what happens.

  • Upvote 1

Share this post


Link to post
Share on other sites

Jean-Luc,  I'm not sure why, but Microsoft Security Essentials is not letting me download this file from your site.  This has never happened before.   Do you have any suggestions?

Thanks,  Howard

Share this post


Link to post
Share on other sites

Hi Howard, the first suggestion that comes to mind is to deactivate MSSE the time for you to download and install the files, or to whitelist them.

Share this post


Link to post
Share on other sites

Well, got into X-Plane 11.05 today and no go. The GNS is a blank screen again. After I checked it last night to see if it came up, I just left X-Plane. I made sure I unselected the GNS before I exited X-Plane. I am getting the same issue in the rxpGtnSim.dll.log file:

17/11/04 17:30:34.561 04424 -    ] # rxpGtnSim64.dll version 2.4.9.0
17/11/04 18:05:16.965 07640 ERROR] Trainer Failed Task: 00000001
17/11/04 18:05:16.992 07640 ERROR] The specified procedure could not be found., code: 0000007f
17/11/04 18:08:30.137 07276 ERROR] Trainer Failed Task: 00000001
17/11/04 18:08:30.155 07276 ERROR] The specified procedure could not be found., code: 0000007f

And when I go to the Garmin trainer software, the GNS 750/650 will not turn on. But the other ones do.

Maybe its my video card I have?  I have a GTX 1080. Not the Ti. Also have the latest version of the Nvidia drivers installed.

Or maybe its a its a dll that I am missing?

Share this post


Link to post
Share on other sites
13 minutes ago, asandor said:

But the other ones do.

What 'other ones' are you referring to? If using the GTN trainer 6.41, you have to run the 'C:\Program Files (x86)\Garmin\Trainers\Launcher\Aviation_Trainer_Launcher.exe' to check it the trainer is working or not.

It is possible there is a file mismatch between the RC and the release during installation. To make sure about this, you may manually delete:

  • C:\Program Data\Reality XP\rxpGtnSim32.dll
  • C:\Program Data\Reality XP\rxpGtnSim64.dll
  • X-Plane\Resources\plugins\rxpGTN\32\
  • X-Plane\Resources\plugins\rxpGTN\64\

Then reinstall 2.4.9 release.

NB: you don't have to use the e-commerce installer if you have ran it once, because it has extracted the RXP software installer in your C:\RealityXP\ folder, which you can run directly. The RXP software installer is rxpGTN-XPL-Setup.exe and its size is 23,310,620 bytes (v2.4.9 Release)

Share this post


Link to post
Share on other sites
4 minutes ago, RXP said:

What 'other ones' are you referring to? If using the GTN trainer 6.41, you have to run the 'C:\Program Files (x86)\Garmin\Trainers\Launcher\Aviation_Trainer_Launcher.exe' to check it the trainer is working or not.

It is possible there is a file mismatch between the RC and the release during installation. To make sure about this, you may manually delete:

  • C:\Program Data\Reality XP\rxpGtnSim32.dll
  • C:\Program Data\Reality XP\rxpGtnSim64.dll
  • X-Plane\Resources\plugins\rxpGTN\32\
  • X-Plane\Resources\plugins\rxpGTN\64\

Then reinstall 2.4.9 release.

NB: you don't have to use the e-commerce installer if you have ran it once, because it has extracted the RXP software installer in your C:\RealityXP\ folder, which you can run directly. The RXP software installer is rxpGTN-XPL-Setup.exe and its size is 23,310,620 bytes (v2.4.9 Release)

With the trainer 6.41 software there is also the GDU 1060 that comes up and works fine.

I reinstalled  but no go, the 750 and 650 are still blank screen. Though you can tell that it is trying to turn on as there is a small glow in the background like in the picture I posted last night before I rebooted and reinstalled.

Share this post


Link to post
Share on other sites

I don´t know if it has happened because I have updated to XPL11.10b6, but Black window back again. 
I have solved it with install 2.4.9 previous release, not final, and dll from final release.
Regards.

Share this post


Link to post
Share on other sites

Ok, so playing around with it for a little bit, I actually got it to work. With the power on and avionics on when I start up the GTN it was a blank screen. But I tried to turn off the power and avionics while the GTN was up and when I turned the power and avionics back on the unit is now working. Though I have only 1 on, and I try to turn the other one, blank screen, I have to power off the power and avionics and then turn them back on again for both to work.

Share this post


Link to post
Share on other sites
1 hour ago, jatar said:

I have solved it with install 2.4.9 previous release, not final, and dll from final release.

Which DLL from final release are you using?

@asandor I don't know what could be the issue at hand, but the RC we passed through seemed working stable for days. There is probably one last minute change between the RC and the Release related to the 'block' which solves the black screen issue, so I'll probably pass you a slightly different build just to compare this specifically on your systems. I know from the RC we've found exactly the reason why, it really is a matter of a few things in fact.

Share this post


Link to post
Share on other sites
1 hour ago, RXP said:

 

@asandor I don't know what could be the issue at hand, but the RC we passed through seemed working stable for days. There is probably one last minute change between the RC and the Release related to the 'block' which solves the black screen issue, so I'll probably pass you a slightly different build just to compare this specifically on your systems. I know from the RC we've found exactly the reason why, it really is a matter of a few things in fact.

Until that build, for now I can just turn off the power and avionics and turn them back on to get the 750/650 working.

Share this post


Link to post
Share on other sites

Hi Jean-Luc, after update xpl to beta6, window black, so I have installed the final release, and window continue black, so I come back to dll you sent me by pm and Light again. 
the file has 6978kb
Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now