Hammercat

Pilot2ATC v2.4 x64

Recommended Posts

Hi Dave,

I cannot seem to get the new version to connect. I click the button and nothing happens. I am network and use P3Dv4 with wideclient. Version 2.3 still connects fine if i go back to it. here is the log.

Program StartedPilot 2 ATC (P2A) - version 2.4.0.0_x64  12/11/2017 21:02:22
Application frmP2AMain starting 12/11/2017 21:02:23
Loading Form
Main form openned: Pilot2ATC 2018 v. 2.4.0.0_x64      AIRAC cycle: 1712
Loading Map Control
LoadMapControl: panel 1
Creating ucMap1
SQLiteVersion: 3.8.11.1 | 2015-07-29 20:00:57 cf538e2783e468bbc25e7cb2a9ee64d3e0e80b2f | INTEROP_CODEC INTEROP_EXTENSION_FUNCTIONS INTEROP_VIRTUAL_TABLE NET_40 PRELOAD_NATIVE_LIBRARY THROW_ON_DISPOSED TRACE TRACE_PRELOAD TRACE_SHARED TRACE_WARNING USE_PREPARE_V2 WINDOWS
ucMap1 Created
ucMap DockFill set.
Setting Map Mode
Error in frmP2AMain LoadMapControl
System.InvalidCastException: Conversion from string "" to type 'Integer' is not valid. ---> System.FormatException: Input string was not in a correct format.
   at Microsoft.VisualBasic.CompilerServices.Conversions.ParseDouble(String Value, NumberFormatInfo NumberFormat)
   at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)
   --- End of inner exception stack trace ---
   at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)
   at P2A_2018.ucMap.ad(Object A_0, EventArgs A_1)
   at System.Windows.Forms.UserControl.OnLoad(EventArgs e)
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.ControlCollection.Add(Control value)
   at P2A_2018.frmP2AMain.c(Int32 A_0)
Done Loading Map Control
Loading FPL Control
FPL Control Loaded
Error in frmP2AMain ConnectToSIM
System.BadImageFormatException: Could not load file or assembly 'SlimDX, Version=4.0.13.43, Culture=neutral, PublicKeyToken=b1b0c32fd1ffe4f9' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'SlimDX, Version=4.0.13.43, Culture=neutral, PublicKeyToken=b1b0c32fd1ffe4f9'
   at P2A_2018.simJoystick..ctor()
   at P2A_2018.P2ASimulatorFSUIPC..ctor()
   at P2A_2018.frmP2AMain.f()

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Application frmP2AMain ended normally 12/11/2017 21:02:36
 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Early versions of the installer had the wrong version of one of the DLLs and caused the program to not connect.

Download, unzip and run a fresh copy of the installer and see if that fixes it.

Dave

Share this post


Link to post
Share on other sites

Dave,

Is it normal with the x64 version that the installed AT&T voices are not seen anymore by P2A?

Thanks

 

EDIT : I checked that the x86 version is still able to use them

Share this post


Link to post
Share on other sites

I cannot seem to get my X-ATC Chatter files to play. I have installed them as controller files in the new x64 install (different drive from the x86 version) but I am not hearing anything. Have I missed a step?

Share this post


Link to post
Share on other sites

Have you checked the settings in Config?  What is the full path to the Chatter Files?

Also, check the volume on the Radio Panel.  When you click the Standby Com Frequency, the panel that pops up has the Volume controls for Chatter and a Mute button.

Dave

 

Share this post


Link to post
Share on other sites
3 hours ago, roland_lfor said:

Dave,

Is it normal with the x64 version that the installed AT&T voices are not seen anymore by P2A?

Thanks

 

EDIT : I checked that the x86 version is still able to use them

Roland,

Mine are still showing.  You should contact AT&T or the vendor you bought the voices from to see if they have a solution.

By the way, mine show up as just Mike16 and Crystal16, so you wouldn't know they are from AT&T.

Share this post


Link to post
Share on other sites

Good Day Dave,

Once again Thank you for the quick response and support! Much appreciated!

I have re-downloaded and reinstalled, looks like that did the trick, however it look 6 minutes and 21 seconds to load. Is that normal?

Share this post


Link to post
Share on other sites

That is definitely not normal.  It should load about the same or slightly faster than the previous version. 

Share this post


Link to post
Share on other sites

well I tried uninstalling and reinstalling fresh. No luck Load time was almost 7 minutes that time. Question, I read that you recommend 16mb of ram to run v2.4 x64 and I am running this networked on an old CPU that has 8MB of ram. Could that be the issue?

Share this post


Link to post
Share on other sites

The 16GB is for a PC that's running the SIM and Pilot2ATC together.  If P2A is the only thing running, 8GB should be enough.

Usually when I have long load times like that, it's because some background task is scanning disk or something that eventually goes away.

Check Task Manager and see what's eating up the resources.

Share this post


Link to post
Share on other sites

Took a look and nothing eating resources. Baffling me. I will try some other ideas. Here is the log if it helps

Program StartedPilot 2 ATC (P2A) - version 2.4.0.0_x64  12/12/2017 22:01:49
Application frmP2AMain starting 12/12/2017 22:07:56
Loading Form
Main form openned: Pilot2ATC 2018 v. 2.4.0.0_x64      AIRAC cycle: 1705
Loading Map Control
LoadMapControl: panel 1
Creating ucMap1
SQLiteVersion: 3.8.11.1 | 2015-07-29 20:00:57 cf538e2783e468bbc25e7cb2a9ee64d3e0e80b2f | INTEROP_CODEC INTEROP_EXTENSION_FUNCTIONS INTEROP_VIRTUAL_TABLE NET_40 PRELOAD_NATIVE_LIBRARY THROW_ON_DISPOSED TRACE TRACE_PRELOAD TRACE_SHARED TRACE_WARNING USE_PREPARE_V2 WINDOWS
ucMap1 Created
ucMap DockFill set.
Setting Map Mode
Error in frmP2AMain LoadMapControl
System.InvalidCastException: Conversion from string "" to type 'Integer' is not valid. ---> System.FormatException: Input string was not in a correct format.
   at Microsoft.VisualBasic.CompilerServices.Conversions.ParseDouble(String Value, NumberFormatInfo NumberFormat)
   at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)
   --- End of inner exception stack trace ---
   at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)
   at P2A_2018.ucMap.ad(Object A_0, EventArgs A_1)
   at System.Windows.Forms.UserControl.OnLoad(EventArgs e)
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.ControlCollection.Add(Control value)
   at P2A_2018.frmP2AMain.c(Int32 A_0)
Done Loading Map Control
Loading FPL Control
FPL Control Loaded
FormClosing Error: System.NullReferenceException: Object reference not set to an instance of an object.
   at P2A_2018.frmTaxiwayGateMnt.a(Object A_0, FormClosingEventArgs A_1)
Application frmP2AMain ended normally 12/12/2017 22:08:17
 

Share this post


Link to post
Share on other sites

What percent of CPU, Memory and Disk are being utilized when loading P2A?

It also looks like the TaxiMnt window as opened and closed at the end of the log file.  Could you have pressed that button accidentally?

Share this post


Link to post
Share on other sites

Hi Dave,

Been struggling with this for the last couple of nights.

Fresh install of windows 10

Still taking 6 minutes + to load.Here are the numbers you asked for and yeah I opened the taxiMnt window on purpose checking functionality.

CPU 28     Memory 23   Disk 4   network 0 - numbers never went higher then these

 

I timed the % done. Not sure if it will help

10% done showed as soon as I opened the program

20% done -10 seconds later

40% Done - 2 minutes and 43 seconds. (skipped over 30%)

50% done - 2.58

70% done - 3.25 (skipped 60%)

80% done - 3.40

90% done - 3.47

100% done at 5.46

First time under 6 minutes. : )

Here is the latest log as well:

Program StartedPilot 2 ATC (P2A) - version 2.4.0.1_x64  12/14/2017 17:49:13
Application frmP2AMain starting 12/14/2017 17:55:00
Loading Form
Main form openned: Pilot2ATC 2018 v. 2.4.0.1_x64      AIRAC cycle: 1712
Loading Map Control
LoadMapControl: panel 1
Creating ucMap1
SQLiteVersion: 3.8.11.1 | 2015-07-29 20:00:57 cf538e2783e468bbc25e7cb2a9ee64d3e0e80b2f | INTEROP_CODEC INTEROP_EXTENSION_FUNCTIONS INTEROP_VIRTUAL_TABLE NET_40 PRELOAD_NATIVE_LIBRARY THROW_ON_DISPOSED TRACE TRACE_PRELOAD TRACE_SHARED TRACE_WARNING USE_PREPARE_V2 WINDOWS
ucMap1 Created
ucMap DockFill set.
Setting Map Mode
Error in frmP2AMain LoadMapControl
System.InvalidCastException: Conversion from string "" to type 'Integer' is not valid. ---> System.FormatException: Input string was not in a correct format.
   at Microsoft.VisualBasic.CompilerServices.Conversions.ParseDouble(String Value, NumberFormatInfo NumberFormat)
   at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)
   --- End of inner exception stack trace ---
   at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)
   at P2A_2018.ucMap.ad(Object A_0, EventArgs A_1)
   at System.Windows.Forms.UserControl.OnLoad(EventArgs e)
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.ControlCollection.Add(Control value)
   at P2A_2018.frmP2AMain.c(Int32 A_0)
Done Loading Map Control
Loading FPL Control
FPL Control Loaded
Application frmP2AMain ended normally 12/14/2017 18:00:37

Regards,

Rich

Share this post


Link to post
Share on other sites

Rich,

Thanks for the detailed timings.  I just timed it on my laptop and it took 49 seconds for the entire load.  6 minutes is definitely too long.

This loading is getting all the critical data out of the Databases and set up in memory for quick access.

After it loads, does the application run OK?

I will PM you a link to the msi file for Microsoft's SQLLocalDB 2014, which is the correct version.  Perhaps something is wrong with your SQL installation.

I also fixed the bug that is causing the error in the log.

Thanks,

Dave

Share this post


Link to post
Share on other sites
8 hours ago, Dave-Pilot2ATC said:

Thanks for the detailed timings.  I just timed it on my laptop and it took 49 seconds for the entire load.  6 minutes is definitely too long.
 

I would think that 49 seconds is too long!  :). Actually, speed is one of the killer problems with this program. The load issue is generally not so bad as you are doing other things anyway. XP itself takes much longer to load and that is usually happening at the same time. The problem is entering the flight plan and subsequently hitting the "Info" button. These can take minutes when it needs to be instant. I basically never hit the Info button anymore as it takes too long - plus the chance of crashing the program is too high (or you give up waiting and kill the process). Connecting to XP also takes a long time. Plan-G and other programs do it instantly.

Share this post


Link to post
Share on other sites
On 12/12/2017 at 10:06 PM, Dave-Pilot2ATC said:

Roland,

Mine are still showing.  You should contact AT&T or the vendor you bought the voices from to see if they have a solution.

By the way, mine show up as just Mike16 and Crystal16, so you wouldn't know they are from AT&T.

Not sure if it's linked, but after the last Windows Update, AT&T voices are again available in x64 P2A.

Share this post


Link to post
Share on other sites

OK this turns out to be my issue. I am trying to run this program on an old CPU with a slow processor in it. I ran this on my simulator PC and it loaded in 31 seconds and worked perfectly.

Thank you for the help Dave! Your support is OUTSTANDING!

Happy Holidays to you and yours!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now