floydcox

No text options

Recommended Posts

I use the copilot to respond to ATC and switch the radio frequencies but now I get no text response choices in the P2A speech assistant. I have updated to the X64 version. What setting have I missed?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Be sure the "Show In-Line Grammar Help" option is checked I nthe P2A Setup tab of Config.

Share this post


Link to post
Share on other sites

Which window are you referring to as the "Speech Assistant"?  Is it the Speech Text window at the bottom right corner of the main P2A window or one of the SayIt windows?

Share this post


Link to post
Share on other sites

I seem to have a similar problem. I also have the "Show In-Line Grammar Help" option checked.

I am running P2A 2.3.1.2. Being a newbie I have only used P2A by clicking on the suggestions and then click "Say It".

Now I don't see the suggestions no more. I have tried to change frequency to another controller but no luck doing that. Still no suggestions.

My system used to work fine but not after I tried to upgrade to the newest 2.4 version and it did install.

When I tried to execute the exe-file I got a prompt that the new version was not compatible with my system (my laptop is running 32 bit Win10, my bad ofcourse..).

I don't know if installing the new version have done anything to the 32 bit installation. The two installations is installed in separate folders.

Best regards

Carsten

Share this post


Link to post
Share on other sites

The Grammar Help data file is stored in shared storage and would be the same for both versions.  Both install packages install the same file to the same place...so chances are, the data is not missing.

Double check that

  1. You are connected to the SIM
  2. Your Power indicator is green
  3. You are on a frequency besides ATIS.  Check Ground or Tower for the airport you are at just to be sure.
  4. Select a Phrase Type and Phrase Name for something you know the controller can respond to, like Taxi.

Dave

Share this post


Link to post
Share on other sites

I am sitting with the sim (Xplane 11.10) now. Location at KBOS.

1.Green is highlighted for connection to the sim.

2. Power indicator is green. I have pressed "Validate" and "File" - both are marked green.

3. While being on ATIS (135.00), the pulldown menus are empty which makes sense. Changing to KBOS ClrDel (121.65), now ATCchatter starts and speech assistant pulldown menus "Request" and "Clearance" appear. Below in the "Phrase" box, no text is displayed. At this stage I normally have phrases available like "SK445 ready to copy IFR clearance".which I could use with the "Say it" command. If I change radios to Gnd (121.75) ATCchatter follows and the rightside pulldown menu change to "Pushback" but still, no ATC phrases to select in the box below. I will try to do a complete uninstall, reboot and install V2.3.1.2 again, to see if that makes any difference.

After the uninstall, I can see that a folder remains called "Grammars". It holds a file "P2AGrmr_log.ldf". I will not delete it in case you like to investigate it..

I will update you how things go after rebboting and reinstalling P2A.

/Carsten

Share this post


Link to post
Share on other sites

After uninstall, reboot and reinstall the program seems to work now.

I now have the text phrases. ;0) I haven't flown a complete leg yet, but i think it works now.

This issue was  likely caused by installation of P2A X64 V2.4 (which I could not run on my 32 bit Win10.

Share this post


Link to post
Share on other sites

I've got exactly the same problem, but I could'nt solve it yet. Even a reinstall of P2A did'nt help. Everything else, including the speech recognition works fine.

 

My settings:

  • conncected to X-Plane 11, power indicators are green, not on ATIS frequency
  • P2A V2.4.0.6_x64_b
  • Windows 10, 64Bit, 16G RAM
  • Show In-Line Grammar Help in the config is checked.

Any help would be great.

 

Share this post


Link to post
Share on other sites

Are you on Ground frequency or some other frequency that has a valid controller?

Is the SayIt(?) button green?

Share this post


Link to post
Share on other sites

Ralf,

It looks correct.  I can't see what frequency you are on.  I presume it's Clearance Delivery.

Just the phrases are missing which leads me to suspect you are missing a file in your Settings folder.  I will PM you with information on how to check that.

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now