RXP

RXP GTN 750/650 Touch X-Plane v2.4.12 Released

39 posts in this topic

Just to make sure, the latest X-Plane version is not 11.1, but 11.11r2 or 11.12rc (new release candidates, I'll have to confirm which one). So do you have the latest, or 11.1?

We might also have introduced a bug in our settings. Specifically, with support for popout windows we've also added support for right mouse button, new with the XP11.1 SDK. 

Therefore, the entire settings controlling mouse are:

; enable mouse clickspots if true, disable if false (use SHIFT to override)
usemouse  =
; left mouse button on the screen toggles popup window if true (requires SHIFT+left mouse button).
popleft =
; right mouse button on the screen toggles popup window if true (requires XP11.1).
popright =

 

Should there is a bug, it might be with the popleft setting? You might want to try depressing the SHIFT key while clicking on the screen to see if this works? Otherwise, the other possible cause could be the 'locked=' setting which disables window resize and mouse clicks, unless also depressing the SHIFT key.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Jean-Luc,

just to confirm, I am running XP11 Version 11.11   Just updated. So I discovered that the panels will not run in full windows just windowed setting of XP

Also tested multiple planes and all the same results. I just tried using the shift key and no luck. Panels will not work in full window mode. I wonder if anyone else is having issues?

 

Share this post


Link to post
Share on other sites

Here my preliminary feedback ( with pictures )

My config is as follow : XP11.11 / Dual Screen ( One for the outside view, the other one for the gauges rendered by AirManager ) through a GTX750 / I have a third screen on my ipad using Duet .. That's on the ipad that I tested to undocking features

My simulator is running full screen mode ( not windowed ) ... It works very well : not to much lag ( totally usable despite a small small delay ) / Connected well with other simulator components like my radio panels.

I have only one small "bug" when I hold my finger too long on the ipad, the GTN dissapears and I have to activate it again ( like it's desactivate ..)

Will continue to search for this one but for the rest.... whaoooo Finaly a touch screen based GPS in my cessna cockpit

Thanks a lot JP

Two pics : https://1drv.ms/f/s!AvAs9pw2Enb5rR4W12YPDHHxCfsB

 

Share this post


Link to post
Share on other sites

Hi, we cannot reproduce this mouse issue with the latest XP 11.11 (11.0.11.1) and if you have a 11.05 version or 11.1 version backup to compare, I'm wondering what this would give. Possibly another plugin not yet fully 11.1 or 11.11 compatible is interfering?

Share this post


Link to post
Share on other sites

First, thank you for the pop-out windows!  It really was the finishing touch on my simulator.  The Reality-XP products are exceptionally well done.

Is there any way to suppress the Windows 10 menu bar at the top of the pop-out windows?  I'm using the 650/750 and the menu bar appears each time the particular gauge is touched.  It would be great if we could somehow stop that from happening.

Thank you.

Share this post


Link to post
Share on other sites

I´m having the same problem that you cannot click the GTN 750 with the mouse if X-Plane is in fullscreen mode. When I use X-plane in windowed mode the GTN 750 works normally as a popout window. But if I switch to X-Plane "Full screen simulator" the GTN will not react to mouse input anymore. This happen consistently every time. It also happens when using the GTN 750 in non-popout mode.

I have X-plane version 11.11. Tried with Laminar Cessna 172 and Baron 58.

Share this post


Link to post
Share on other sites

@Scotto123 The menu bar is out of our control, it is the way XP11.1 displays popout windows. Now while writing this, I don't remember this to appear. I'm currently out of reach of any test computer but I'll try to see that later. Do you mean a menu bar right below the title bar, displayed like a typical File | Edit | etc... menu in its own row?

@VirtualFlyingFinn This must only be a XP11.11 peculiarity, maybe dependant on the video card? We have consistent working mouse fullscreen/windowed in all our tests, but I'll try to check something else just in case. Nevertheless, can you disable all your plugins but RXP's to cross check any possible conflict? It is very easy to do: 1) create a plugin.disabled folder at the same level of your plugin folder 2) drag and drop the ones you'd disable into this new folder. 3) to restore the plugins, drag and drop them back into the plugin folder.

Share this post


Link to post
Share on other sites

RXP, I apologize, I didn't use the correct Windows term in my previous post.  I was referring to the Windows 10 Title Bar. When the GTN 650/750 is selected, the white title bar appears.

Take a look at this picture.  The 650's title bar appears when the screen is touched and covers the bottom of the GTN 750 stacked above.  Otherwise, it looks perfect.

https://www.dropbox.com/sh/39g75sqiocmklow/AACHuD5LbSMg6n8TZ2mudwPaa?dl=0

I understand it may not be possible but it would be great if we could somehow prevent the title bar from appearing.

Thank you.

Share this post


Link to post
Share on other sites

@Scotto123 this is the title bar indeed! Unfortunately X-Plane is controlling how these are displaying when popped out. It seems there is no SDK provided setting to control this, on the other hand, the only setting is about adding a frame around the window with the same look and feel as the XPlane popped out map window.

Maybe you'd find a way to display an overlaying 'black rectangle' of some sort over the GTNs, like a black cardboard taped to your monitor, cutout to let show the gauges underneath? You'll loose bezel-to-bezel alignment, but this will mask-off the OS chrome title bar.

Share this post


Link to post
Share on other sites
8 hours ago, VirtualFlyingFinn said:

I´m having the same problem that you cannot click the GTN 750 with the mouse if X-Plane is in fullscreen mode. When I use X-plane in windowed mode the GTN 750 works normally as a popout window. But if I switch to X-Plane "Full screen simulator" the GTN will not react to mouse input anymore. This happen consistently every time. It also happens when using the GTN 750 in non-popout mode.

I have X-plane version 11.11. Tried with Laminar Cessna 172 and Baron 58.

 

7 hours ago, RXP said:

@Scotto123 The menu bar is out of our control, it is the way XP11.1 displays popout windows. Now while writing this, I don't remember this to appear. I'm currently out of reach of any test computer but I'll try to see that later. Do you mean a menu bar right below the title bar, displayed like a typical File | Edit | etc... menu in its own row?

@VirtualFlyingFinn This must only be a XP11.11 peculiarity, maybe dependant on the video card? We have consistent working mouse fullscreen/windowed in all our tests, but I'll try to check something else just in case. Nevertheless, can you disable all your plugins but RXP's to cross check any possible conflict? It is very easy to do: 1) create a plugin.disabled folder at the same level of your plugin folder 2) drag and drop the ones you'd disable into this new folder. 3) to restore the plugins, drag and drop them back into the plugin folder.

VFF, sorry to hear you are having the same issue buy very glad to hear I am not alone. Jean-Luc, I did move all the plugins away and same result.I was not able to move XPLM and XPWidgets. The sim refused to start with out them?? I also downloaded the latest drivers for the GPU. I will keep testing and report back.

Share this post


Link to post
Share on other sites

Also having the dead GTN problem.  Running XP 11.11  Multiple aircraft have same symptom.  Even tried with prior version of trainer.  License screen appears but the window will not respond to any click.

Share this post


Link to post
Share on other sites

I was able to get the GTN to work by reducing my configuration to a single monitor.  The I added the other monitors with no problem  Changed the XP Main to a secondary monitor --> broken.   It looks like the XPlane Main monitor and the Windows 10 Primary monitor must be the same for the mouse clicks to been seen?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now