Ray Proudfoot

Aerosoft Lisbon v2 PAPI fault

Recommended Posts

I've had v1 of Lisbon for years and finally got fed up with the grotty looking terminal textures. A month ago I bought v2 for my sim - P3D v3.4

Whilst the terminal buildings are greatly improved the lack of moving jetways is disappointing but my main problem is the disappearing PAPI lights when on final approach. Around 2-3 miles out they just go out.

The problem according to Aerosoft staff is a bug in P3D and the author of Lisbon appears reluctant to fix it when his code didn't cause it. Fair comment. LM haven't released any correction as far as I know.

But this leaves me with a non-functioning PAPI system on a P3D compatible airport. I don't suppose I'm alone having this problem but has anyone got any suggestions on how it can be fixed?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hello.

 

You're not alone indeed. It's another classic Aerosoft costumer support case. "It's not our fault". 

And maybe they are right, but since LM is moving on with P3Dv4 no one will correct the scenery. 

However there is a simple way to correct this problem: via the AFCAD. Use Airport Design Editor to open the AFCAD file and add PAPIs to runways 03/21 and 35 (runway 17 doesn't have PAPIs). Since you're there you might just add default runway lights as well since the lights were also broken by some v3 update and were never updated.

There is another solution: wait for the MK Studios version of Lisbon. But it will still take some time, though. 

Good luck and let me know if you need any help editing the file.

 

  • Upvote 1

Share this post


Link to post

Wolf, you’re a star, thanks very much. I shall attempt that tomorrow and I’ll report back.

Share this post


Link to post

Having given this some thought I hope this isn’t a stupid question. Clearly PAPI lights already exist on Rwy 03 since I see them until 2-3 miles out. How will creating my own fix the problem?

And won’t I end up with double PAPIs?

Share this post


Link to post
8 hours ago, Ray Proudfoot said:

Having given this some thought I hope this isn’t a stupid question. Clearly PAPI lights already exist on Rwy 03 since I see them until 2-3 miles out. How will creating my own fix the problem?

And won’t I end up with double PAPIs?

Rat,  there a papi bgl in the scenery folder which you can take out or disable ?

regards, Gerard

Share this post


Link to post

Thanks Gerard. The fact it's a discrete file makes life easier.

According to Mathijs at Aerosoft the scenery is bought "as is" and there is no expectation for the developer to fix bugs.

Share this post


Link to post

I don't appear to have a PAPI BGL in the scenery folder. Any advice appreciated.

LPPT_Scenery.png?dl=0

Share this post


Link to post

I persevered with the simmershome.de site which does provide a patch for LIsbon albeit with the site almost all in German and the need to register and then go through a purchase process to gain the free file.

I did ask Aerosoft if they could make the file available on their website but that request came to nothing.

And there is no warning on the Lisbon v2 package of any lighting problem with the airport in P3D. Poor service from Aerosoft. :sad:

Share this post


Link to post

In their defence: They are selling it for P3D v1 and P3D v2 and not for P3D v3. So in the end you can't really complain.

But that they have a poor service in general is a given fact I guess :) ... so "professional" ;)

Share this post


Link to post
12 minutes ago, officercrockey said:

In their defence: They are selling it for P3D v1 and P3D v2 and not for P3D v3. So in the end you can't really complain.

But that they have a poor service in general is a given fact I guess :) ... so "professional" ;)

I would have preferred to see a prominent notice that it is not 100% compatible with v3. That would have made me think twice. Hopefully the patch will fix things.

Share this post


Link to post

Hello.

Sorry to answer so late but I've been away from my PC.

I've "deleted" two files from the Aerosoft folder that Ray showed above:

LPPT_RWYLights.BGL.off

LPPT_ZLIB.BGL.off

And then edited AF2_LPPT.BGL via Airport Design Editor to include PAPIs and RWY lights.

This way we get rid of the non working runway lights and PAPIs for the (ugly but working) default ones.

 

Share this post


Link to post

My problem with the airport including the above is the height problems of the parking, taxiways and just generally the airport. I have ORBX and tried the app for elevation fixes etc and it's still the same ugly mess. Simply stopped flying there.

Share this post


Link to post

Thanks @Wolf0. I’ll try the patched file first and then try your suggestion if the patch isn’t to my liking.

Share this post


Link to post

@Wolf0, I've renamed the extension of the two files you listed plus my existing AF2_LPPT.BGL and added yours. But I'm not seeing any PAPI lights on 03/21.

Share this post


Link to post
On 12/21/2017 at 7:35 PM, Wolf0 said:

Hello.

 

You're not alone indeed. It's another classic Aerosoft costumer support case. "It's not our fault".

 

I agree, AS are really good at relinquishing responsibility on scenery issues.

Share this post


Link to post

Having gone to great lengths to acquire the free patch from the German site I installed it and now have working (but somewhat crude) PAPI lights plus the other airport lights.

That package included extra texture files which might explain why the PAPIs became visible. Thanks to @Wolf0 and others for their help.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now