frat0r

no atc (almost) after take off

Recommended Posts

hey there!

i´m on the latest trial and after filing a flight plan and getting clearance for take off there is no atc for me other than correcting altitude, but no course correction after I´m in the air. it gave me only once the "you are off course, plz turn..." when I was many miles in a opposite direction.

isn´t it supposed to tell me to fly to the next waypoint according the sid in the flight plan?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

No.  You are supposed to fly the flight plan either manually or using the automatic pilot. 

If you are following the flight plan and get off course a bit, you may get an "off course" call, but don't expect ATC to give you vectors along the route.

Share this post


Link to post
Share on other sites

thx for your quick reply.

does this mean when I´m on ga, i.e. n the Cessna, I have to enter the flight plan into the navi by hand? or can I just use the autopilot in pilot2atc set to "nav"?

i´m guessing it´s more realistic that way but the internal atc and the one from x-life gave me corrections to the course along the route and I expected the same in pilot2atc.

Share this post


Link to post
Share on other sites

As in the real world, you need to enter a flight plan into the aircraft GPS or FMC in order for the autopilot to follow it.

Depending on the SIM and aircraft and GPS or FMC unit, there are different ways of importing or loading a flight plan file.  Or you can always enter it manually.

If you want to import/load it from a file, you will have to check the documentation for the GPS unit and figure out what format it needs to be in and how to do it.  In most cases, you can export it from P2A to that format.

Share this post


Link to post
Share on other sites

Hello. I downloaded the trail yesterday and have tried MANY times to get P2A clearance delivery (at any airport) to respond. I try with voice or with SAYIT and nothing happens.

When I use SAYIT, my request will show in green, no response. Validated and Filed flight plan boxes both show green. Using correct (only) clearance frequency.

It will respond occasionally, but mostly silence. I think the same is happening with other services (ground etc), but mostly I have attempted to get clearances. Why doesn't P2A respond?

Share this post


Link to post
Share on other sites

Here are some things to check:

  1. SWITCH SETTINGS: Check to be sure the Power indicator in the bottom left of the main P2A screen is  green.  If not, then you need to turn on the battery switch and avionics switch in the aircraft, or if that doesn’t turn it green, check the 2 options “Ignore Battery Switch” and “Ignore Avionics Switch” in the Config P2A Setup panel.
  2. VALID CALL SIGN: Make sure you are using a valid call sign by changing it to the default Mfg: Beech; Tail Number: N431VB and pressing the Save Button.  You can send me a screenshot of this page and I will let you know if there is a problem with the call sign.
  3. VALID FREQUENCY: Be sure you have a valid frequency showing in the Active frequency display.  Open the Radio Panel and check that the frequency selected has a valid controller assigned.  Try swapping the active and standby frequencies a couple of times.
  4. PTT BUTTON: Use the PTT button on the main screen to eliminate the possibility of it being the Joystick button setup as the issue
  5. VALID PHRASES: Make sure the phrase you are using is appropriate for the controller.  “Say Altimeter” should work with all controllers, so use it.
  6. VOLUME SETTINGS: Check the Windows Volume Mixer and be sure Pilot2ATC volume is turned up. (RIght click on the speaker icon in the task bar and select Volume Mixer).  Also check the volume of the voices in P2A Config.  On the Communications tab of the Sound dialog, be sure "Do Nothing" is checked for when Windows detects Communications activity.
  7. GRAMMAR HELP SCREEN AND DIAGNOSTICS: Try using the Grammar Help screen. 
    • Press the Grmr Help button to the right of the Flight Plan
    • Pess the Practice button
    • Take a screenshot of the resulting Message box with the connection information and email to me
    • Try saying "Say Altimeter" with no other words.  It should be recognized.  Let me know the result.

Share this post


Link to post
Share on other sites

Dave, thank you for the reply and suggestions. To recap:

I neglected to mention I am using XP11 current beta

I had ignore battery and avionics switch boxes checked,

P2A set to airline, Delta, call sign DAL 515. When I could get atc to reply, it replied properly,

Again, when I could get a reply, it was on the correct frequency

PPT box showed green when I keyed the xmit button. My verbiage showed in the right hand box and then turned green, I assume it meant P2A heard me, no response.

I also tried the SAYIT function, same result

Nothing I phrased resulted in a response, even using SAYIT

Volume was OK

Since my verbiage showed in the right hand box correctly in green, I assume P2A "heard" me correctly.

Couple of observations:

When I first tried P2A, I filled in the flight plan (KLAX-KLAS), validated it (turned green), but failed to file. I called clearance and it informed me I had no flight plan on file. I filed it (it turned green), tried clearance again, no response. I unchecked both validate and file, clicked them again, both turned green, tried clearance, nothing. If P2A is following some type of script, maybe a reset it needed to re sync??

From there, nothing seemed to get P2A back, on any freq, trying voice and SAYIT. Shutting P2A down without shutting XP11 down seemed to have no effect. Reloading both seemed to be the only way to recover. Frustrating.

Last night, I tried a flight from KLAX to KPHX. Validated and filed before contacting clearance, worked OK. Rest of flight went OK till missed approach (traffic on runway, I use WT3), P2A didn't handle the missed properly, Finally flew back to IAF and reestablished with P2A and was cleared for the RW07R approach and landing. (99% went OK).

Also tried a short (GA) IFR flight as Eclipse 24S from KEEO to KPUB. Non-towered airport. Contacted Denver Center on ground (freq was already loaded by P2A), received clearance. Went to CTAF, took off, contacted center on same frequency as before. Radar contact. Then first center freq handoff went OK, on second freq handoff, silence. Never could reconnect with P2A on any frequency. As you can read P2A responses in the right hand box, confirmed correct frequency, reported DENVER CENTER, ECLIPSE 24S with you at FL170, nothing. Continued flight, shut down P2A, re-launched it, validated and filed same flight plan, nothing, I was in-flight, did not shut down XP11. Again, seems if script is interrupted (in this case, to my knowledge, nothing interrupted it), silence.

As time permits, I will continue to experiment. BTW, I do indeed try the simple commands as suggested, SAY ALTIMETER etc. I am a RW pilot and understand the phraseology. 

Hope something in this diatribe is helpful.

 

Share this post


Link to post
Share on other sites

You say your call sign is DAL 515.  Your Call Sign box should have the Airline option checked, the Call Sign box should say Delta and the Flight Number box should say 515 and your full call sign should be Delta 515.  If not, it could cause some issues.

If you could send me the P2A logs for those flights I can see what might have gone wrong.  Email them to me at admin@pilot2atc.com.  

Log files are located in:

C:\Users\<UserName>\AppData\Roaming\P2A_200\Logs

where <UserName> is your PC user name.  Portions of the path may be hidden by default, so be sure Windows Explorer has Show Hidden Items checked in the View menu.

A new one is created each time you start Pilot2ATC, so if you take the most recent one when you have the error, you should have the correct one.

Thanks,

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now