Daedalus

PTA v2.61 update question for P3D v4.2

Recommended Posts

I have a question regarding the PTA update process. 

I updated P3D to v4.2 via the Client-only update. I had already installed a PTA preset before I updated.

Before the client update, I did not restored the initial shaders in PTA 2.6.  

As a result I was not able to restore the initial shaders after I updated to v4.2 as PTA v2.6 did not work.

Now, PTA v2.61 is out. If I do a clean install of PTA v2.61 it won't be able to save the default P3D shaders I guess because they are already modified.

So, what is the correct procedure so I can still have the default P3D v4.2 shaders as a backup in PTA 2.61 ?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Installing the client for P3D v4.2 resets the shaders back to default - so you essentially have a clean copy.

All you need to do is download PTA v2.61 and run it - it'll work just fine.

  • Upvote 1

Share this post


Link to post
Share on other sites
3 minutes ago, MattDavies said:

Installing the client for P3D v4.2 resets the shaders back to default - so you essentially have a clean copy.

All you need to do is download PTA v2.61 and run it - it'll work just fine.

Ah perfect ! Thank you very much for the quick reply Matt ! : )

Share this post


Link to post
Share on other sites

Just a word of warning (slightly off-topic - sorry) ... but FSUIPC 5.123c (the latest) has issues with P3Dv4.2. FSUIPC 5.123b (and any versions prior to that) are fine, apparently. Major stuttering and SimConnect issues. Pete isn't back from holiday until 20th Feb so there'll be a little wait. He's usually pretty quick.

I'm going to wait a week or so before going to 4.2.

Matt - are there any other changes to PTA with 2.61 (from 2.60) that I need to know about - with respect to revising my presets?

Adam.

Share this post


Link to post
Share on other sites

As I already poseted in another thread : if you use the cloud directional custom tweaks, remove them as they do not work in P3Dv4.2 and make the 3D clouds dissappear.

Share this post


Link to post
Share on other sites
3 hours ago, Adamski_NZ said:

Just a word of warning (slightly off-topic - sorry) ... but FSUIPC 5.123c (the latest) has issues with P3Dv4.2. FSUIPC 5.123b (and any versions prior to that) are fine, apparently. Major stuttering and SimConnect issues. Pete isn't back from holiday until 20th Feb so there'll be a little wait. He's usually pretty quick.

I'm going to wait a week or so before going to 4.2.

Matt - are there any other changes to PTA with 2.61 (from 2.60) that I need to know about - with respect to revising my presets?

Adam.

Nope - there is nothing from a functionality point of view that's changed except supporting the new version. 

  • Upvote 1

Share this post


Link to post
Share on other sites
6 minutes ago, MattDavies said:

Nope - there is nothing from a functionality point of view that's changed except supporting the new version. 

Great - thanks, Matt - I've already had some queries as to whether my last preset will work with 2.61 and I couldn't answer them without going down the 4.1->4.2 route myself!

Adam.

Share this post


Link to post
Share on other sites

I have presets that now throw a few errors when applying which is probably related to what GSalden is referring to. That's one of the bummers here is that every time a version jump is made not only does PTA need an update, but many of the presets do as well.

Share this post


Link to post
Share on other sites

Well ... I bit the bullet and installed the P3Dv4.2 client - thinking I can always remove it and reinstate 4.1. Got PTA 2.61 ready and waiting ... and off I went!

So far (touch wood), everything seems OK. My version of FSUIPC wasn't recent, so no problems there. All my add-on aircraft seem to work (I don't own any of the apparently "problematic" ones).

The PTA upgrade was simple and painless - and my old preset (Adam 26_02) seems to work fine - no issues there either, as far as I can see.

Thanks for the quick release of the compatibility update, Matt - much appreciated!

Back to flying again!

Adam.

  • Upvote 1

Share this post


Link to post
Share on other sites

ok ... can somebody please help me :( .

its freakin me out . i just got the PTA ... sadly 2.61 ... i want the 2.6 setup . and i cant find it on the website . can anybody help me please ? cuz i am not updating to p3d 4.2 at this time . please help. any help is appreciated . thanks

Share this post


Link to post
Share on other sites

For some reason 2.61 isn't working for me. I keep getting the following errors:

ERROR: shader file D:\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx is not original Prepar3D shader and can't be used
ERROR: shader file D:\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx is not original Prepar3D shader and can't be used
ERROR: shader file D:\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh is not original Prepar3D shader and can't be used
ERROR: shader file D:\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fxh is not original Prepar3D shader and can't be used
ERROR: shader file D:\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl is not original Prepar3D shader and can't be used
ERROR: shader file D:\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\FXAAResolve.hlsl is not original Prepar3D shader and can't be used
 

I ran a repair on the client to rebuild the ShadersHLSL file, after deleting the shader folder in appdata/local. everything is run with administrator. Here's what PTA shows in setup info:

PTA version : 2.61
Prepar3D main directory: <D:\Lockheed Martin\Prepar3D v4\>
Target Prepar3D version: <4.2.21 build 24048>
Prepar3D main config file: <C:\Users\lacel\AppData\Roaming\Lockheed Martin\Prepar3D v4\Prepar3D.cfg>
Shaders cache directory: <C:\Users\lacel\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders\>
Shaders backup directory: <E:\FS-Addons\Graphics\PTA\SHADERS_BACKUP\>

Unfortunately I still can't figure out how to post a screenshot.

 

Never mind (as he sits shaking his head), I fixed it. I didn't realize that I should have deleted the ShaderHLSL folder before running the Client to repair. "DOH!!" 

Share this post


Link to post
Share on other sites

Uninstall PTA. Delete any leftover from PTA ( folder ).

Un - reinstall P3Dv4.2 Client That will create the correct Shaders again.

Then re-install PTA and re-save the Shaders with PTA.

  • Upvote 1

Share this post


Link to post
Share on other sites
15 hours ago, Samany69 said:

ok ... can somebody please help me :( .

its freakin me out . i just got the PTA ... sadly 2.61 ... i want the 2.6 setup . and i cant find it on the website . can anybody help me please ? cuz i am not updating to p3d 4.2 at this time . please help. any help is appreciated . thanks

https://0310e3e48f9f8fd91f21-c59b2c829b25cbc666933a71e5c2b2ea.ssl.cf3.rackcdn.com/releases/pta_2.60.zip

  • Upvote 1

Share this post


Link to post
Share on other sites
5 minutes ago, MattDavies said:

ah awesome . thanks to you . btw matt , just wanted to tell you , i am happy with your product. but i would like to have your recommendation on presets , cuz there are tons of them , i want the best of the bests for flying IFR and VFR at the same time .  thanks again .

Share this post


Link to post
Share on other sites

Everybody has different tastes - I included my preset with the download because that's the one I use. It doesn't necessarily mean it's the best - it's all relative to your preferences. 

Share this post


Link to post
Share on other sites

Not sure if this is on subject. Just beginning descent into WSSS from VHHH in PMDG 747. Left the room whilst in decent, on return P3d had shut down. Can't find application crash log so not sure what happened.

i had updated to p3d v4.2 earlier in the day but hadn't updated PTA ( I now have ) 

Add ones running ( all current versions )

chaseplane

asn

traffic live

Any ideas 

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now