Sign in to follow this  
A32xx

Antialias in Full Screen Mode - FIXED!

Recommended Posts

If you're using nVidia Inspector, you can now get Antialiasing (AA) in full-screen mode in older games such as FS2004 and FSX in Windows 10:

(From the A2A Simulations forum, posted by molleh)

Towards the top of the profile settings in your nVidia Inspector profile you will see a setting called "Antialiasing compatibility."

Set that to "0x004412C1 (Diablo III)" and it should work again.

Apparently many other games that run in exclusive fullscreen mode require a similar change to the antialiasing compatibility flag to have the profile settings stick like they should. In the Fall Creators Update, MS changed how fullscreen rendering works - for example, you can disable Vsync now in a borderless windowed app (such as Prepar3D!) which wasn't actually possible before because of the desktop compositor which basically forced Vsync. Apparently this new functionality wasn't tested very well on older apps/games.

  • Like 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Whaddaya know... this really works!!! Thank you thank you thank you!

I turned AA off within FS9 again and set up the nVidia Inspector profile like I used to in Win7.

Override the application setting, 16xS AA + 8x Supersampling and it looks stunning! 4 x Multisampling + 4 x SGSS also works as before, but I find that 16xS + 8 x Supersampling gives the best result on my GTX970.

Who knows what other hidden treasures are yet undiscovered.

Share this post


Link to post
Share on other sites
Posted (edited)

Would that work in p3d ?

Edited by MindYerBeak

Share this post


Link to post
Share on other sites
On 14/03/2018 at 12:08 PM, A32xx said:

If you're using nVidia Inspector, you can now get Antialiasing (AA) in full-screen mode in older games such as FS2004 and FSX in Windows 10:

(From the A2A Simulations forum, posted by molleh)

Towards the top of the profile settings in your nVidia Inspector profile you will see a setting called "Antialiasing compatibility."

Set that to "0x004412C1 (Diablo III)" and it should work again.

I'm a little confused by this statement. I have Windows 10 Pro, 64bit (Fall Creators Update) fully up to date and I've always been able to get antialiasing in FSX running full-screen. I use NVIDIA Profile Inspector and have always left the Antialiasing Compatibility setting at default (0x00000000) in the Microsoft Flight Simulator 10 profile.

Share this post


Link to post
Share on other sites

I'm sorry to revive this topic but I really need to thank you for this, I was trying to solve this problem for a long time and you saved me !! THANK YOU !!!!!!!!!!!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this