Jump to content

n4gix

GNS530/430 Remain Dark - SOLVED!-

Recommended Posts

I just installed the latest version of the GNS530 and GNS430 in both P3Dv4.2 and FSX:SE. Using the configuration tool I installed them in the new Milviz C310R Redux in anticipation of finalizing the Service Release this weekend.

To my utter surprise and confusion, both units refuse to "turn on" and the screen remains completely dark. All mouse actions are working, which proves that the gauges are loaded...

I installed the same pair into the C172 in FSX:SE as a "sanity check" and the same thing applied there as well: the screens remain totally dark. :ohmy:

Quote

//--------------------------------------------------------
[Window03]
size_mm=100,100
window_pos=0.617188,0.201796
window_size=0.382812,0.506144
visible=1
always_visible=0
zorder=99
background_color=0,0,0
ident=15531
gauge00=rxpGNS2!GNS_530_1, 0, 0,100,100

//--------------------------------------------------------
[Window04]
size_mm=100,100
window_pos=0.617188,0.707940
window_size=0.382812,0.292060
visible=1
always_visible=0
zorder=99
background_color=0,0,0
ident=15432
gauge00=rxpGNS2!GNS_430_2, 0, 0,100,100

Share this post


Link to post
Share on other sites

Addendum to the above:

I note that the G530SIM.exe and hsi400wx.exe are not being loaded at all, which means that the Garmin Trainer isn't available.

Edited by RXP

Share this post


Link to post
Share on other sites

Hi Bill, 

The standard G530/G430 ON/OFF default is volume only until changed using SHIFT + Right Click on the upper frame of the unit. Towards the bottom of configuration pop-up screen is the option to change default ON or OFF. I use default OFF and the center mouse wheel to activate. Please pardon me if you're already aware of this. 

 

Share this post


Link to post
Share on other sites

Thank you for the reply Les. Both the 530 and 430 are set "Always On". As per the Addendum note above though:
 

Quote

 

I note that the G530SIM.exe and hsi400wx.exe are not being loaded at all, which means that the Garmin Trainer isn't available.

 

 

Edited by RXP

Share this post


Link to post
Share on other sites

This is just an update to confirm that the "dark screen" problem has been solved.

Since the F1 GNS530/430 units worked just fine, I knew that the G600 Trainer package was installed. So, it stood to reason that since the Trainer wasn't being loaded by the RXP units, for some reason they weren't "seeing" the G600 Trainer.

I uninstalled the G600 Trainer and reinstalled it to the default folder location on the C drive. Now the RXP units are working perfectly. I didn't want to install this on my C drive because it's a small SSD, but I have no real choice unfortunately.

F1 was clever enough to simply ask me in a popup window to browse to the G600 Trainer's actual location and continued merrily along.

Anyway, that problem is solved! :biggrin:

Share this post


Link to post
Share on other sites

Hi Bill,

In this case, the rxp log files should have tell the GNS V2 failed to locate the Garmin Trainer. Please note the GNS V2 always find the trainer: installer saves installation location to registry and the RXP GNS V2 picks it up, unless you manually move the installed files AFTER installation in which case only you knows where to.

Should you've manually moved the trainer files in another location, you may manually configure a couple environment variables to explicitely tell where to find the GNS trainer.

This is all explained (logs and environment variables) in the User's Manual.

Share this post


Link to post
Share on other sites

No manual movement of the Trainer(s). When I installed both Trainers, I specified to use the suggested path, but on the D drive instead of C. For whatever reason, the GNS units failed to find them. But, all is well now so it's no longer much of a concern for me. I just needed them working so I could get on with my tweaking... :cool:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...