Alberto Zanot

Free Bombardier CRJ-700 Complete HD Rework for Prepar3D v4

Recommended Posts

Posted (edited)

Please Note: 

I am having troubles with my website. Meanwhile download the aircraft from here:

https://drive.google.com/file/d/1_TBjK9Jm4AtUg1U0k61LsCwxIrNUmJ3D/view

 

Finally i finished my work, and i would like to share it with the community.
It is a complete high definition rework of the default CRJ-700, ported to (and only compatible with) Prepar3D v4
This thread is intendended to be a feedback and support thread.
Some feature:

  • 4K external and virtual cockpit high definition textures
  • TrueGlass© rain drops effects from TFDi Design©
  • Milviz© WX Advantage Radar© implementation (not included, you must own the product)
  • Added new cockpit sound effects
  • Impressive lighting effects and smooth day/night transitions
  • New and fixed flight instruments and VC integrated FMC
  • Hundreds of visual and programming fixes and improvements...

Some images and the showcase video:


bcg_slide-1.jpg

bcg_slide-2.jpg

bcg_slide-3.jpg

bcg_slide-4.jpg

 

Video:

 

Download at: http://www.webalice.it/ozoners

Hope you like my work.

 

 

Edited by Poppet
edited post on the request of OP to Include an additional link
  • Like 3
  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

When reporting a problem (i.e. a P3D crash when loading one of the flight scenarios included in the zipped file), please:

  • describe the problem the best you can, including every detail
  • copy and paste here the Windows Event Viewer details about the P3D crash

Together we can try to find out what is causing the issue and fix the problem.
Thanks!

 

 

Edited by Alberto Zanot

Share this post


Link to post
Share on other sites

250 visits to the thread and approx. 200 downloads.

But no replies. Well, looks like there are no issues and everything works.
Very good.
I just hope that people also like it :-)

Have a shiny day!

Share this post


Link to post
Share on other sites

Hi Alberto,

LOL - welcome to the wonderful world of freeware development - I've had projects downloaded over 2000 times - without a single comment -  sometimes casting files off into the abyss that is the file library can be a tad anticlimactic...

Haven't tried your work so I can't comment on it - but THANKS for the huge effort - noted some of your posts over on FSDeveloper - looks good...

Regards,
Scott

  • Like 1

Share this post


Link to post
Share on other sites

Hi Alberto, superb mods for this a/c.

However, on my first flight (ready for t/o) P3Dv4 crashed to desktop after 12 mins of flight. No errors shown.

I will test again because the a/c is worth it, that's for sure.

Just going through the manual now😤

Pierre

Share this post


Link to post
Share on other sites

3rd attempt. Crashed to desktop again after 14 mins. Nothing in the event viewer.

This time I loaded the default flight (F22) and loaded the CRJ700 no dyn lights.

That is all I have for now.

Cheers,

Pierre

Share this post


Link to post
Share on other sites

Mh this is puzzling with this few informations. And always later almost the same minutes... mh...

I've only found problems with Milviz WX Radar installed during my testings. Then they updated it and in all my test flights it flew for 12 hours no stop (unlimited fuel naturally).

Do you have the Milviz wx radar installed and did you installed in the AC?
Also try to change location, take off from somewhere else.
Did you tried also the "dark and cold" flight?

 

Share this post


Link to post
Share on other sites

Yes, I have the Milviz wx radar. It is installed. Followed your instructions for that "place mv_wx.dll" in the panel folder but I don't think that is right!!!!. The mv_wx.dll is in the "gauges" main folder. But I tested both setup : inside the panel and inside the gauge folder with the same crash to desktop. (disabled the mv_wx.dll while i did so).

My last flight: ready for takeoff, with mv_wx.dll in the gauges folder and tried disabling Active Sky 16. CTD after 10 mins.

Will try your suggestions

Share this post


Link to post
Share on other sites

the folder "panel" of the plane is correct for the DLL.
P3D (and FSX) works like this: the "gauges" main folder contains the 'common' gauges, but if there is a gauge (even with the same name) in the plane "panel" folder, the simulator will use that and ignore the "gauges" ones.
I think that you have to update your WX radar with the milviz updater, they released a lot of updates for p3dv4 later these days.
Once you upated it, go in the main "gauges" folder and copy the updated DLL copying it in the "panel" plane folder.

Share this post


Link to post
Share on other sites

My mv_wx.dll is up to date: Just checked again, no updates available. It is listed for P3Dv4.2. Listed as version 1.40.40 dated 22 03 2018.

As per suggestion: loaded cold and dark at LFMN. Did not activate the wx radar from the cockpit and P3D did not crash.

So it is looking like the wx gauge is the problem. Will check my other planes with wx radar and see the results.

Share this post


Link to post
Share on other sites

yes please let me know.
also the fact the you lodaded dark and cold and moved the plane at LFMN may have helped.
I mean, probably is not 100% the wx.

Share this post


Link to post
Share on other sites

and i think that you do not have planes woth the wx radar integrated INSIDE the VirtualCockpit. Correct? They are just window gauges, i think.
I ask because there is big difference.

Share this post


Link to post
Share on other sites

Presently flying with the Baron with mv_wx.dll in the cockpit and working flawlessly. No problem. So yes, I have planes with wx radar in the vc, but I have others with the 2d window wx radar.

Of course, as you know they do not use the same files: mv_wx.dll is for the vc and mv_wxm.dll is for the 2d popup.

While I write this my B55 is still running fine with mv_wx.dll after 20 mins.

So my last attempt this morning will to try: change to LFMN cold and drak and initiate wx radar.

 

Share this post


Link to post
Share on other sites

Another 10 mins of flying. No CTD.

Changed departure to LFMN, initiated mv_wx.dll from the cockpit. Departed Nice towards the north (Tstorms) , no problem and wx radar showing rain activity in the area.

So, maybe a problem with the initial scenario LIRF and ready for t/off ??

On a side note Alberto, I use dyn lighting and noticed the dyn light of the a/c seems too much: for example, with just the taxi lights, dynamic lighting washes out the runway markings so they become unreadable. Just my observation.

Have to go to lunch now,

Cheers,

Pierre

Share this post


Link to post
Share on other sites

Thanks Pierre.

It is not the readytotakeoff scenario, because the parameters are the same with darkandcold scenario. 

I have run in a similar problem years ago, CTD  always after same minutes, always at the same location. It is a ai traffic related problem. Nothing to do with the plane or scenario or wx radar. 

If you try to do same flight with another jet with similar speeds you will see that your p3d will crash anyways. 

I bet you use a ai traffic addon. Probably mytraffic. That is your issue. 

I solved turning off the military.bgl

Hope this helped. 

Share this post


Link to post
Share on other sites

Well it is not the AI either. I do not use mytraffic. As I do not trust software that much, redid the scenario with the f50 from Caranedo and no CTD

So, it is something else.

Share this post


Link to post
Share on other sites

I think the F50 cannot get in *that exact location* in *that exact time* as the CRJ does.
Maybe it is not a good comparison.
Anyways i am afraid i ran out of ideas 😞

Share this post


Link to post
Share on other sites

The F50 was not meant to be an exact copy of the CRJ flight. It was just to demonstrate that the AI was perfectly OK for that departure and the result is just that, the AI is perfectly OK.

I redid a number of flights with the CRJ to try and come up with some common cause.

I found out that I have already have TrueGlass from Milviz C310R and am about to test it disabled and see the results.

Maybe it interferes with your TrueGlass.

Will see

Share this post


Link to post
Share on other sites

Could be...
Every plane got its own trueglass installation, but could be.

Thanks again for your time and testing Pierre!
Let me know how about without TG.

Share this post


Link to post
Share on other sites

Alberto could you confirm what your PC configuration is?

Here I use:

P3Dv4.2.21 i74790K GTX1080ti video drivers 378.78, video memory 11264 mb, 16gb ram

On that setup, I run XP11, FS2, FSX, P3Dv3.4.22 and P3Dv4.2.21

 

Share this post


Link to post
Share on other sites

Another thing Alberto, the CRJ doesn't show in P3Dv3.4.22. You can hear sounds from the engines but no planes are shown.

Share this post


Link to post
Share on other sites

Hello ! 

I confirm, the CRJ is invisible in P3D V3 but it works on PD3 V4. 

I also wanted to report a bug on the CRJ. The HP/IN button does not work, the display remains only in inchs even if the pop-up shows the HP mode. Secondly, I don't know if it's normal but when the autopilot or speed hold is activated, there is no indication on the PFD.

I also have a question : Is it possible to undock the gauges ? I'm building a home cockpit based on a CRJ and it would be interesting to integrate your gauges into my cockpit. It would also be easier to use certain buttons when flying.

Otherwise, congratulations pour this great job !

Share this post


Link to post
Share on other sites
Posted (edited)

@ppo

Sure, mine:

P3Dv4 4.2.21.24048
i7 3770K @ 4.3 ghz
GTX 980ti drivers 391.35 6gb memory
16GB Ram

About P3Dv3, damn, i will check again monday, on my P3dv3 machine.

@dylan33

Thanks i will check both HP and PFD.

There are no windowed (undockable) gauges. Everything is integrated in the VC.
And some of the switches, i.e. the wipers are not bindable to any key, sorry.

Thanks!

Edited by Alberto Zanot

Share this post


Link to post
Share on other sites

Oh, Pierre, did you tried also the TUTORIAL scenario?
and try to follow the tutorial (there's also the PDF)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now