thefrog

Windows 8.1 powering down my controllers

Recommended Posts

This has been a longstanding issue for me with Win 8.1 and I wondered if anyone on this forum had experienced the same problem and found a solution. It occurs with my USB joystick, Saitek yoke and throttle. I uncheck "Allow the computer to turn off this device to save power" for the Power Management properties in all the HID's, but then a few days or weeks later, my devices stop functioning mid-flight and I discover that some of them are checked again.

There doesn't seem to be a way of permanently saving the setting.

 

Any thoughts would be welcome!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If I remember correctly, I think there are only two solutions; upgrading to Win 10 or get a registered version of FSUIPC and set controllers through there.

Share this post


Link to post
Share on other sites
Posted (edited)

"updating" to Windows 10 is probably the best solution. 

 

Edited by Jude Bradley

Share this post


Link to post
Share on other sites

When you were in Device Manager, did you also go down the list to USB Controllers > USB Root Hub and do likewise in the Power Management tab?

Chris

Share this post


Link to post
Share on other sites

Many thanks for all your replies.

Yes I have got FSUIPC and my controllers are set through that.

I went to check the USB Root Hubs just now because I forgot about those this time and yes, some had now got "Allow the computer to turn off this device to save power" checked - even though I unchecked them originally several weeks ago.

So there doesn't seem to be a way of permanently saving these settings. So I either upgrade to Win10 or check the device settings every few days!

Share this post


Link to post
Share on other sites
Posted (edited)

There is a way to edit the registry and stop this behavior in Windows 8.1 BUT getting to Windows 10 is a better solution.

There are still some controllers/devices that are affected in Windows 10 (Thrustmaster MFD, in my case) but overall, the problem is much resolved.

Here is an article I wrote about editing the registry in Win 8.1. See "USB Device Problem"

https://uchisworld.wordpress.com/2015/10/08/exploring-a-dark-forest/

EDIT: PS read the comments to the article as well

Edited by Henry Street
  • Like 1

Share this post


Link to post
Share on other sites
On ‎19‎/‎04‎/‎2018 at 12:11 PM, thefrog said:

This has been a longstanding issue for me with Win 8.1 and I wondered if anyone on this forum had experienced the same problem and found a solution. It occurs with my USB joystick, Saitek yoke and throttle. I uncheck "Allow the computer to turn off this device to save power" for the Power Management properties in all the HID's, but then a few days or weeks later, my devices stop functioning mid-flight and I discover that some of them are checked again.

There doesn't seem to be a way of permanently saving the setting.

 

Any thoughts would be welcome!

This will fix it:

 

http://uraster.com/en-us/products/usbenhancedpowermanagerdisabler.aspx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now