jeno26

Wonky Cockpit Lighting in P3Dv4.2

Recommended Posts

Posted (edited)

Hey folks,

 

It's been a few years since my last post here, but I have not been able to find the answer to the problem I am having. I recently switched over to P3Dv4.2, and have had no issues aside from VC textures inside my PMDG 777. Please take a look at the information below, thanks!

 

Problems:

1. My VC looks blurry with mipmap turned on (both daytime and night so I have been flying with mipmap turned off via the P3D in game settings)

2. During hours that require cockpit lights, turning on floodlights will create what I can best describe as orange and black stripes along the areas of the lighting (Please see "Without mipmap" photo in link below). Now, if I turn mipmap back ON during the same flight with the floodlights still on, my lighting looks perfect, but the VC once again becomes blurry (please see "With mipmap" photo in link below).

 

Photos for above problems:

https://drive.google.com/open?id=1FE4GOedHLAq-g6vDoXjeHnWKcbMsa7DY

***I know from the photos above that the textures from both photos look just as blurry, but with mipmap off, the textures are much clearer, the screenshot just didn't capture it as well.

 

In my P3D Display setting, I have:

FXAA: Off

AA: 4xMSAA

Texture Filtering: Anisotropic 16x

Texture Resolution: 4096x4096 

Wide-view Aspect Ratio: Off

No personal modification to my .cfg file except the use of the PTA tool.

Edited by jeno26

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Please note PMDG forum rules ask for our full names on all posts.

Why do you have wide aspect ratio off?  It looks like you have a 16x9 display and should be using this option.  I do not see a difference with mipmap on or off and also use same settings without PTA, my display is crystal sharp.

Share this post


Link to post
Share on other sites

Jeno,

first of all, great detailed support request, if all people would share information like this it would be a lot easier to (try to) help.

second: please notice, that PMDG requires all postings to be signed with the full name.. 

third: have you tried it with wide-view aspect ratio turned on? you have a wide screen, there's actually no sense in turning it off or what do I miss? I guess you have to zoom out quite a bit which definitely will make the textures look blurry. 

What graphic card do you have?

Share this post


Link to post
Share on other sites
Posted (edited)

Oops! Signature line has been added.

 

Ephedrin, 

I have tried with Wide View Aspect Ratio turned on, and the result has been the same (mipmap still causes blurrier textures and the lighting issues still exist to the same degree)

*I am using a GeForce Nvidia 1070 graphics card

 

I find it quite odd because I also own the FlytheMaddog MD82 64bit and the lighting and textures have had no issues (both with wide view turned on and off, although mipmap also makes those textures blurrier)

Edited by jeno26
Added pertinent information

Share this post


Link to post
Share on other sites
Posted (edited)

I don't have a "that's it" solution for you but a few guesses you could check or try.

 

- Gracard driver up to date?

- NVIDIA inspector (if you use it) doesn't have the same effect anymore as with previous versions of FSX/P3D. If something was changed, only use the NVIDIA Control Panel. There, if you haven't tried that yet, are some settings that might improve your display (and performance if needed). Google may help to find proper settings for your card, also you don't need to touch your cfg anymore. 

- you have a good graphic card. Do you also have a good screen? This sounds a bit silly, I know, but I had issues with the DVI plug and P3Dv3 until I got a new screen and used HDMI. 

- check that you don't accidentally use 16:9 in the Sim and 16:10 on your screen (or vice versa). 

 

just a few thoughts, I hope you get this sorted.

Edited by Ephedrin

Share this post


Link to post
Share on other sites

Graphics driver is up to date.

Nvidia: I just checked the settings for P3D via Nvidia Control Panel and saw that the FXAA setting was still turned on! It has now been turned off.

My monitor should be fine for the purpose of flight sim, I am using a gaming monitor with 1ms with 144hz (I have not been experiencing tearing or stuttering yet with unlimited FPS)

Does the Wide View Aspect Ratio turned on mean that the sim is running at 16:9 ratio? (My current monitor setting via NVIDIA Control Panel is set to Full Screen, not Aspect Ratio)

Share this post


Link to post
Share on other sites
Posted (edited)

I would recommend that you save your P3D Inspector profile and return it to default. (All the ones that point to your P3D exe). Leave Wide Screen Aspect ON and see what happens. Inspector setting having conflicts with P3D settings would be my 1st order of business. Get that doubt fully out of the way and go from there. 

Edited by xkoote

Share this post


Link to post
Share on other sites

I highly doubt that the vga is the problem. 

We have a texture problem - to be precise a 2D bitmap. (DDS)

The graphics card is just mapping them and that seem to be a problem here. The filtering looks wrong.

 

The blurry VC is normally linked to FXAA when using high DPI Displays. 2K,4k etc.

Do you have such a 2k display ? 4K isn't available in 4K.

Please post your resolution.

 

Share this post


Link to post
Share on other sites

I am using a 1920x1080 monitor.

 

Small update: even after turning FXAA off in both P3D and NVIDIA Control Panel, I have been unable to resolve the issue.

Share this post


Link to post
Share on other sites
Posted (edited)

Some more pertinent information:

1. I have been using an AA-Transparency setting of 4x Supersample with AA-Mode set to "Enhance the application setting" and AA-Setting of "None" inside NVIDIA control panel.

2. My P3D in game AA setting was set to 4xMSAA

3. If I set the P3D in game AA setting to 4xSSAA or higher, the night lighting issue in the 777 cockpit is 85-100% gone (At the heavy expense of in game FPS, stuttering views, etc)

4. However, at 4xSSAA or higher, the rest of my cockpit textures become blurry (in the same way mipmap blurred out textures in my cockpit)

 

Some questions:

1. Should my NVIDIA control panel AA setting be set to Enhance Application Setting or Application Controlled?

2. If set on "Enhance Application Setting", I have settings of 2x, 4x, and 8x for the Nvidia AA setting mode. Does this correlate to the amount it'll enhance my P3D AA setting? (4xMSAA in game and 2x Nvidia setting equates to 8xMSAA in game?.....or am I completely wrong?)

3. Would you guys please take a look at the screenshots of my NVIDIA Control Panel settings in the link below? :)

https://drive.google.com/open?id=17VjXUUi5ncJLlSkrFFDjE2Bd7j7DjSv6

(they are .png files, please let me know if you cannot open them and I can re-save as .jpeg)

Edited by jeno26

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now