Recommended Posts

Im using a Logitech Extreme 3D Pro joystick and have been for years with FSX and Windows 10, Last time i flew with it was Tuesday night and it was working perfectly fine. Since then ive touched nothing and only changes to FSX was uninstalling World of AI then on thursday when i sit down to fly, the joystick wont work.... Windows sees the device in Device Manager and in hardware and devices and i can even check and adjust its calibration but FSX doesnt see it, the only options in FSX controls are Mouse Look and Mouse yoke. ive tried changing power settings for the computer and individual usb ports, tried getting the latest drivers from logitech's website for the Extreme3D Pro, and tried a completely fresh FSX installation but still no joystick. im at a loss and hoping anyone has any experience or tips i can try to get it working...i bought this joystick only 2 months ago to replace my other aging extreme 3D Pro which has worked for years with no issue.

 

thanks in advance.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Backup your fsx.cfg file (without FSX running) and then delete the original and start FSX and allow it to rebuild the .cfg file. If it all works, re-apply any tweaks you made to the file. If it doesn't work, just delete the new file and restore the backup.

Share this post


Link to post
Share on other sites
3 hours ago, vortex681 said:

Backup your fsx.cfg file (without FSX running) and then delete the original and start FSX and allow it to rebuild the .cfg file. If it all works, re-apply any tweaks you made to the file. If it doesn't work, just delete the new file and restore the backup.

tried that before a fresh reinstall and it didnt work, joystick still doesnt show up in crontrols

Share this post


Link to post
Share on other sites

Have you tried CTRL+K  (Joystick on/off)?  In the FSX/Controls section...have you tried resetting defaults?

Share this post


Link to post
Share on other sites

Considering your old E3DPro was just old but not malfunctioning, and new is just new and therefore better tighter. What about plugging your original E3DPro back in, see if it is properly detected and working in FSX, then plug your new one in (same USB port) see if the results have improved,  it wouldn't be the first time new hardware has had an electronic component failure.

Edited by Jethro

Share this post


Link to post
Share on other sites

tried the control + K and even resetting everything in the controls settings to default.

Ive tried the old E3DPro in each usb port, restarting FSX each time and even it isnt detected but still recognised by the computer. ive even tried uninstalling and reinstalling the device and drivers multiple times. ive even tried FSX in compatibility for windows 7 and as Administrator and still nothing

Share this post


Link to post
Share on other sites

Did you check your anti-virus program and make sure nothing is in quarantine?  You will have to do this for Windows 10 Defender - Search Windows Security>Virus & Threat Protection>Threat History.  Windows Defender just loves to remove anything and place the file in quarantine.  Same goes with any anti-virus or anti-malware program you have installed.  When you installed/reinstalled the joystick driver, it probably quarantined something.

You state you tried starting FSX as Administrator.  This is not enough.  Right click FSX.exe, select Properties, Click on Compatibility tab, and then make sure fsx starts up for all users.

Share this post


Link to post
Share on other sites

Checked Windows Defender and Malwarebytes, nothing detected or quarantined in the last month. yes i tried starting fsx as admin but ive also set the compatibility and run as admin in the properties for all users. not sure if it helps but i also tried setting permissions to full control for all users but still nothing.

Today i tried installing FSX to my main C drive instead of a second drive and yet again nothing. i can confirm the joystick works on the computer, tested with X-Plane Demo and i had full control so the problem somehow lies with FSX. 

Share this post


Link to post
Share on other sites
45 minutes ago, DominusLux said:

tested with X-Plane Demo and i had full control so the problem somehow lies with FSX. 

This is why I think it is a permissions issue.  It is the only thing that makes sense.  I have a Microsoft Account and, in my Users Account I have the option to use my Microsoft Account or the local account.  I decided to change to the local account (or vice-versa.  Cannot recall).  When I changed accounts, all of my files suddenly went to read only.  Nothing was working properly.  I tried to remove the read only from all of the files but could not.  I went back to my previous user account and all was well again.  You might say this could never happen to you as the program was working great one night and not the next night and you did nothing to your computer.  Microsoft has a way of changing things when you are not looking with their Windows updates.

Another thing to try is to go to the standard.xml and rename it to standard.off, restart fsx and let it rebuild.  Standard is located in your user account/AppData/Roaming/Microsoft/FSX/Controls.

Share this post


Link to post
Share on other sites

i agree, i feel like something happened with windows and fsx and messed with something. ive checked the permissions and they seem fine, set full controll for every group on the list and even added my own user which is a microsoft account, i dont have local account and still no luck.

i also made the standard.xml rebuild and still nothing.

Share this post


Link to post
Share on other sites

The solution that worked for me was changing a few steam settings as I had purchased FSX through them. In the top left go to Steam->Settings->Controller->General Controller Settings and deselect everything. Then simply close out. Restart FSX and if you go to Controllers in the game under Settings your joystick should be there.

Share this post


Link to post
Share on other sites
17 hours ago, cmwest3 said:

The solution that worked for me was changing a few steam settings as I had purchased FSX through them. In the top left go to Steam->Settings->Controller->General Controller Settings and deselect everything. Then simply close out. Restart FSX and if you go to Controllers in the game under Settings your joystick should be there.

you, good sir, are my savior. that actually worked!! never considered those settings before, perhaps i should have mentioned it was steam edition. thank you so much, now i can get back to my flying addiction xD

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now