Jump to content

Sign in to follow this  
odaber

p3d v4.4 default airplanes will not load

Recommended Posts

When starting P3D v4.4 after updating v4.4 from 4.3 Client and content, I get the following Message: "Vehicle initialization has failed for: F-22 Raptor-525th Fighter Squadron. You will now be placed in vizualization-only mode". I have nailed my problem to the New Client-part after many ways of settings and trials. Client for v4.4 simply won't load any default airplanes. Elaine, please help! i have tried without any success Your tips here:

With regards

Share this post


Link to post

Hi there,

What is the airplane saved for the scenario that you are trying to load? is it one of the Textron Aircraft that have been removed (King Air, Carenado Bonanza A36, etc.) if it is, the reason for your error is because these were models were removed P3D 4.4 as requested by Textron.

To fix your problem just load the scenario, change your vehicle to another aircraft (F-16 for example) and save your scenario.. next time you load it the error message will be gone.

All the best,

S.

Share this post


Link to post

Thank's for the reply. Not any of my over 100 planes will load. They are situated as they were in v4.3 simObjects/Airplane-folder. But they have simply disapeared from my list in the game 4.4.

Edited by odaber

Share this post


Link to post

I just had a similar problem. The window showing the selected aircraft stayed completely white and when I pressed OK the P3Dv4.4 froze. Had to kill it with the Task Master, rebooted the PC and tried again. All was ok and I hope it will stay like that.

 


Jürgen Martens

Share this post


Link to post

The folder is complete with all my airplanes i simobjects/airplanes intact as in v4.3. Only some helicopters, avatars and bought planes are shown in the catalogue.

Share this post


Link to post

Here You are:

[Entry.0]
PATH=SimObjects\Airplanes
TITLE=Default Airplanes
ACTIVE=true
REQUIRED=true
[Entry.1]
PATH=SimObjects\Avatars
TITLE=Default Avatars
ACTIVE=true
REQUIRED=true
[Entry.2]
PATH=SimObjects\Rotorcraft
TITLE=Default Rotorcraft
ACTIVE=true
REQUIRED=true
[Entry.3]
PATH=SimObjects\GroundVehicles
TITLE=Default Ground Vehicles
ACTIVE=true
REQUIRED=true
[Entry.4]
PATH=SimObjects\Boats
TITLE=Default Boats
ACTIVE=true
REQUIRED=true
[Entry.5]
PATH=SimObjects\Animals
TITLE=Default Animals
ACTIVE=true
REQUIRED=true
[Entry.6]
PATH=SimObjects\Misc
TITLE=Default Misc
ACTIVE=true
REQUIRED=true
[Entry.7]
PATH=SimObjects\Submersible
TITLE=Default Submersible
ACTIVE=true
REQUIRED=true
[Entry.8]
PATH=SimObjects\Weapons
TITLE=Default Weapons
ACTIVE=true
REQUIRED=true
[Entry.9]
PATH=SimObjects\Countermeasures
TITLE=Default Countermeasures
ACTIVE=true
REQUIRED=true
[Entry.10]
PATH=SimObjects\AI Airplanes
TITLE=AI Airplanes
ACTIVE=true
REQUIRED=true
[Entry.11]
PATH=SimObjects\UT2 Aircraft
TITLE=UT2 Aircraft
ACTIVE=true
REQUIRED=true

Share this post


Link to post

Ok the default airplanes entry is there, have you edited this file before? I see UT2 there.

If so maybe the encoding is now wrong, try using notepad plus to re-save the file.

Another possibility is directory security, you mentioned that avatars and helicopters are showing, compare the NTFS security of the Airplanes folder with the Avatars folders.

Another test would be launching Prepar3d as administrator to see if you can see the selectable airplanes.

Regards 

Simbol 

Share this post


Link to post

99 times out of 100 these errors are caused by typos in an edited configuration file. Are you sure that those last two entries have the correct folder names? For example, extra spaces etc..

Share this post


Link to post

In my SimObjects.cfg I notice that entry 0-9 has "default" in the beginning of the title. The folders in my SimObjects-folder have no default in their names. There were the same in 4.3 with no problems. May this be a cause in 4.4?

Share this post


Link to post
51 minutes ago, odaber said:

In my SimObjects.cfg I notice that entry 0-9 has "default" in the beginning of the title. The folders in my SimObjects-folder have no default in their names. There were the same in 4.3 with no problems. May this be a cause in 4.4?

That is just the title of the Entry for references purposes, nothing to do with your folders.

I wonder if you have an airplane that is not compatible causing the entry to be ignored, can you make a backup of your \Aircraft directory and leave in there only the F22 for example? then launch P3D and check if you see it listed.

If it is, then add one airplane at a time until you find the culprit.

Regards,
S.

Share this post


Link to post

Then why has I no problem with any of my airplanes in v4.3? Besides it's obvious that F-22 default on Egelin not will start by the message "Vehicle initialization has failed for: F-22 Raptor-525th Fighter Squadron. You will now be placed in vizualization-only mode". This alone make me believe that  there is something wrong in the loading of v4.4 itself. I have tried different options and deleted and replaced different airplanes in my Airplanes-folder with no success.

Share this post


Link to post

Because 4.4 is a different product, it could be that one of your default Aircraft was compiled using the FS9 SDK and now it blowed up.

The message you get is only an symptom, it means P3D did not loaded all the Aicraft from the first entry on your SimObjects.cfg file.

Regards 

S.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    14%
    $3,540.00 of $25,000.00 Donate Now
×
×
  • Create New...