michaelth

Autopilot: wild oscillations

Recommended Posts

I have the PC-12 since 2017 and know it quite well. Yesterday, I took it out for the first flight since upgrading from P3Dv4.3 to 4.4: no problem flying by hand, but as soon as autopilot was active it went mad with wild vertical and horizontal oscillations. As always, I trimmed to the desired climb rate and put it on course before I activated the autopilot. Any ideas?

Michael

 

Edited by michaelth

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Precisely, stored flights in cold & dark mode. It seems that the autopilot properly initializes only when the airplane is set to "Ready to Taxi" (Shift-8 menu). I have already opened a service ticket with Carenado.

Michael

Share this post


Link to post
Share on other sites

Hello Michael,

I have this problem with PC-12 and P3D 4.4.  Have you any answer from Carenado?

 

Mark

Share this post


Link to post
Share on other sites

The Carenado sales strategy is: sell and forget.

The reason why the PC12 is one of the best Carenado airplanes is because of Bert and a few other talented enthusiasts how made this encreatable mods.

Don't expect an usefull answer from the Carenado support. The standard reply is: Thank you for your feedback, we are going to check it and include on a future version if a fix is needed as this is the first ticket we received with this issue.

So if you live long enough to wait for an update... 😕

Edited by Raller

Share this post


Link to post
Share on other sites

I have a similar problem with v4.4. All plans are fresh and from PFPX.

On my first flight the navigation was fine with NAV mode enabled with GPS selected. After landing and parking I loaded the next plan.

The a/p could not hold the correct heading in either HDG or NAV modes. Before my third flight I exited and restarted P3D.

This time, just like the first, navigation was fine. Is there a known bug if you fly multiple legs without restarting P3D? I can’t think of any other reason.

Share this post


Link to post
Share on other sites
Posted (edited)

Ray,

before I start a new flight, I always re-start P3D. I have found that the autopilot works as expected with the following steps:

1. save a PC-12 flight in condition "Ready to Taxi" (set with the Shift-8 menu of the PC-12)

2. load this flight and again set "Ready to Taxi".

Setting the PC-12 to "Cold & Dark" causes the autopilot to get wild. I suppose that some internal settings are not updated entering the "Cold & Dark" state.

Michael

Edited by michaelth

Share this post


Link to post
Share on other sites

@michaelth, thanks. Given it was the only time I started a second flight without restarting P3D I’m putting the problem down to that.

I always start from C&D so that isn’t the issue. Something clearly isn’t being reset correctly but it’s not a problem as I’m unlikely to begin a second flight immediately after a previous one.

Share this post


Link to post
Share on other sites

Sorry to pull up an old post, but is this still an issue ?

Is it OK to start P3D and then start a fresh situation in cold and dark ?

I.E. the problem is only for turnaround flights ?

 

Thnx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now