Adrian123

LatestGTN GS capture problems. Xp and FS

Recommended Posts

Default aircraft. B350 P3DV3 and C90 in Xplane 11. Been having problems capturing the GS /LPV both XP and FS with 2.5.12. Either with GUI set to Auto or Manual. When LPV is activated and at correct initial waypoint altutude, the aircraft first climbs then descends violently and never does capture the GS. HSI is displaying correct GS path. Have tried various setups in the configuration with same results. FYI, Loaded the "other guys" latest GTN in FS and shot the same approach using the same settings and worked fine. Could I be omitting something in the setup. Tried everything I can think of. Thank you.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Just flew my standard LPV test approach w V2.5.12.

KTPA, R01L, via PIE at 2600 ft

RealAir Legacy P3DV4.4.

APP mode after glideslope indicators became visible, autopilot flew the approach correctly.

Share this post


Link to post
Share on other sites
2 hours ago, Bert Pieke said:

Just flew my standard LPV test approach w V2.5.12.

KTPA, R01L, via PIE at 2600 ft

RealAir Legacy P3DV4.4.

APP mode after glideslope indicators became visible, autopilot flew the approach correctly.

Well, im sure its something ive done wrong.; I;ll keep trying different settings. Flown 1000's of approaches so its not a pilot thing....could be. 🙂

 

Btw Bert, did you try it in P3DV3 or 4 because v4 works fine. I only see the issue in V3 with different default aircraft!

 

Edited by Adrian123

Share this post


Link to post
Share on other sites
38 minutes ago, Adrian123 said:

Btw Bert, did you try it in P3DV3 or 4 because v4 works fine. I only see the issue in V3 with different default aircraft!

 

V4.4. only... maybe it is a Carenado thing.. they supplied default aircraft models for V3.  :cool:

There are HSI GSI, and NAV GSI needles in the P3D coding list... maybe one or the other was screwed up..

Edited by Bert Pieke

Share this post


Link to post
Share on other sites

Ya Bert. Its just V3 but it's the same with the default aircraft also! . No problem w/V4. No biggy as I rarely use V3 and can use the F1 GTN there.  anyway just kinda wierd.

Share this post


Link to post
Share on other sites
4 minutes ago, Adrian123 said:

Ya Bert. Its just V3 but it's the same with the default aircraft also! . No problem w/V4. No biggy as I rarely use V3 and can use the F1 GTN there.  anyway just kinda wierd.

As they say:  "Never look back... they may be gaining on you.."  :cool:

V4 it is!

Share this post


Link to post
Share on other sites
15 hours ago, Adrian123 said:

Its just V3 but it's the same with the default aircraft also!

Hi,

have you check the RXP log files? I'm wondering whether you're using a P3D3 version for which there is no autopilot support implemented (this is the sole custom hack needed per prepar3D version).

Just let me know if there is any 'oto' mention in the rxpGTN.gau.log file and which version gets reported in this case.

Share this post


Link to post
Share on other sites

Jean-Luc, No mention of "oto" in the log files in. All the aircraft are complete default aircraft, no mods. P3DV3: 3.4.22.19868

19/02/14 14:33:32.495 04424 -    ] # rxpGTN.dll version 2.5.12.0
19/02/14 14:33:32.495 04424 INFO ]

-I want to retract the original XP statement. It was just the known "Certain" aircraft. All else is fine.

 

Share this post


Link to post
Share on other sites

This P3D3 version is supported. What I'm wondering is the 'behavior' you're describing (nose up then down and dive violently)?!?!?

Share this post


Link to post
Share on other sites
35 minutes ago, RXP said:

This P3D3 version is supported. What I'm wondering is the 'behavior' you're describing (nose up then down and dive violently)?!?!?

Simply put. RXP GTN see's the gs/LPV and activates the APPR mode but  the AP just wont capture it. That certainly acts like the AP of the aircraft and not RXP? But all aircraft?... Could it be a Simconnect issue? BUT, if it were that , why does the F1 GTN work as expected?

-Always been aware if I'm the only one seeing this, its my setup and I'll resolve it. Please Don't waste too much time on this Jean-LUC.  thank you

 

Edited by Adrian123

Share this post


Link to post
Share on other sites

- New observation. V3, The moment the GTN activated the APPR mode, the AP "ALT" disengages. Can that work and why would it? That's seem to be the issue?

-V4 , same aircraft and approach doesn't deactivate the ALT.

Edited by Adrian123

Share this post


Link to post
Share on other sites

the APPR mode is just 'triggered' using the standard FltSim key event 'KEY_APPR_HOLD_ON'. It might be this aircraft is not pleased with another gauge changing its modes underneath.

This is one of the reasons latest update has this 'command' sent only when you select the corresponding AFMS option, otherwise, it won't do it and you can then manually ARM any autopilot mode you prefer.

Can you confirm you have set "AFMS Engage Autopilot APPR" enabled? What about disable it?

Share this post


Link to post
Share on other sites
12 minutes ago, RXP said:

Can you confirm you have set "AFMS Engage Autopilot APPR" enabled? What about disable it? 

Yes and it still disconnects the ALT. Both enabled and disabled.

Edited by Adrian123

Share this post


Link to post
Share on other sites
On ‎2‎/‎14‎/‎2019 at 10:33 AM, Adrian123 said:

- New observation. V3, The moment the GTN activated the APPR mode, the AP "ALT" disengages. Can that work and why would it? That's seem to be the issue?

-V4 , same aircraft and approach doesn't deactivate the ALT.

I'm having the exact same problem with GNS530 V2. Doesn't matter if "AFMS Engage Autopilot APPR" is enabled or not.

Share this post


Link to post
Share on other sites

@Adrian123 is this also happening with v2.5.13?

@Spug Do you use the latest GNS v2.4.8? You might want to cross check the RXP log files (see User's Manual for file/path). Each file header (1st line) prints the version number.

Share this post


Link to post
Share on other sites

Yes, using GNS v2.4.8 Had recently upgraded to that version.

Share this post


Link to post
Share on other sites

Hi,

Ok this is starting to make sense and I can see there is a 'hidden' bug in managing these 'AFMS' settings which can lead to a whole cascade of issues. Evidently this can affect the A/P but other things as well.

We're working on a new update since last version and there will be a fix to this too. I'm sorry for the inconvenience in the meantime.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now