Sign in to follow this  
ols500

E-Jets Weird elevator problem

Recommended Posts

Hi I purchased both the 170/190 & 175/195 packages from feel there. It takes 180knots to rotate and the aircraft feels sluggish. Is there any fixes?

 

-Ollie

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

This may sound like a dumb question, and apologies if you already know this, but have you checked the fuel and payload prior to takeoff? Also have you set an amount of pitch trim (I don't have the products, but in my simming experience, most aircraft benefit from some amount of nose up trim..)

Share this post


Link to post

Ok, I'll try a re-install. 

1 hour ago, HighBypass said:

This may sound like a dumb question, and apologies if you already know this, but have you checked the fuel and payload prior to takeoff? Also have you set an amount of pitch trim (I don't have the products, but in my simming experience, most aircraft benefit from some amount of nose up trim..)

Yes I have checked the gross weight is under the limit, so all good there. 

  • Like 1

Share this post


Link to post

Does any owner of the E-Jets v2 (so 175 and 195) know if it simulates ATTCS (this is where if one engine fails, the other engine "overboosts" above 100% normal power)? 

Share this post


Link to post

No, It doesn't simulate ATTCS. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this