Jump to content

Sign in to follow this  
blr0108

WARN: unknown version, ERROR: trainer not found

Recommended Posts

Hey all,

I'm trying to get the GTN 750 working for the first time and seem to be hitting a wall.  Black screen. 

I suspect I don't have the right version of the trainer installed, but I'm unsure how to acquire v6.50.1.

Logs:

19/06/28 16:09:50.983 05340 -    ] # rxpGtnSim64.dll version 2.5.18.0
19/06/28 16:09:50.982 05340 INFO ] 
19/06/28 16:10:22.961 05340 WARN ] unknown version: C:\Program Files (x86)\Garmin\Trainers\Packages\GTN\bin (0xce644339 0xdd9b40fe 0 0xbaa0b7d1 0xfe48c6ac 0x4fcd80b6 )
19/06/28 16:10:22.963 05340 ERROR] trainer not found

According to the RXP release notes, the latest supported trainer is v6.50.1.  I've been unable to find a place to download this specific version.  The installer on the Garmin site is currently showing GTN Trainer v6.62.0.

After lots of searching, I've seen plenty of posts related to trouble with antivirus and admin related privilege settings, but none that I've seen so far mention the inability to obtain the v6.50.1 trainer.

Any ideas?  Is it the version, or am I barking up the wrong tree here?

Thanks!

Share this post


Link to post
Share on other sites

I'm not sure what the problem is since I can't get it installed myself and waiting for support. But on the other hand did you notice the last few rules in the release note of 2.5.18?

Quote

Please note: if you were running the simulator as-admin or if you're experiencing a Black Screen problem:
Running the simulator as-admin was preventing the trainer from running as a normal user afterward.
After installing this update, running the simulator as-admin just once more fixes the Windows access rights permanently.

Does any of that help you at all?

Share this post


Link to post
Share on other sites

No help, I'm afraid.  I had seen that post and already tried that one.  Thanks!  Good luck friend.

Share this post


Link to post
Share on other sites

Try to install an older version of the Garmin trainer, instead. I just reinstalled my system today, and thus also installed the GTN again. But it couldn't download the Garmin trainer and it only showed a black screen in the cockpit (even after having installed the Garmin trainer 2400 manually). So I went to the Garmin site and found an older version 6.21.1 ( https://www8.garmin.com/support/download_details.jsp?id=9256 ). Sure the AIRAC is even older on that version. But my GTN works.

Share this post


Link to post
Share on other sites
1 hour ago, Asdiroc said:

Try to install an older version of the Garmin trainer, instead. I just reinstalled my system today, and thus also installed the GTN again. But it couldn't download the Garmin trainer and it only showed a black screen in the cockpit (even after having installed the Garmin trainer 2400 manually). So I went to the Garmin site and found an older version 6.21.1 ( https://www8.garmin.com/support/download_details.jsp?id=9256 ). Sure the AIRAC is even older on that version. But my GTN works.

You sir you saved my day!

Uninstalled the 2400 and installed the one from your link and believe it or not but it works like a charm. Maybe with older AIRAC but who cares, it's the first time I see a lit screen in 72 hours of struggle lol.

Share this post


Link to post
Share on other sites

You should be able to copy the content of the "Databases" folder from version 2400, into the "DB" folder from the 6.21. Then it should give you the 1809 navigation database in your GTN. Not sure if that leads to problems somewhere along the way, though.

Share this post


Link to post
Share on other sites

I just a complete reinstall of my OS and XP11....  and attempting to download the trainer associated with the GTN, the file is not on their Garmin servers....as I get a 404 download error during the RXP install.

@RXP any ideas?  Do you have a backup link for the trainer?


|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites
51 minutes ago, ryanbatcund said:

any ideas?

Ryan,
There is a link two messages up in this topic.  Did you try it?  The link worked for pietergoris.  I do not need it but just tried and the DL link works for me.


Frank Patton

Gigabyte GA-Z97X-Gaming 7 MOB; i7 4790 4.4Ghz; 16gb DDR3 2300; MSI GTX970 4gb Gaming 100ME, Coolermaster Pro 5 case, Corsair H100i

Former USAF meteorologist and ground weather school instructor; AOPA Member #07379126

There is no limit to what a man can do or where he can go if he doesn’t mind who gets the credit! - Benjamin Jowett

 

Share this post


Link to post
Share on other sites

Hi,

There is new Trainer version just released and we are working on this.

There is always a delay between their release and our update obviously, because we need to work on this.

In the meantime, there is the older GTN Trainer 6.21 working:

https://www8.garmin.com/support/download_details.jsp?id=9256 

Also, you might want to try this link for the GTN 6.50.1:

http://securemanifest.garmin.com/avtrainer/GarminTrainerSetup_2.3.1.0.exe

 


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Thanks all.  I was at least able to get trainer version 6.21 installed and functioning.

Still no luck installing v6.50.1, however. 

This link to the GarminTrainerSetup_2.3.1.0.exe does download the installer properly, but it prompts to update the installer early in the process.  I haven't been able to figure a way to ignore the update.  Continuing installs the latest version of the installer and trainer.

I may try copying the DB folder of the new trainer as suggested above by Asdiroc as a stop gap solution.  Good idea, sir.

I look forward to an updated GTN plugin from RealityXP.  😀  Good luck with the update!

Share this post


Link to post
Share on other sites

 


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

This was the missing piece of the puzzle.  I've now got v6.50.1 installed and the plugin is functioning.  Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...