Jump to content

Sign in to follow this  
Ray Proudfoot

P3D v3 crash but no Event Viewer entry

Recommended Posts

I have both P3D v3 and v4. This particualar problem has never occured in v4, only v3. Version is v3.4 and I'm only using it to fly FS Labs Concorde. On a flight from Heathrow down to Tenerife P3D just shut down. No warning and no entry in Event Viewer which is really weird.

My aircraft was no closer than 100nm from land so I cannot see how a bad airport can be responsible. No-one else in the FSL's forum has mentioned this so it seems to be something unique to my system. But what? I'm reasonably experienced at sorting out problems but without a clue in Event Viewer it's hard to know where to start.

I did have FSUIPC running with autosave and reloaded the last saved scenario and completed the flight. Baffling.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites
22 minutes ago, Ray Proudfoot said:

I did have FSUIPC running with autosave and reloaded the last saved scenario and completed the flight. Baffling

Autosave is known to cause crashes and disabling it has fixed problems for many.

You can download and run AppCrashView and it might show a faulting module.  A link is in the AVSIM CTD Guide but here's one here too - https://www.nirsoft.net/utils/app_crash_view.html


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites
17 minutes ago, Jim Young said:

Autosave is known to cause crashes and disabling it has fixed problems for many.

You can download and run AppCrashView and it might show a faulting module.  A link is in the AVSIM CTD Guide but here's one here too - https://www.nirsoft.net/utils/app_crash_view.html

Thanks Jim. That would be odd given how long both FSUIPC and FSL Concorde have been around. Pete always says the autosave routine is the same as the user pressing ; and entering a name.

ACV may show something Event Viewer doesn’t l


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

There is probably something else interacting with Autosave as it does not cause an issue for all.  But some have had constant crashes with it on and, when they disable, the crashes go away.  Maybe an old version of FSUIPC.  Dunno.

 


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

I’m pretty sure I’m up to date with FSUIPC4 but will check tomorrow. It’s something unique to P3Dv3 but what. Concorde seems unlikely given it’s a mature product. I might try running without Ultimate Traffic Live as that does not run in v4. Maybe there’s a bad texture somewhere.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Absolutely nothing showed up in App Crash Viewer or Event Viewer. FSUIPC4 is up to date. Bizarre that an application can crash and be undetected by the OS. Ho hum. :sad:


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

I started a flight from Heathrow to Lisbon in Concorde. Got as far as the English Channel north of the Channel Islands before P3D v3 crashed. No Event Viewer or App Crash entry.

From reading LM advice on this it can be caused by scenery. I do have a lot of scenery ported from v4 which still works in v3 so disabled all entries in Europe. I also cleared shaders folder and didn't run UT Live.

Resumed flight was fine. I need several  more before I can be sure the problem has gone.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Strange you have no Event Viewer entry.  Are you going to Custom Views>Administrative Events?  It should show that your AppHang B2 indicating it hung up or froze.  It could be incompatible scenery or textures from scenery or AI aircraft.


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites
2 minutes ago, Jim Young said:

Strange you have no Event Viewer entry.  Are you going to Custom Views>Administrative Events?  It should show that your AppHang B2 indicating it hung up or froze.  It could be incompatible scenery or textures from scenery or AI aircraft.

If that’s the very top selection on the left hand pane then yes, that’s where I’m looking. Zero warnings, errors or critical events in last 24 hours.

Personally I suspect scenery as this type of problem never happened on my previous PC with FSL Concorde installed. That build had only P3D v3 so all scenery was compatible. I’ve copied my v4 scenery.cfg over and removed v4 only scenery but perhaps missed some.

Time to strip down the scenery.cfg. Once I’ve had 3 clean flights I’ll add UT Live back in.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

A problem presented to the GPU can come out with no entry. So the suspect would probably be something in the scenery or static aircraft or AI traffic or vehicle coming into range.

  • Like 1

Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites

@SteveW, that makes sense. In both cases I was nowhere near an airport. Supersonic over ocean a fair distance from land. It could be UT Live but it’s going to need repeated tests to confirm that.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Completed a EGLL-LPPT flight this morning without a crash. No UT Live running. I’ll try the return shortly and report back.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

I have UTLive but have not suffered any crash since purchasing a year or two ago.  I have not installed any of the AI schedules, etc.  Just the basic product with no more additions.  I do know from previous experience with MyTrafficX that AI can crash your simulator when they near your aircraft because of incompatible textures.  I used Process Monitor to pin down the cause of that crash.  In the AVSIM CTD Guide I have set up a procedure on how to set up the investigative tool, Process Monitor, so that it only shows what's happening with P3D and P3D addons.  Nothing else.  It might provide you with a clue if you can shutdown Process Monitor immediately when P3D crashes and you check the system time too so that you are not searching more than 2-3 minutes (a lot of entries are made just in one second!).  It will show you what was loading around the time of the crash. For me to identify my crashes, I saw that MyTrafficX was loading aircraft for at least a minute near the same spot every time I flew that particular flight plan.  I disabled MyTrafficX and the crashes stopped. Turned out to be USAF Military AI not compatible.  For setup, goto page 18 of the AVSIM CTD Guide.

Jim

  • Like 2

Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

This problem is infuriating. This morning, with no Ai traffic, I had a clean flight down to Lisbon. This afternoon, with the same settings I returned to Manchester. Everything was fine until descending over Liverpool with around 25nm to go. I was looking left and right and then - the dreaded crash and nothing in Event Viewer or App Crash.

So we can discount Ai since there wasn’t any. I loaded an autosave well before the crash position and flew it again including left / right view changes around the point where it crashed before. No problems.

I know it sounds odd but I suspect it might be related to graphics drivers. FS Labs recommend 376.33 which are now so old they aren’t compatible with a 1080Ti. So I’ve loaded the latest ones, forget the version number.

The FSL Spotlights utility which was payware is now freeware and it would crash P3D unless compatible drivers were used. So I uninstalled Spotlights in order to use relatively recent drivers for v4.

I will try Process Monitor as it’s the only thing that might capture the cause of the problem. With minimal scenery and no Ai there really should not be any problems. I rarely get them with v4. Maybe there’s some incompatibility with what is now an old aircraft in P3D and Windows 10. I’ll ask if others are having problems with Concorde in W10 over at FSL.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

Sorry to hear you are still having issues Ray.  In the AM, you might want to rename the dll.xml in the same folder as your scenery.cfg by renaming it dll.off. This is the new LM default location.  The former default location has the dll.xml located in the same folder as the P3D.cfg.  You should also rename this to dll.off.  This will make sure none of your modules are loaded.  Modules get corrupted a lot.  It will disable fsuipc so you won't be able to use the save function in FSUIPC.  But you are investigating.  It is located in the dll.xml located in the same folder as your P3D.cfg.  ASP4 as_connect module is located there too.  Would be nice if they could move their entries to the new default.  Do not try to merge these files into the one located in the same folder as the scenery.cfg.  I tried that once and had major issues starting up and running P3DV4.  Suspect it may conflict with Windows Registry entries.  The dll.xml in the same folder as your scenery.cfg will be created when you restart P3D.  The one in the P3D.cfg folder will not.

You might also want to try to remember what you installed before these problems started happening, if anything.

If that does not fix the problem, then I hope you will try out the Process Monitor to see what is loading.  I wish there was an easy fix but everyone has different add-ons and computers.  I see you have almost the same system as mine.  Good selections 😎 .  I plan on moving to 32GB's of memory but want to see what 16GB's does when running MSFS.  Right now I barely use memory and it will be a long time before I even get to 16GB's.

Jim

 


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...