Jump to content

Sign in to follow this  
captain420

My aircraft is black at night in P3D v5

Recommended Posts

Posted (edited)

At certain airports like FB's KSFO, Flytampa's Dubai, and a few others. Whenever I set the time to night, my aircraft is like almost completely black with on details at all. This wasn't the case before. It really breaks the immersion when trying to set up a night time flight because of this. Is this an issue on LM's part of with the 3PD? I have tried with the PMDG 747, 737, and FSLabs A320. So it's not that. The cause is coming from either P3D v5 itself or the airport needs to be updated? But I already have Flightbeam's latest KSFO version for P3D v5. I thought that was suppose to be P3D v5 ready already?

This is at T2G VHHH

image.png

In the pic below, certain AI aircrafts are showing up fine though.

image.png

Edited by captain420

Aaron Vinci

----------------

Intel i9 10900K (no overclock) / Windows 10 Pro 2004 64 bit / 64GB DDR4 3200MHz CL 16RAM / EVGA NVIDIA GTX 1080 FTW 8GB RAM / 1TB NVME SSD (OS Drive) / 2TB SATA SSD / 4TB SATA HDD / 850watt PSU

Share this post


Link to post
Posted (edited)

That right there is a case of dynamic lighting either not turned on in the UI of either P3D or Flighbeam manager. I had this at a few FlyTampa airports in v4.5 and turned out I did not have the FlyTampa Libraries properly installed in the sim. 

Also: http://www.prepar3d.com/forum/viewtopic.php?f=6312&t=137784

 

Edited by B777ER

Eric 

 

 

Share this post


Link to post

agree with 1st reply.  If that doesn't work you have to make sure that your sceneries are kept updated.  Most of the payware makers had to reissue lighting fx files due to LM changes.  


9700k | Maximus XI Hero| 32gb DDR4 3000 | 1080Ti 11GB | 1tb EVO Plus 970 and 500GB M2+3TB HDD | 43" Samsung X60R 4k and 2  22" monitors | Corsair RM1000x |  240MM AIO.| MFG Crosswind | T16000M Stick | Saitek Throttle Quad | Skalarki MCDU and FCU | Saitek Radio Panel

Share this post


Link to post
Posted (edited)

What I don't understand is why certain AI planes don't appear black while others look fine? It can't be the scenery then if that's the case. I assume it would be that certain AI models don't have PBR textures? I am using AIG-OCI for my AI btw, and made sure all the models are up to date. Yet from the picture above, you can see some are lit up correctly while others are black. However, all the planes that I fly in appear black. The issue is quite confusing. I have updated my FlyTampa libraries already. OMDB has this issue, but Kai Tak doesn't.

I will check my P3D settings later to see if I have dynamic lights enabled.

Does dynamic reflections need to be on? I believe I have that set to off.

UPDATE: I do have Dynamics light enabled for FB KSFO v2.0.8 and also in P3D. Is this how it's suppose to look at VHHH?

image.png

Edited by captain420

Aaron Vinci

----------------

Intel i9 10900K (no overclock) / Windows 10 Pro 2004 64 bit / 64GB DDR4 3200MHz CL 16RAM / EVGA NVIDIA GTX 1080 FTW 8GB RAM / 1TB NVME SSD (OS Drive) / 2TB SATA SSD / 4TB SATA HDD / 850watt PSU

Share this post


Link to post
1 hour ago, captain420 said:

I assume it would be that certain AI models don't have PBR textures?

PBR textures are not required to light up the aircraft (AI or otherwise).  Dynamic Reflections are not required either. 

Are you running T2G VHHH V2 for P3D V5?

Here are some snapshots of T2G VHHH V2 with Dynamic Lights enabled in P3D.  T2G VHHH V2 does appear to have a configuration panel so it seems to be supporting Dynamic Lights by default.  The AI aircraft I'm using are all from UTLive v1.2 that I adapted to run in P3D V5 (until UTLive V2.0 arrives).

Some aircraft stalls/gates have more lighting than others, but all the AI aircraft are responding to Dynamic Lights correctly.

T2G VHHH V2, PMDG 737NGx, all graphics settings maxed out, 100% AI traffic (commercial and GA):

uc?export=view&id=1SG3u8UBYWRlkiayjHUGUQ

 

uc?export=view&id=1ke03Nar8ZyLYQbJGxGSJS

Cheers, Rob.

Share this post


Link to post

Rob, I am using T2G VHHH v2.2. I have dynamic lighting enabled in the sim. Strange.


Aaron Vinci

----------------

Intel i9 10900K (no overclock) / Windows 10 Pro 2004 64 bit / 64GB DDR4 3200MHz CL 16RAM / EVGA NVIDIA GTX 1080 FTW 8GB RAM / 1TB NVME SSD (OS Drive) / 2TB SATA SSD / 4TB SATA HDD / 850watt PSU

Share this post


Link to post

Hmmm ... are you absolutely sure it's T2G VHHH V2?  Your ground textures are very different with what appears to be baked in lighting.  The latest version of VHHH V2 I downloaded from my simmarket account is 1.2.0.0 so not sure where you got V2.2 from?

There is a WF Scenery VHHH and I think an ImagineSim VHHH also.

Cheers, Rob.

Share this post


Link to post

Go to Inibuilds website and d/l the dynamic lighting v2 for T2G VHHH. It's much better.


Eric 

 

 

Share this post


Link to post

Interesting ... your article link says available in SimMarket and I just downloaded from SimMarket last night and there is no V2.2 designation indicates V2.1 https://secure.simmarket.com/taxi2gate-vhhh-v2-hong-kong-international-airport-vhhh-p3d-v4-v5.phtml

The version number on the installer .exe is V1.2.0.0

Don't know what to say, very strange indeed.

Cheers, Rob.

 

 

Share this post


Link to post
Posted (edited)
16 hours ago, B777ER said:

Go to Inibuilds website and d/l the dynamic lighting v2 for T2G VHHH. It's much better.

Will try it out.

What I don't understand is why certain planes are lit up at night while others aren't. Makes no sense to me. It seems that dynamic lights are working at the airport, however some objects don't seem to have updated textures to support it from what I can see in the screenshots I posted.

UPDATE: Installing the dynamic lights from iniBuilds seems to have fixed most of the problems, however there's still some AI aircrafts that are not lit up. I have posted a screenshot below. This could be a problem with some of the models or textures in AIG-OCI.

image.png

Edited by captain420

Aaron Vinci

----------------

Intel i9 10900K (no overclock) / Windows 10 Pro 2004 64 bit / 64GB DDR4 3200MHz CL 16RAM / EVGA NVIDIA GTX 1080 FTW 8GB RAM / 1TB NVME SSD (OS Drive) / 2TB SATA SSD / 4TB SATA HDD / 850watt PSU

Share this post


Link to post

Something is serious wrong. I have tried deleting my shaders folder, and Prepar3D.cfg, made sure that dynamic lighting was both enabled in P3D and for my Airports. This is at ImagineSim WSSS.

image.png


Aaron Vinci

----------------

Intel i9 10900K (no overclock) / Windows 10 Pro 2004 64 bit / 64GB DDR4 3200MHz CL 16RAM / EVGA NVIDIA GTX 1080 FTW 8GB RAM / 1TB NVME SSD (OS Drive) / 2TB SATA SSD / 4TB SATA HDD / 850watt PSU

Share this post


Link to post

There's no nav lights or logo lighting on that plane either. Looks like an effects issue related to the plane. Do the taxi and landing lights light up the ground when you are taxiing?

Share this post


Link to post

That's me in the PMDG 747. yes the nav lights work and all. Just when you view the plane from external view at night, it's not lit up and appears black. I can't fly at night because of this issue and I can't seem to fix it.


Aaron Vinci

----------------

Intel i9 10900K (no overclock) / Windows 10 Pro 2004 64 bit / 64GB DDR4 3200MHz CL 16RAM / EVGA NVIDIA GTX 1080 FTW 8GB RAM / 1TB NVME SSD (OS Drive) / 2TB SATA SSD / 4TB SATA HDD / 850watt PSU

Share this post


Link to post
Posted (edited)

If you go to fsdt kordv2 almost all planes are lit, if you go to kmsp flightbeam, none are lit. This is using oci. So it looks like a airport issue.At KMEM fsdt all are dark and also at KPHX FBeam.

It looks like the only airport I have that is truly v5 ready is  kord. It is also my latest purchase. So out of all my airport purchases only one is up to snuff.

Edited by rickgo

I5 9600k@ 4.8ghz    rx580 limping-along   2x 1080P Monitors

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,075.00 of $25,000.00 Donate Now
×
×
  • Create New...